LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-03-2008, 03:24 PM   #1
attaro
LQ Newbie
 
Registered: Dec 2008
Posts: 15

Rep: Reputation: 0
kernel panic


When I boot my system (Fedora 7) I get error msg:

VFS: Cannot open root device "VolGroup00/LogVol00" or unknown-block(0,0)
Please append a correct "root=" boot option
kernel panic - not synching: VFS: Unable to mount root fs on unknown-block(0,0)

I've tried sda1 etc to no avail

Any help will be much appreicated
 
Old 12-03-2008, 03:28 PM   #2
baig
Member
 
Registered: Nov 2008
Location: وادی ھنزہ
Distribution: Solaris 5.10, Debian Server 5.2, CentOS 5.6
Posts: 226
Blog Entries: 3

Rep: Reputation: 38
On my old pc

80G.B HDD
384 MB RAM
733 MHz Intel Processor
OS Fedora 8 & w$OS

The same happens on booting it.. and when I reboot it "pressing button" then it boots up very well as if there was never a Kernel Panic.. about three time this happened and I rebooted it and it worked..

I don't know why this happens?....
 
Old 12-03-2008, 03:30 PM   #3
hasanatizaz
Member
 
Registered: Nov 2007
Location: Pakistan
Distribution: Redhat and Debian
Posts: 302
Blog Entries: 1

Rep: Reputation: 34
post your grub.conf or menu.lst
 
Old 12-03-2008, 03:43 PM   #4
attaro
LQ Newbie
 
Registered: Dec 2008
Posts: 15

Original Poster
Rep: Reputation: 0
grub.conf


# NOTICE: You have a /boot partition. This means that
# all kernel paths are relative to /boot/, etc
# root (hd0,0)
# kernel /vmlinuz-2.4.18-0.12 ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-2.4.18-0.12.img
#boot=/dev/sda
default=0
timeout=5
title Fedora (2.6.21-1.3194)
root (hd0,0)
kernel /vmlinuz-2.6.21-1.3194.fc7 ro root=/dev/VolGroup00/LogVol00

Last edited by attaro; 12-03-2008 at 03:44 PM.
 
Old 12-03-2008, 03:52 PM   #5
baig
Member
 
Registered: Nov 2008
Location: وادی ھنزہ
Distribution: Solaris 5.10, Debian Server 5.2, CentOS 5.6
Posts: 226
Blog Entries: 3

Rep: Reputation: 38
#boot=/dev/sda
default=1
timeout=10
splashimage=(hd0,5)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.27.5-41.fc9.x86_64)
--------root (hd0,5)
--------kernel /vmlinuz-2.6.27.5-41.fc9.x86_64 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
--------initrd /initrd-2.6.27.5-41.fc9.x86_64.img
title W$4DMES
--------rootnoverify (hd0,0)
--------chainloader +1



Device Boot Start End Blocks Id System
/dev/sda1 * 1 2607 20940696 7 HPFS/NTFS
/dev/sda2 2608 9728 57199432+ f W95 Ext'd (LBA)
/dev/sda5 2608 6431 30716248+ b W95 FAT32
/dev/sda6 6432 6456 200781 83 Linux
/dev/sda7 6457 9728 26282308+ 8e Linux LVM

So the count starts form 0 there for my 6th partition is referred to as 5th

this is my working Grub of New PC which works fine so compare it...


I am using sda.

Last edited by baig; 12-03-2008 at 03:57 PM.
 
Old 12-03-2008, 04:10 PM   #6
attaro
LQ Newbie
 
Registered: Dec 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Baig, Is this part of your grub.conf file?

Device Boot Start End Blocks Id System
/dev/sda1 * 1 2607 20940696 7 HPFS/NTFS
/dev/sda2 2608 9728 57199432+ f W95 Ext'd (LBA)
/dev/sda5 2608 6431 30716248+ b W95 FAT32
/dev/sda6 6432 6456 200781 83 Linux
/dev/sda7 6457 9728 26282308+ 8e Linux LVM


Grub tells me that initrd /initrd-2.6.27.5-41.fc9.x86_64.img is missing (Error 15)

chainloading +1 is not valid

Thanks
 
Old 12-03-2008, 05:49 PM   #7
baig
Member
 
Registered: Nov 2008
Location: وادی ھنزہ
Distribution: Solaris 5.10, Debian Server 5.2, CentOS 5.6
Posts: 226
Blog Entries: 3

Rep: Reputation: 38
No Man!!!!!

its my fdisk -l part... Sorry, that was to make the point clear about numbering your partition...
 
Old 12-03-2008, 05:54 PM   #8
baig
Member
 
Registered: Nov 2008
Location: وادی ھنزہ
Distribution: Solaris 5.10, Debian Server 5.2, CentOS 5.6
Posts: 226
Blog Entries: 3

Rep: Reputation: 38
# NOTICE: You have a /boot partition. This means that
# all kernel paths are relative to /boot/, etc
# root (hd0,0)
# kernel /vmlinuz-2.4.18-0.12 ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-2.4.18-0.12.img
#boot=/dev/sda
default=0
timeout=5
title Fedora (2.6.21-1.3194)
root (hd0,0)
kernel /vmlinuz-2.6.21-1.3194.fc7 ro root=/dev/VolGroup00/LogVol00
initrd /initrd-2.6.21-1.3194.fc7.img
rootnoverify (hd0,0)
chainloader +1


don't you think this is missing there?

Last edited by baig; 12-03-2008 at 05:58 PM.
 
Old 12-04-2008, 12:53 AM   #9
attaro
LQ Newbie
 
Registered: Dec 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Baig

This line
/initrd-2.6.27.5-41.fc9.x86_64.img
gives me Error 15 - missing file on

and
chainloading +1 is not a valid command


Thanks
 
Old 12-04-2008, 09:38 AM   #10
hasanatizaz
Member
 
Registered: Nov 2007
Location: Pakistan
Distribution: Redhat and Debian
Posts: 302
Blog Entries: 1

Rep: Reputation: 34
you need to re-create initrd with the help of mkinitrd
 
Old 12-04-2008, 09:40 AM   #11
hasanatizaz
Member
 
Registered: Nov 2007
Location: Pakistan
Distribution: Redhat and Debian
Posts: 302
Blog Entries: 1

Rep: Reputation: 34
see in grub its not chainloading. its chainloader
 
Old 12-04-2008, 10:00 AM   #12
judge312
LQ Newbie
 
Registered: Dec 2008
Distribution: fedora,rhel
Posts: 18

Rep: Reputation: 1
try this (one should work )
1. root=/dev/sda6 in kernel options (check fdisk -l )
2. check your lvm (if lvm was configured at installation time).
3. mkinitrd YOUR_KERNEL
4. check raid drivers (if raid drive )
 
Old 12-04-2008, 10:33 AM   #13
baig
Member
 
Registered: Nov 2008
Location: وادی ھنزہ
Distribution: Solaris 5.10, Debian Server 5.2, CentOS 5.6
Posts: 226
Blog Entries: 3

Rep: Reputation: 38
What method you have adopted to edit grub.conf? are you using a rescue media i.e CD, Floppy or what? if yes then reinstall your grub..


Cheers!!
 
Old 12-04-2008, 05:31 PM   #14
attaro
LQ Newbie
 
Registered: Dec 2008
Posts: 15

Original Poster
Rep: Reputation: 0
mkinitrd seems to be solving the problem. However, booting gets stuck on "UNKNOWN KEY PRESSED...."

Thanks a lot
 
Old 12-04-2008, 05:34 PM   #15
hasanatizaz
Member
 
Registered: Nov 2007
Location: Pakistan
Distribution: Redhat and Debian
Posts: 302
Blog Entries: 1

Rep: Reputation: 34
did you press something while booting or have you passed any extra argument?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
upgrading Fedora Core 3 kernel 2.6.9-1.667 to 2.6.26.3 manually+kernel panic error LinuxLovinNoob Linux - Newbie 7 12-17-2008 08:45 PM
kernel panic: try passing init= option to kernel...installation with Red Hat 9 kergen Linux - Hardware 1 09-30-2004 03:28 AM
Kernel panic puts me in a panic theeeg Linux - Software 2 07-31-2004 04:46 PM
kernel panic (narius panic) narius Linux - Newbie 3 06-20-2002 03:56 PM
Kernel panic making me panic! Linux_N0oby Linux - Software 19 05-29-2002 12:31 AM


All times are GMT -5. The time now is 10:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration