LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-22-2005, 05:04 PM   #1
mstep
LQ Newbie
 
Registered: Jun 2005
Posts: 23

Rep: Reputation: 15
kernel panic :-(


I've been running Debian Sarge for around 2 months now kernel version 2.2.20. Today I decided to update the kernel to 2.6.12.5, as it's difficult to get sound for my Vortex 1 card with my current kernel version. I've never updated the kernel before so I read a handy how-to specifically geared towards newbies. Everything appeared fine until I tried to load the new kernel from LILO. A couple of pages or so of text scrolled up the screen and I was pleased with the way things were looking but then I received the message

Quote:
VFS: cannot open root device "303" or unknown-block(3,3)
please append a correct "root=" boot option
kernel panic- not syncing: VFS : Unable to mount root fs on unknown-block(3,3)
I'm completely clueless as to what this means. As such I'm not sure what hardware specifications somebody willing to help would need to know. Any assistance would be greatly appreciated.
 
Old 08-22-2005, 05:29 PM   #2
sundialsvcs
LQ Guru
 
Registered: Feb 2004
Location: SE Tennessee, USA
Distribution: Gentoo, LFS
Posts: 7,183

Rep: Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212
Well, I wish you were running grub right now, instead of LILO.

What has happened is that Linux cannot find the root-filesystem. This is probably because of a parameter that was (incorrectly) given to Linux, by the boot-loader [LILO], viz: root=303.

Linux doesn't know what that means. And it doesn't mean anything. "303" is not a valid device-reference in Linux. It wants something like /dev/hdan...

Boot up the system with a CD-ROM drive, if you can't boot your old system. Check to find out where the root-filesystem is supposed to be. Let's say that it's /dev/hda2. Change lilo.conf and re-run LILO. (Grub doesn't require you to re-run anything, which is one of many reasons why I like that loader much better, but nevermind...)

If you do get a chance to edit boot-time parameters when you restart your machine, look at the parameters for Linux and I think you'll see the incorrect boot=. You might be able to re-type it on the fly.

Last edited by sundialsvcs; 08-22-2005 at 05:31 PM.
 
Old 08-22-2005, 05:48 PM   #3
mstep
LQ Newbie
 
Registered: Jun 2005
Posts: 23

Original Poster
Rep: Reputation: 15
ok first of all thanks for the speedy and helpful response

Luckily I can easily boot my old system so no trouble there. I have opened lilo.conf but can't see anything like root=303. In fact according to lilo.conf root=/dev/hda3. Which is exactly right... I think. However it also says: boot=/dev/hda, with no number on the end. Can I assume this is the problem (I'm fairly sure it should be /dev/hda1)? It seems strange as the error seemed more focussed on the root= option.

I think once this is sorted the first thing I'll do is install grub :S
 
Old 08-22-2005, 09:30 PM   #4
sundialsvcs
LQ Guru
 
Registered: Feb 2004
Location: SE Tennessee, USA
Distribution: Gentoo, LFS
Posts: 7,183

Rep: Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212
Check to make sure what the location should be. It definitely needs to be (afaik), /dev/hdan ... You have to specify the partition. My assumption at this point is still that the problem is with the root= parameter.
 
Old 08-22-2005, 09:36 PM   #5
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
If you can boot up the computer using the rescue disc, typing lilo should fix ur prob. lol...i've actually updated my kernel too many times to mention and had to go back and run lilo again.
 
Old 08-22-2005, 10:13 PM   #6
shotwellj
Member
 
Registered: Jul 2005
Location: Tempe, AZ
Distribution: Slackware
Posts: 66

Rep: Reputation: 15
What filesystem are you using? Is supoprt for that filesystem compliled into the kernel, or as a module? If it is comiled as a module, you'll have to use mkinitrd to create an initial ramdisk.

man mkinitrd

Jacob
 
Old 08-23-2005, 06:25 AM   #7
mstep
LQ Newbie
 
Registered: Jun 2005
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by sundialsvcs
Check to make sure what the location should be. It definitely needs to be (afaik), /dev/hdan ... You have to specify the partition. My assumption at this point is still that the problem is with the root= parameter.
yup. root is /dev/hda3 and lilo.conf states root=/dev/hda3. I added a 1 to boot=hda but to no avail. Exactly the same error

Quote:
Originally posted by bosewicht
If you can boot up the computer using the rescue disc, typing lilo should fix ur prob. lol...i've actually updated my kernel too many times to mention and had to go back and run lilo again.
I can boot my old kernel through lilo easily enough... so no need for a rescue disk? Typing lilo at the terminal brings up the message:

Warning: boot record relocation beyond BPB is necessary: /dev/hda1
Added Linux *
Added LinuxOLD
Added Linux(hda1)

(Note that all three boot options were already there). I'm not entirely sure what that warning means, but could it be part of the problem? It sounds promising...

Quote:
Originally posted by shotwellj
What filesystem are you using? Is supoprt for that filesystem compliled into the kernel, or as a module? If it is comiled as a module, you'll have to use mkinitrd to create an initial ramdisk.

man mkinitrd

Jacob
On my old kernel I'm using ext2. In my new kernel I added support for ext2 and ext3. I'm fairly sure that I didn't compile either as a module... but not 100%. How do I go back and check? I've opened qconf but have no idea where the config file I saved might be. Also I don't have a manual for mkinitrd


Thankyou for all of your help
 
Old 08-23-2005, 07:34 AM   #8
b0nd
Senior Member
 
Registered: Jan 2005
Distribution: Slackware, BackTrack, Windows XP
Posts: 1,020

Rep: Reputation: 45
Hi there,
will you please post the contents of your lilo.conf....

Quote:
Originally posted by mstep
How do I go back and check? I'm fairly sure that I didn't compile either as a module... but not 100%. I've opened qconf but have no idea where the config file I saved might be. Also I don't have a manual for mkinitrd
As far as "config" file is concerned it resides in /boot/ along with System.map, vmlinuz etc. ( i know about slackware and redhat only) moreover many times its a hidden file.
But its there until you don't do "mrproper"

regards
 
Old 08-23-2005, 09:41 AM   #9
mstep
LQ Newbie
 
Registered: Jun 2005
Posts: 23

Original Poster
Rep: Reputation: 15
Gah! I give up. I tried to edit lilo.conf to make LinuxOLD the default kernel as it kept loading the new non-functioning one by mistake, which was annoying. So I changed the line Default=Linux to Default=LinuxOLD, saved the file and ran lilo. I got exactly the same message as before and assumed it was fine. But now when I try to start up I just get the letter L followed by a multitude of "9A9A9A9A9A9A9A".

Once I broke LILO and it stopped at LI, but it was fairly easily fixed in Knoppix. I can't see any way to fix this. I can't find my rescue disk and I can't find an image for it on the net. I'm just going to download the netinst image for the current Debian testing distribution and start again from scratch.

I won't have access to my linux box for a few days after sometime today, so I won't be able to install the new OS until Friday. If there's any other way to fix this I'd love to know- but don't worry if you can't be bothered

Thanks once again for all of your help
 
Old 08-23-2005, 10:50 AM   #10
b0nd
Senior Member
 
Registered: Jan 2005
Distribution: Slackware, BackTrack, Windows XP
Posts: 1,020

Rep: Reputation: 45
try this

This too

regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel 2.4 in Zipslack (Waring: unable to open an initial console | Kernel Panic...) kurtamos Linux - General 2 05-10-2006 01:58 PM
kernel panic: try passing init= option to kernel...installation with Red Hat 9 kergen Linux - Hardware 1 09-30-2004 04:28 AM
Kernel panic puts me in a panic theeeg Linux - Software 2 07-31-2004 05:46 PM
kernel panic (narius panic) narius Linux - Newbie 3 06-20-2002 04:56 PM
Kernel panic making me panic! Linux_N0oby Linux - Software 19 05-29-2002 01:31 AM


All times are GMT -5. The time now is 06:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration