LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-01-2003, 01:51 PM   #1
stupid_guy
Member
 
Registered: Jun 2003
Distribution: mandrake 9.2
Posts: 57

Rep: Reputation: 15
kernel halts, system halts, computer commits suicide


i just newly installed redhat linux 9 a few days ago cos i thought its gonna be cool. But this really sucks.
everytime my kernel reaches this line:
-----------------------------------------------------------------------
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16)
----------------------------------------------------------------------
my computer freezes rock dead. I have 3 questions:
1. is it the apm thats causing the problem?
2. is it the next line (kswap) thats causing the problem?
3. how do i fix it

thanks for reading this...

additional information:
after entering rescue mode, and typing "apm" my computer says no apm support in kernel
but typing in displayapm in "command line" at grub my computer returns sever array of numbers...
my computer is a tower, compaq presario, pentium 4,
 
Old 06-02-2003, 09:54 AM   #2
jpbarto
Senior Member
 
Registered: Mar 2003
Location: Pittsburgh, PA
Distribution: Gentoo / NetBSD
Posts: 1,251

Rep: Reputation: 45
Re: kernel halts, system halts, computer commits suicide

Quote:
Originally posted by stupid_guy

additional information:
after entering rescue mode, and typing "apm" my computer says no apm support in kernel
but typing in displayapm in "command line" at grub my computer returns sever array of numbers...
my computer is a tower, compaq presario, pentium 4,
well the rescue mode kernel probably does not provide apm support as its a rescue kernel... meaning bare minimum. Similiar to Windows Safe Mode w/ no drivers. To trouble shoot the normal kernel you can pass a kernel parameter (I don't know the specific one yet) that should be able to turn apm off so you can get pass that phase and see if kswapd is what's messing you up.

double checked against apm.c... its apm=off

hope that helps,
jbarto

Last edited by jpbarto; 06-02-2003 at 09:59 AM.
 
Old 06-03-2003, 08:56 PM   #3
stupid_guy
Member
 
Registered: Jun 2003
Distribution: mandrake 9.2
Posts: 57

Original Poster
Rep: Reputation: 15
thanks jpbarto, I searched your solution on the internet and it confused me because there were some mixed views on apm= off.
So I have 2 questions

the linux manual says that the command looks like this:
boot: apm=off
-----------------
question 1: how do you get the "boot: " to come up? is it by using the linux startup floppy?
-----------------

other people mentioned about the grub kernel command line. they say that I should modify it like this:

kernel /boot/vmlinuz-2.4.18-3 ro root=/dev/hda1 hdd=ide-scsi apm=off

------------------
question 2: which option is the best? I'm looking for a permanent fix to this bug.
-------------------

again thanks a bunch for helping out here...
 
Old 06-03-2003, 09:20 PM   #4
jpbarto
Senior Member
 
Registered: Mar 2003
Location: Pittsburgh, PA
Distribution: Gentoo / NetBSD
Posts: 1,251

Rep: Reputation: 45
well a permanent fix would be to download the kernel source and compile it yourself minus the apm.

as for the boot up I'm only familiar with lilo.

are you running grub or lilo?
 
Old 06-04-2003, 05:45 AM   #5
mhearn
Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
You should get a small prompt at startup, or a graphical menu etc. It may only be there for a few seconds, so watch carefully.

Another solution may to switch off APM in the BIOS. It's not critical for a desktop machine, APM == Advanced Power Management.
 
Old 06-04-2003, 08:09 AM   #6
stupid_guy
Member
 
Registered: Jun 2003
Distribution: mandrake 9.2
Posts: 57

Original Poster
Rep: Reputation: 15
I'm using grub, because most people seem to prefer it to lilo.
I think I'll just go to edit kernel arguments in the startup screen and type in apm=off. I think that's what you mean by "BIOS" mike.

as for making my own kernel... I'll do it another day
 
Old 06-04-2003, 08:26 AM   #7
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix, 98,2000 + various
Posts: 3,171

Rep: Reputation: 51
what he meant by bios is the bios setup, like where you
hit delete when you computer is in coming on, but that
depends on the brand a little, lliek f10 for compaq.
but anyway, most computers that you could hit delete
to enter startup, you go to power management and
turn apm off.

you can also enter rescue mode and edit your
/etc/grub/grub.conf and add apm=off to append line.
 
Old 06-04-2003, 08:37 AM   #8
jpbarto
Senior Member
 
Registered: Mar 2003
Location: Pittsburgh, PA
Distribution: Gentoo / NetBSD
Posts: 1,251

Rep: Reputation: 45
a wise indian once told me that "a man cannot truly call himself a man, until he builds his own kernel".
 
Old 06-04-2003, 05:47 PM   #9
stupid_guy
Member
 
Registered: Jun 2003
Distribution: mandrake 9.2
Posts: 57

Original Poster
Rep: Reputation: 15
one step at a time... a wise engineer once told me "the lower you start, the higher you get to be. A sky scraper could not have got so high if the fundation did not start so low"-- I hope I'm starting low enough on linux

anyway. I'll have time this weekend to reinstall linux. THanks for all the information, I think I can get this apm thing solved this time.

If it works, I'll post again so that other linux starters who encounter the same problem will know that it works.

If it fails, I'll post again with more questions!
 
Old 06-04-2003, 06:08 PM   #10
jpbarto
Senior Member
 
Registered: Mar 2003
Location: Pittsburgh, PA
Distribution: Gentoo / NetBSD
Posts: 1,251

Rep: Reputation: 45
either way let us know. best of luck to you.
 
Old 06-07-2003, 05:44 PM   #11
stupid_guy
Member
 
Registered: Jun 2003
Distribution: mandrake 9.2
Posts: 57

Original Poster
Rep: Reputation: 15
yes...yes...YES, and yes.

here's what I did, when grub boots up press p for bootloader password.
Now, choose the option "edit kernel arguments", Now at the end of the line add: apm=off
now press enter, it should load now.
Thanks a plethora for all the help, linuxs looks so cool.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
System halts when the card is injected Birgi Linux - Hardware 1 08-29-2005 03:00 PM
Computer halts after ctrl-alt-backspace koloth Slackware 4 06-09-2005 08:08 AM
File system halts Wolf_Assassin Linux - Software 8 08-17-2004 04:15 AM
computer halts oded31 Linux - Hardware 1 08-31-2003 08:24 PM
Rh9 Halts System During Use atlantis Linux - Hardware 3 05-11-2003 09:36 AM


All times are GMT -5. The time now is 06:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration