LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-13-2004, 04:35 PM   #1
AgentZ86
LQ Newbie
 
Registered: Apr 2004
Posts: 13

Rep: Reputation: 0
Kernel Configuration


Hi all,

I am trying out Slackware

I see when doing a lsmod, and lspci that my device module is no loading into the kernel

I go into the KDE/control center it tells me my Yamaha opl3 module is configured, but no red x or no green checkmark to indicate that it's enabled or disabled. It just says configured.

I'm not sure about a few things regarding this

It tells me to say Y or M and has other topics regarding this, but I'm not sure this applies to what I want to do, and I'm not sure I need to re-compile anything either.

In the kernel directory there is a config file that has the line item for my sound device, however it has a # in front of it, and also a M

What does the # do
and what is the Y or the M stand for or do.

Can I change the config file to enable my device or is there more to it then this.

Please advise

Thanks

Last edited by AgentZ86; 04-13-2004 at 04:37 PM.
 
Old 04-13-2004, 05:07 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,751

Rep: Reputation: 272Reputation: 272Reputation: 272
"In the kernel directory there is a config file that has the line item for my sound device, however it has a # in front of it, and also a M

What does the # do
and what is the Y or the M stand for or do.

Can I change the config file to enable my device or is there more to it then this."

This config file is the parameters that Slackware used when compiling the kernel that they installed in your Slackware system. This particular config file is for reference purposes only and you should not change it. You can, however, use it as a reference when your do you own kernel compile.

The # at the beginnng of the line means that line is a comment only. Since that line is commented out it means that the driver for your sound card was not compiled into your kernel which is why the sound card will not work. Y means that the driver is to be compiled into the bootable kernel. M means that the driver is to be compiled as a loadable module and save in the loadable modules directory somewhere in /lib.

"It tells me to say Y or M and has other topics regarding this, but I'm not sure this applies to what I want to do, and I'm not sure I need to re-compile anything either."

If your Yamaha opl3 module is not compiled into the kernel then you will have to do a kernel compile to get the Yamaha opl3 working. You start out with a copy of the config file in /boot and make whatever changes you want to your new config file. You would probably uncomment the Yamaha opl3 module parameter and set it to M. Then you compile a kernel using your new config file.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites

Last edited by jailbait; 04-13-2004 at 05:09 PM.
 
Old 04-13-2004, 05:28 PM   #3
AgentZ86
LQ Newbie
 
Registered: Apr 2004
Posts: 13

Original Poster
Rep: Reputation: 0
Kernel Configuration

I see so I could use the current config as a template for trying to get my sound card working,

Ok So I'll attempt to uncomment and set it to M, also perhaps the other sound devices that are Y, perhaps should be commented, I'm guessing to avoid any conflict perhaps, tell me it this sound right ?
Or will this matter, can I leave them alone ?

Then to kernel compile? I'll have to reasearch the how to's on that one, I don't know how to compile the kernel yet ?

Please advise if you have some simple commande or instructions on this
Thanks

I'll also re-check the forum for this, I'm sure it's in there someplace

Also please advise that I have sort of 2 similar files in my boot directory

config, and config-ide-2.4.22
system map, and system map-ide-2.4.22
vmlinuz, and vmlinuz-ide-2.4.22

All of the above have written in the top, automatically generated make config: don't edit.
will this effect what I want to do with my config, or the compiling the kernel ???


Thanks

Last edited by AgentZ86; 04-13-2004 at 05:52 PM.
 
Old 04-13-2004, 06:15 PM   #4
AgentZ86
LQ Newbie
 
Registered: Apr 2004
Posts: 13

Original Poster
Rep: Reputation: 0
I rechecked the config and the yamaha module has no # and has a M so I don't know why it's not working,

Please advise

I do know lsmod, and lspci says it's not loading any sound device

 
Old 04-13-2004, 07:50 PM   #5
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,751

Rep: Reputation: 272Reputation: 272Reputation: 272
"Also please advise that I have sort of 2 similar files in my boot directory"

config is a symbolic link to config-ide-2.4.22
system map is a symbolic link to system map-ide-2.4.22
vmlinuz is a symbolic link to vmlinuz-ide-2.4.22

"All of the above have written in the top, automatically generated make config: don't edit.
will this effect what I want to do with my config, or the compiling the kernel ???"

It means that you should not change the master copy of these files. Instead make a second copy and work with that.


"I rechecked the config and the yamaha module has no # and has a M so I don't know why it's not working,

Please advise

I do know lsmod, and lspci says it's not loading any sound device"

The Yamaha driver is compiled into the kernel loadable modules and so you do not need to do a kernel compile.

A loadable module is usually loaded the first time that you access it. So start a program that plays an audio CD and try to play one. This should cause the sound drivers to load.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 04-13-2004, 08:48 PM   #6
AgentZ86
LQ Newbie
 
Registered: Apr 2004
Posts: 13

Original Poster
Rep: Reputation: 0
Sound Server informatin message:
Error while initializing the sound driver:
device / dev/dsp can't be opened (No such device)
The sound sevrver will continue, using the null output device

Thats what I get on startup,

CD plays but no sound

Last edited by AgentZ86; 04-13-2004 at 08:51 PM.
 
Old 04-13-2004, 09:47 PM   #7
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,751

Rep: Reputation: 272Reputation: 272Reputation: 272
"Sound Server informatin message:
Error while initializing the sound driver:
device / dev/dsp can't be opened (No such device)
The sound sevrver will continue, using the null output device"

This message means that Linux does not know what driver to run for /dev/dsp which is your sound card. The first thing to do is to find out the name of your Yamaha opl3 sound driver. Try the following commands to see if you can find the driver:

find /lib -iname "*opl3*"
find /lib -iname "*yamaha*"

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 04-16-2004, 08:54 PM   #8
AgentZ86
LQ Newbie
 
Registered: Apr 2004
Posts: 13

Original Poster
Rep: Reputation: 0
Here is what I get

root@MiniServ:~# find /lib -iname "*opl3*"
/lib/modules/2.4.22/kernel/drivers/sound/opl3sa.o.gz
/lib/modules/2.4.22/kernel/drivers/sound/opl3.o.gz
/lib/modules/2.4.22/kernel/drivers/sound/opl3sa2.o.gz
/lib/modules/2.4.22/kernel/sound/isa/snd-opl3sa2.o.gz
/lib/modules/2.4.22/kernel/sound/drivers/opl3
/lib/modules/2.4.22/kernel/sound/drivers/opl3/snd-opl3-lib.o.gz
/lib/modules/2.4.22/kernel/sound/drivers/opl3/snd-opl3-synth.o.gz
root@MiniServ:~#

Then this

root@MiniServ:~# find /lib -iname "*yamaha*"
root@MiniServ:~#
root@MiniServ:~#


So it appears I have the opl3 drivers in there, which is what I believe I have according to Intel website docs.

Onboard Yamaha

I could disable that card an put a pci ensoniqui 1370 in there also, but I thought I tried it and same thing, no sound.

Anyhow I'm sorry to be such a noob, but I want to learn slackware, I think If I can learn to compile a kernel, or get drivers working I'll be set from there,

Thanks for the all the help so far

I tried to determine if my sound device would work on linux and it appears to have the capacity to work.

Anyhow thats the latest on this.

Thanks for any new info on how I may get the sound going.

Steve
 
Old 04-16-2004, 09:49 PM   #9
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,751

Rep: Reputation: 272Reputation: 272Reputation: 272
"I could disable that card an put a pci ensoniqui 1370 in there also, but I thought I tried it and same thing, no sound."

I use an ensoniq 1370. You would have to have a driver called es1371 installed for your ensoniq chipset to work. Slackware probably did not install ec1371 if your ensoniq pci was
not installed when you did the Slackware install. You could use find to check for es1371.

"root@MiniServ:~# find /lib -iname "*opl3*"
/lib/modules/2.4.22/kernel/drivers/sound/opl3sa.o.gz
/lib/modules/2.4.22/kernel/drivers/sound/opl3.o.gz
/lib/modules/2.4.22/kernel/drivers/sound/opl3sa2.o.gz
/lib/modules/2.4.22/kernel/sound/isa/snd-opl3sa2.o.gz
/lib/modules/2.4.22/kernel/sound/drivers/opl3
/lib/modules/2.4.22/kernel/sound/drivers/opl3/snd-opl3-lib.o.gz
/lib/modules/2.4.22/kernel/sound/drivers/opl3/snd-opl3-synth.o.gz"

I don't know how much of this you must have in memory to have your sound to work. Try booting and then use:
lsmod
to see if any of the opl3 drivers are loaded. If none are loaded then do:
modprobe opl3
to try to get them loaded. After you get some loaded then try your sound again. If the problem turns out to be that some drivers are not automatically loaded then you might be able to get them to load at boot by placing a modprobe statement in /etc/modprobe.conf.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 04-18-2004, 12:42 AM   #10
AgentZ86
LQ Newbie
 
Registered: Apr 2004
Posts: 13

Original Poster
Rep: Reputation: 0
Kernel Module

Thanks for everything

I'm almost there

I was playing around with the modprobe thing I could actually get a es1371 to load somethings, but still no sound, so I scratched that idea and went back to the onboard yamaha

As it turned out, I found that the onboard is a oplsa3, ymf715
accourding to what I read in the KDE, control center/ kernel

I look under the sound devices and it does not appear to support that in particular, however I kept playing with the modprobe as I've said and ended up getting it to work

I typed modprobe opl2sa2 and it appears to work and sound is good, including CD's etc.

Now if I could learn how to load this in the kernel / module so that it will load on startup without having to type modprobe opl3sa2 everytime

I'll be set.

This is very exciting my first linux fix, Yea !

I noticed when I do make changes to the kernel under KDE control center, it says something about run make symlink now, etc.

I don't know what this means or how to date, but I'll figure this out.

Anyhow for now, If you could point me to the info for compiling the opl3sa2 into the kernel, I'll be set

Thanks again for all the help so far.

P.S
I fried my main computer out today, so now I have to use this slackware computer, a little slower then I'm use to, but oh well it's a good motivator to learn what I'm doing LOL
 
Old 04-18-2004, 02:30 AM   #11
comp12345
Member
 
Registered: Feb 2004
Posts: 467

Rep: Reputation: 30
You can set it to automatically load the module by editing /etc/modules.conf.
 
Old 04-18-2004, 12:34 PM   #12
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,751

Rep: Reputation: 272Reputation: 272Reputation: 272
"You can set it to automatically load the module by editing /etc/modules.conf."

Recently /etc/modules.conf has been changed on some distributions to /etc/modprobe.conf. If you have /etc/modprobe.conf on your system then place your modprobe command in /etc/modprobe.conf. If you have no /etc/modprobe.conf then use /etc/modules.conf like comp1234 says.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 04-19-2004, 05:16 PM   #13
AgentZ86
LQ Newbie
 
Registered: Apr 2004
Posts: 13

Original Poster
Rep: Reputation: 0
I have both modprobe and modules ?

I changed the one that says etc/modules.config and it did not appear to be the same file type as the etc/modprobe.config

Anyhow I changed the modules.config and no effect, except the file type changed to some sort of kwrite type, but still txt, or text file.

I hope this will not effect anything, as appeared to be a blank file

I will try the etc/modprobe.config and see if anything changes

I'm guessing I can just click on the file and it will open then I could just make my changes and save and exit and reastart etc.

And It should all work fine with the new command modprobe opl3sa2

Please advise if thats all there is to it ?

Thanks
 
Old 04-19-2004, 05:20 PM   #14
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,751

Rep: Reputation: 272Reputation: 272Reputation: 272
"I'm guessing I can just click on the file and it will open then I could just make my changes and save and exit and reastart etc.

And It should all work fine with the new command modprobe opl3sa2

Please advise if thats all there is to it ?"

That's all there is to it.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
using an old configuration for a new kernel mushmaster Linux - Software 2 02-16-2005 02:07 AM
New FAQ topic: Should I edit my kernel configuration?/Should I build a custom kernel? chort *BSD 10 09-11-2004 12:15 AM
Kernel Configuration berti Debian 2 02-08-2004 12:34 PM
kernel configuration hotrodowner Linux - Software 2 02-19-2003 10:04 AM
kernel configuration Syncrm Linux - General 2 03-07-2002 07:56 PM


All times are GMT -5. The time now is 08:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration