LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-28-2004, 05:14 PM   #1
sakya_trips
LQ Newbie
 
Registered: Oct 2004
Posts: 14

Rep: Reputation: 0
Kernel 2.8


Hi,
I ama trying to update my kernel. I downloaded the kernel-source-2.4.20-9.i386 rpm and installed. But i guess its not installed properly. As when I install it again it says its already installed and when i try to uninstall it, then says that its not installed.
What are the steps to installed, compile and configure the kernel-source-2.4.20-9?
Thanks
-sakya
PS: 'yum update' is also not working in the middle it gives me a GPG Key error.
 
Old 10-28-2004, 05:26 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
how abou you actually tell us what you are doing, rather than what you think you are doing..

i bet you're doing this...

rpm -i kernel.rpm
error: already installed
rpm -e kernel.rpm
error not installed

you remove packages by their package name, not by file name...

rpm -e kernel

and where did 2.8 come from? that won't exist for a few years if ever....
 
Old 10-28-2004, 06:51 PM   #3
sakya_trips
LQ Newbie
 
Registered: Oct 2004
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks for the info. Btw i was talking about kernel-source-2.4.20-8.i386.rpm which i am trying to install. And indeed I was doing

rpm -iv kernel-source*.rpm
and also
rpm -ev kernel-source*.rpm

i guess thats the mistake.
My aim is to run a VPN (Cisco VPN 4) client on my machine. I have installed the client. but when i start it, it says that the version of VPN was compiled for kernel version 2.4.20-8 while i have 2.4.20-6. I even tried installing the lower version of the client. But that was compiled in gcc2 while i have gcc3. thats the entire story. This is the first time i am working with linux, so all this is totally new for me.
Thanks for your help.
-sakya
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel 2.4 in Zipslack (Waring: unable to open an initial console | Kernel Panic...) kurtamos Linux - General 2 05-10-2006 01:58 PM
Kernel-Patch Debian Logo 2.6.2 not correctly working for custom kernel 2.6.11 smp deepclutch Debian 3 06-27-2005 04:59 AM
kernel panic: try passing init= option to kernel...installation with Red Hat 9 kergen Linux - Hardware 1 09-30-2004 04:28 AM
Unable to build NVIDIA kernel module / determin kernel version Night Ink Fedora 2 05-31-2004 05:54 PM
Kernel 2.4.23 compile causes kernel panics on ATA RAID-1 (mirror) array Raptor Ramjet Slackware 3 12-18-2003 02:40 PM


All times are GMT -5. The time now is 06:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration