LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-15-2005, 07:52 AM   #1
daleb
LQ Newbie
 
Registered: Dec 2005
Posts: 5

Rep: Reputation: 0
kernel 2.6.xxx won't boot


Not a newbie..but a newbie question, I guess. Have the funky abit be6-2 mobo with HPT Ultra DMA controller.
Back in the days of 2.2.xxx I had to disable the UDMA and plug HD into IDE channel to get linux to boot. This was all fixed in 2.4.xxx--great!
Upgrading to 2.6.xxx, grub won't boot linux...not even if I use the trick of disabling UDMA, plugging HD into IDE channel, and going into BIOS to make HD0 my first boot disk. This always worked before...even with BeOS.
Tried several different distros, all choked at boot. I am back to using Mandrake 9.1, but would like to upgrade. Any help appreciated.

dale
 
Old 12-15-2005, 08:26 AM   #2
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
Choked??? An actual error message might help someone help you.

Have you tried installing GRUB on a floppy and booting from the floppy? GRUB would still need to read the HDs, but the exercise could be interesting.
 
Old 12-15-2005, 08:44 AM   #3
daleb
LQ Newbie
 
Registered: Dec 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Yeah, tried that trick, too.
Grub starts, shows all the kernel info and location, shows the initrd info and location then boots to a blank screen.
I went back to the 2.4 kernel...grub finds kernel and system boots up as it always did. BTW, this happens no matter what flavor distro I use. Mandrake Fedora, Ubuntu. Any with the 2.6 kernel won't boot. There used to be a patch for the 2.2 kernel to get it to recognize the HTP366 controller. This was incorporated into the kernel in the 2.4 flavor. Maybe this hardware patch was forgotten in the 2.6 kernel.
Thanks for your help.

dale
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"Error, some other host already uses address XXX.XXX.XXX.XXX" mwbb_support Linux - Networking 5 01-20-2014 08:59 AM
Problem getting connection with a DLink Router with IP 10.xxx.xxx.xxx kezira Fedora 9 11-28-2005 10:31 PM
Problem getting connection with a DLink Router after setting static IP 10.xxx.xxx.xxx kezira Linux - Networking 1 11-09-2005 10:27 PM
Host XXX.XXX.XXX.XXX is not allowed to connect to this MySQL server ocavid Linux - Newbie 2 03-16-2005 09:40 AM
# ping -b xxx.xxx.xxx.255 porous Linux - Networking 2 10-13-2003 12:34 PM


All times are GMT -5. The time now is 05:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration