LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-07-2005, 08:39 PM   #1
javb
Member
 
Registered: Dec 2004
Posts: 83

Rep: Reputation: 15
kernel 2.6.11 and NVIDIA conflicts-UPGRADING


ok, here is my god !@#$ problem, i have installed Fedora Core 3, on my AMD64 NVIDIA chipset-graphics based Compaq r3000z laptop. i want to install the lastest NVIDIA drivers and this is what i get.


"WARNING: Your Linux kernel has problems in its implementation of the change_page_attr kernel inteface. The NVIDIA kernel module will atempt to work around these problems, but system stability may be affected. It is recommended that you update to a 2.6.11 or newer kernel."

NOTE: My kernel version is 2.6.10-4 .. i have used YUM to update it, but it says there is nothing new or other release to upgrade my kernel, so how am i gonna to upgrade it?

Can someone give me a hand on this?

THANKS.
 
Old 04-07-2005, 09:19 PM   #2
piscikeeper
Member
 
Registered: Jul 2003
Location: Pennsylvania USA
Distribution: SuSE
Posts: 425

Rep: Reputation: 30
try the 6629 nvidia drivers.
 
Old 04-11-2005, 04:51 PM   #3
javb
Member
 
Registered: Dec 2004
Posts: 83

Original Poster
Rep: Reputation: 15
Ok, i decided to install an older NVIDIA driver version, so i downloaded it and start, thia is what i got..

(2 errors)

1- Your kernel was configured to include rivafb support as a loadable kernel module. ......
What to do in this case.

2 - After hitting OK in the error 1, i got this :

ERROR: Unable to load the kernel module "nvidia.ko". This is most likely because the kernel module was built using the wrong kernel source files. please make sure you have installed the kernel source files for you kernel; on Red .......

here no more step foward.. ! what can i do, wwhere can i see if i have it installed, if not, how and where install it.. damn ! and this is just for Graphics drivers.. missing synaptic mouse, wireless mouse, and i have 4 days that i already installed :S

be aware that a process like building a kernel was completed before this error.

but i ll win.


if u wanna see my /var/log/nvidia-installer.log ---> http://www.geocities.com/valdezjoelandres
thanks
 
Old 04-11-2005, 06:27 PM   #4
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 52
calm down dude and install the nvidia driver rpm from here

http://rpm.livna.org/fedora/3/x86_64/RPMS.testing/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia-kernel conflicts with rivafb driver?? LeftyAce Debian 7 11-08-2005 02:41 PM
Upgrading kernel to 2.6.12 + nvidia drivers MorbidConcept Debian 5 08-08-2005 01:33 PM
Kernel upgrading and nvidia drivers jaakkop Slackware 5 06-30-2005 09:00 AM
kernel 2.6.11 and NVIDIA conflicts-UPGRADING javb Fedora 3 04-11-2005 05:42 PM
NVidia Problem after upgrading kernel XPediTioN Slackware 4 05-04-2004 12:12 AM


All times are GMT -5. The time now is 02:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration