LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-20-2007, 01:56 PM   #1
sanctusiuda
LQ Newbie
 
Registered: May 2007
Posts: 7

Rep: Reputation: 0
KDM on slackware 11 Doesn`t Start


Hi this is my first post, I been reading a lot of helpfully responses on this forums, this is my problem I install Slackware 11 on my computer, everything was working very well, but the mouse scroll was not working, so i decide to edit de xorg.conf file changing the parameters to make it work, since then the screen stays in starting KDM and never start up, how i can edit or restore the old xorg.conf file or login as root to run the xorg config wizard?
 
Old 05-20-2007, 02:12 PM   #2
Okie
Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 963

Rep: Reputation: 34
/etc/xorg.conf should have no bearing on KDE's KDM logon manager hanging up, a badly configured xorg.conf could cause the x-window-system from not working completely leaving you with only CLI mode until xorg.conf was fixed...

however if you don't know exactly what you changed in xorg.conf just run as root xorgconfig and overwrite it with the correct values...

Last edited by Okie; 05-20-2007 at 02:13 PM.
 
Old 05-20-2007, 02:17 PM   #3
vtel57
Member
 
Registered: Jul 2006
Location: Tampa, FL, USA
Distribution: Slackware64
Posts: 835

Rep: Reputation: 88
Which bootloader are you using? LILO? Or GRUB?

Have you tried CTRL+ALT --> F3 or BACKSPACE to get you to a command line?
 
Old 05-20-2007, 03:31 PM   #4
sanctusiuda
LQ Newbie
 
Registered: May 2007
Posts: 7

Original Poster
Rep: Reputation: 0
hi, thank you for your help, the problem is the system hang up and i can't login as root because the computer don't respond at all I try ctrl+alt+f3 and ctrl+alt+backspace and nothig happens, any other idea? I apreciate your help.
 
Old 05-20-2007, 05:00 PM   #5
Sonneteer
Member
 
Registered: May 2006
Location: Canada
Distribution: Slackware 13.37; Ubuntu 12.04
Posts: 81
Blog Entries: 5

Rep: Reputation: 15
If your booting Slackware straight into X, by default there will only be a console available on tty6, so try ctrl+alt+f6 (instead of f3).
Another option would be to use 3 as a boot option (boot: linux 3) to get you to the default Slackware runlevel without KDM.
 
Old 05-20-2007, 05:12 PM   #6
Okie
Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 963

Rep: Reputation: 34
that is what i do is keep runlevel 3 default and just use the console to log on, startx is no problem...

also if you make a text file and name it .bash_profile and save it in your home directory and just add startx in it you will get a gui every time you log on automatically...
 
Old 05-20-2007, 06:46 PM   #7
vtel57
Member
 
Registered: Jul 2006
Location: Tampa, FL, USA
Distribution: Slackware64
Posts: 835

Rep: Reputation: 88
I guess you didn't make a floppy boot disk when you installed Slack, huh?
 
Old 05-21-2007, 10:37 PM   #8
sanctusiuda
LQ Newbie
 
Registered: May 2007
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Sonneteer
If your booting Slackware straight into X, by default there will only be a console available on tty6, so try ctrl+alt+f6 (instead of f3).
Another option would be to use 3 as a boot option (boot: linux 3) to get you to the default Slackware runlevel without KDM.
thanks for the responses i try ctr+alt+F6 and it works, i run xorgconfig and same problem when finish the config, i restart and stays in "Starting up X11 session manager" then nothing happens and stays in the same message all the time what i going to do is edit the file /etc/initab.conf to change it to runlevel 3 the try to startx thanks,
 
Old 05-21-2007, 11:15 PM   #9
sanctusiuda
LQ Newbie
 
Registered: May 2007
Posts: 7

Original Poster
Rep: Reputation: 0
Ok, Only for let you know guys my slackware is working thank you for your help I just login as root run xorgconfig again and it works, also edit the inittab.conf file and change it to level 3 thank you I apreciate your help.
 
Old 05-21-2007, 11:26 PM   #10
vtel57
Member
 
Registered: Jul 2006
Location: Tampa, FL, USA
Distribution: Slackware64
Posts: 835

Rep: Reputation: 88
Good for you! Glad you got it working!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New slackware install and my debian doesn`t work well Sinaz Slackware 2 03-11-2006 07:15 AM
Won't start KDM terfy Debian 4 01-06-2006 07:00 PM
kdm won't start kde seb3579 Linux - Software 12 09-12-2004 11:33 PM
fedora core 2 doesn*t start on AMILO kalyanvgopal Linux - Laptop and Netbook 4 09-09-2004 11:36 PM
eth0 doesn´t start snu Linux - Networking 2 07-07-2003 10:58 PM


All times are GMT -5. The time now is 02:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration