LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-28-2007, 08:25 PM   #1
SeanW
LQ Newbie
 
Registered: Dec 2007
Location: US =/
Distribution: Fedora 8
Posts: 9

Rep: Reputation: 0
KDE sound not working


Hi,

I recently replaced GNOME with KDE, but now I am getting a bad problem now. The sound doesn't work ever since I installed KDE. I know its not a problem with my sound card because it worked perfectly in GNOME and windows. I have no idea how I'd fix this. Anyone have any pointers to how I'd go about fixing this problem? I tried looking on the net for solution but found nothing good.

Thanks
 
Old 12-28-2007, 08:44 PM   #2
fuzzyworm
Member
 
Registered: Sep 2003
Location: Stroud, UK
Distribution: Kubuntu, Debian
Posts: 149

Rep: Reputation: 15
KDE has its own sound system, aRTS, which sits on top of your normal sound system, e.g. Alsa

First step, test that the sound is still working underneath:

Make sure your volume on your speakers is not too high before trying this step!!

In a Konsole window, type

Code:
cat /dev/urandom > /dev/dsp
Press Ctrl+C to stop it.

This should send random static to the sound card. If nothing happens, turn the volume up slowly. Please post any error messages. If this step fails, it may not necessarily be a problem, but if it works, then you just need to tweak KDE's own settings. To do so:
  1. Go into the KDE Control Centre, 'Sound & Multimedia', 'Sound System' control
  2. Make sure it's enabled (default installation should enable it)
  3. Go to Hardware tab
  4. If you know which sound system you are using, choose it, if in doubt, choose Autodetect or ALSA (Advanced Linux Sound Architecture)
  5. Apply changes
  6. Go back to General tab and test sound, you should hear a nice little 'wave' file.

If it's still not working, and you have had any specific errors at any stage, please post them, as there are various things that could have gone wrong. aRTS is usually a very good system, but occasionally there are some kinks to be worked out, as there is no de facto standard for sound in Linux, though ALSA is rapidly claiming the top spot.

One problem that you might want to look into is whether or not you have permission to access the sound devices. If the command I gave you above doesn't work as a normal user, try it as root. If this works, you may simply need to add your user to the 'audio' (or equivalent) group.

Last edited by fuzzyworm; 12-28-2007 at 08:47 PM. Reason: Stupid spelling mistake: I am hereing things, it's all up hear in my head
 
Old 12-28-2007, 09:13 PM   #3
SeanW
LQ Newbie
 
Registered: Dec 2007
Location: US =/
Distribution: Fedora 8
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks for the feedback.

The static sound works great. I didn't need to log in as root for that.
So I went into 'Sound System' in the Control Center, and the sound system was enabled. In the hardware tab, I tested the test sound with ALSA and auto detect, unfortunately, neither worked.

There were no error messages anywhere during any of the stages...
Any more ideas?

Thanks
 
Old 12-28-2007, 10:27 PM   #4
fuzzyworm
Member
 
Registered: Sep 2003
Location: Stroud, UK
Distribution: Kubuntu, Debian
Posts: 149

Rep: Reputation: 15
Ok, that seems strange.

Do you have any other sound cards? Onboard sound as well as a dedicated card? A TV card?

Open 'kmix', there should be a drop-down list if you have more than one card. Also, while you're in kmix, this may seem obvious, but have you checked the volume - try turning everything right up, at least until the sound is working.

Do:
Code:
ls -l /dev/dsp*
If more than one appears here, then KDE may be trying to use the wrong one.

If this is the case, go back to the settings page, and try overriding the device location to the one that worked with the static, i.e. /dev/dsp

Also, if this doesn't work, please post the result of:
Code:
lspci

Last edited by fuzzyworm; 12-28-2007 at 10:29 PM. Reason: Volume
 
Old 12-29-2007, 12:12 AM   #5
SeanW
LQ Newbie
 
Registered: Dec 2007
Location: US =/
Distribution: Fedora 8
Posts: 9

Original Poster
Rep: Reputation: 0
I went into Kmix and there are two items in the drop-down list. One of them is Audigy 2 ZS and the other CA0106. I assume CA0106 is my on-board sound card that I am not using. I never installed drivers for them. Audigy 2 ZS is my peripheral sound card that I am using.

Here is the output of ls -l /dev/dsp*
Code:
/dev/dsp
/dev/dsp1
I do get an error message when I try to override the device location with /dev/dsp and /dev/dsp1

Here is the error message:
--------------------------------------------
Informational - artsmessage

Sound server informational message:

Error while initializing the sound driver:

device: /dev/dsp can't be opened for playback (No such file or directory)

The sound server will continue, using the null output device.

---------------------------------------------------

Also, I turned absolutely everything up to the max in Kmix, and blasted the speakers to the max. Still no sound.

I would give you the result of lspci, but it says:
Code:
bash: lspci: command not found
This is a very persistent problem, I will continue to experiment with options.

Any more ideas?

Last edited by SeanW; 12-29-2007 at 12:16 AM. Reason: Made the error message distinct from the rest of the post
 
Old 12-30-2007, 01:57 AM   #6
SeanW
LQ Newbie
 
Registered: Dec 2007
Location: US =/
Distribution: Fedora 8
Posts: 9

Original Poster
Rep: Reputation: 0
Been messing around with it for a while to no avail. No more ideas?

Last edited by SeanW; 12-30-2007 at 01:58 AM.
 
Old 12-30-2007, 03:02 AM   #7
AceofSpades19
Senior Member
 
Registered: Feb 2007
Location: Chilliwack,BC.Canada
Distribution: Slackware64 -current
Posts: 2,079

Rep: Reputation: 58
run lspci as root
 
Old 12-30-2007, 12:03 PM   #8
fuzzyworm
Member
 
Registered: Sep 2003
Location: Stroud, UK
Distribution: Kubuntu, Debian
Posts: 149

Rep: Reputation: 15
Sorry, I've been away for a while.

I don't think you would learn anything from lspci that you don't already know. I'm surprised that you can't run it as a normal user - it works for me, but try it as root.

You shouldn't need it for this, but you may need to find it if you have problems in the future.

Out of interest, try the speakers or some headphones in the other sound card, and see if it works.

To change your default ALSA sound card, assuming alsa-utils is installed:
(based on my system, adjust accordingly)
Code:
~$ asoundconf list
Names of available sound cards:
M5461
UART
CX8811
~$  asoundconf set-default-card M5461
Once this is done, you will need to restart the aRTS sound server to see any change.
 
Old 12-30-2007, 01:06 PM   #9
SeanW
LQ Newbie
 
Registered: Dec 2007
Location: US =/
Distribution: Fedora 8
Posts: 9

Original Poster
Rep: Reputation: 0
I tried the lspci command as root but it still says its an unrecognized command. I am using fedora 8 if that matters. The ~$ asoundconf list doesn't work either, both as a normal user and root.

I tried to plug the sound into the on-board sound but it doesn't work.

I did find something new though. In KMenu > System > SoundCard Detection. The Audigy sound card that I am trying to use works when I test its sound. At first, KDE had my other on-board card set as default, which didn't work. So I switched it to my peripheral sound card and doing the testsound there works. Unfortunately though, it doesn't work anywhere else.
 
Old 12-30-2007, 01:32 PM   #10
fuzzyworm
Member
 
Registered: Sep 2003
Location: Stroud, UK
Distribution: Kubuntu, Debian
Posts: 149

Rep: Reputation: 15
Have you got alsa-utils installed? (The package name may be slightly different under Fedora)

Does asoundconf work at all? Even if it doesn't list any hardware?

I don't have that KDE app in my menu, and I don't know what it would be under to install it, so I can't test that myself.

Other than that, I'm afraid I can't think of anything else at the moment, but I'll keep thinking.
 
Old 12-30-2007, 02:14 PM   #11
SeanW
LQ Newbie
 
Registered: Dec 2007
Location: US =/
Distribution: Fedora 8
Posts: 9

Original Poster
Rep: Reputation: 0
Went into the package manager and I do have alsa-utils installed..
Yeah I tried the asoundconf list command with both root and normal user in the shell and in init 3, unfortunately it says its an unrecognized command. It doesn't list anything at all, it simply says its an unrecognized command.

I will keep experimenting with it. BTW: Thanks for all the help, I still wouldn't have made it this far without it.
 
Old 12-30-2007, 02:36 PM   #12
fuzzyworm
Member
 
Registered: Sep 2003
Location: Stroud, UK
Distribution: Kubuntu, Debian
Posts: 149

Rep: Reputation: 15
It may be an Ubuntu/Fedora difference then.

Previous versions of alsa-utils just had the command 'set-default-card' instead of 'asoundconf set-default-card'

Unfortunately, I can't find what the equivalent for 'asoundconf list' is, however, I did manage to find someone who had the same sound card listed as 'Audigy2', so try
Code:
set-default-card Audigy2
Incidentally, this chap was having a similar problem to your own:
http://ubuntuforums.org/archive/index.php/t-346574.html
 
Old 12-30-2007, 02:45 PM   #13
AceofSpades19
Senior Member
 
Registered: Feb 2007
Location: Chilliwack,BC.Canada
Distribution: Slackware64 -current
Posts: 2,079

Rep: Reputation: 58
If you are using Fedora 8, it uses pulse audio so that might be a problem
 
Old 12-30-2007, 02:46 PM   #14
fuzzyworm
Member
 
Registered: Sep 2003
Location: Stroud, UK
Distribution: Kubuntu, Debian
Posts: 149

Rep: Reputation: 15
Quote:
Originally Posted by AceofSpades19 View Post
If you are using Fedora 8, it uses pulse audio so that might be a problem
In that case, I can't help any more - I've never used pulse audio
 
Old 12-30-2007, 04:13 PM   #15
bigmig
LQ Newbie
 
Registered: Nov 2006
Posts: 9

Rep: Reputation: 0
I don't know why, but every time I install Linux with KDE, sound is "muted".

I just play some mp3 or cd and in Kmix I click in all "mute" bottons (one at the time) untill I get sound.

You can try it... it wont make it worst
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
no sound on xmms but kde effects working dave`2005 Slackware 8 10-09-2005 11:37 AM
KDE 3.4 Sound Notifications not working joncbl Linux - Software 8 04-17-2005 04:14 PM
kde sound system not working shyam_d_sundar Linux - Newbie 1 02-25-2005 11:05 PM
Sound working, but not in KDE microsoft/linux Debian 2 12-12-2004 06:35 PM
need to get sound working on kde startup lokizen Linux - Newbie 2 09-09-2004 02:06 AM


All times are GMT -5. The time now is 09:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration