LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   KDE Plasma plasmoid using 100% resources; cannot remove (http://www.linuxquestions.org/questions/linux-newbie-8/kde-plasma-plasmoid-using-100-resources%3B-cannot-remove-701974/)

peteyperson 02-03-2009 12:07 PM

KDE Plasma plasmoid using 100% resources; cannot remove
 
Hey all,

I added a couple of new widgets/plasmoids to KDE 4, running the latest openSUSE version. I believe the icon-based file launcher plasmoid is sucking all the resources and I cannot get into the Widget List (Ctrl-A) to remove the plasmoid to rectify. The window won't scroll down the list, nor give me access. I have command line (Alt-F2), and no menu availability. Hunted on the net for way to resolve but alas.

Total Linux newbie. Enjoying the experience so far. Thanks for any help!

Best,
Petey

TB0ne 02-03-2009 12:13 PM

Quote:

Originally Posted by peteyperson (Post 3430612)
Hey all,

I added a couple of new widgets/plasmoids to KDE 4, running the latest openSUSE version. I believe the icon-based file launcher plasmoid is sucking all the resources and I cannot get into the Widget List (Ctrl-A) to remove the plasmoid to rectify. The window won't scroll down the list, nor give me access. I have command line (Alt-F2), and no menu availability. Hunted on the net for way to resolve but alas.

Total Linux newbie. Enjoying the experience so far. Thanks for any help!

Best,
Petey

That happens due to a malfunctioning plasmoid. You have no choice but to go into a terminal-window, run "top", then "kill -9 <process id>" (first column, labeled PID).

This WILL put your KDE desktop into a bad state....however, you can either <CTRL>-<ALT>-<BACKSPACE> to restart X windows, or type in "reboot" (you have to be root for that to work, though). When you come back up, the offending plasmoid shouldn't be there. Note I said "shouldn't"...:) If it is, you have to grab it IMMEDIATELY when you see it on the screen, and close it. Otherwise, you'll peg the CPU, and it'll be almost impossible to do.

peteyperson 02-03-2009 12:34 PM

Hi there,

Thanks for the quick reply.

I type Alt-F2 and then top. The top icon comes up, but it doesn't load. This is strange as other apps are loading like Firefox, KSysGuard, etc.

I cannot see an individual process to kill from the process list; only Plasma and X. So I wouldn't know the process number (added that column).

The desktop icon launcher has no side strip to hit the red X to close it, only the smaller icons for the apps included. I can close them, then there is a blank strip. No way to close it using a mouse. I was thinking there was a way to give the Widget Add/Remove window more resources by prioritising it?

Petey

>> That happens due to a malfunctioning plasmoid. You have no choice but to go into a terminal-window, run "top", then "kill -9 <process id>" (first column, labeled PID).

This WILL put your KDE desktop into a bad state....however, you can either <CTRL>-<ALT>-<BACKSPACE> to restart X windows, or type in "reboot" (you have to be root for that to work, though). When you come back up, the offending plasmoid shouldn't be there. Note I said "shouldn't"... If it is, you have to grab it IMMEDIATELY when you see it on the screen, and close it. Otherwise, you'll peg the CPU, and it'll be almost impossible to do.

Petey

Saptech 02-03-2009 12:42 PM

just type ps ax | more in a terminal and find the pid to kill.

peteyperson 02-03-2009 12:52 PM

Sorry, not command-line proficient (4th day in Linuxland).

If I can't get any of this to work, is there a way to reset the KDE desktop? Obviously there are various boot options like Repair, etc.

Petey

Quote:

Originally Posted by Saptech (Post 3430660)
just type ps ax | more in a terminal and find the pid to kill.


Saptech 02-03-2009 01:37 PM

Just go in the menu and open a terminal window, looks like a DOS box, and type that command I gave in other post. I don't use KDE so not sure exactly what its called.

peteyperson 02-03-2009 05:30 PM

Well I see what you mean, but I cannot access the Terminal as the menu doesn't work and Konsole won't load from the command line either.

What I've ended up doing is creating a 2nd user, and accessing my browser and other programs as if I'm the 1st user. This way I keep the settings in a lot of places and don't have to setup everything up again (bookmarks, music, icons, etc). Best workaround I could think of.

Thanks,
Petey

Quote:

Originally Posted by Saptech (Post 3430660)
just type ps ax | more in a terminal and find the pid to kill.


General Failure 02-04-2009 02:03 AM

Petey,

to "reset KDE" just move/rename the .kde directory in your home folder to any other name or location. After that, you will have default KDE settings again.

To do this on the command line, type
Code:

mv /home/<your_username>/.kde kde-backup
You can get usually to a login terminal from KDE by pressing CTRL-ALT-F6. Just login as your user and issue the command above.

You will have to set KDE up to your personal taste again afterwards though.

peteyperson 02-05-2009 09:17 AM

Hi Gen Fail,

Thanks for the info.

I'm using a newly created user and set things up again. A Linux book saved me with teaching me how to setup a new user. I did attempt what you said and it all worked as described, however when I booted into the old user the problem persisted. A background window was blank instead of showing a picture, but otherwise the same and the widget was still blocking all activity.

I'm still quite pleased at my five days using openSUSE Linux. I've learnt how to make a mount permanent an external HDD that was mounted, then lost the mount on reboot. Problems are becoming easier to figure out and it's starting to make sense. Incredibly robust system, using less than half the WinXP resources, making a 3-year old Dell run like new.

Cannot install Castle Wolfenstein: ET via Wine though. Wine runs, then stops and nothing happens. Call of Duty 4 (PC) wouldn't install via Wine either despite Wine's web site assurance that it would. Can't win em all.

Petey

Quote:

Originally Posted by General Failure (Post 3431467)
Petey,

to "reset KDE" just move/rename the .kde directory in your home folder to any other name or location. After that, you will have default KDE settings again.

To do this on the command line, type
Code:

mv /home/<your_username>/.kde kde-backup
You can get usually to a login terminal from KDE by pressing CTRL-ALT-F6. Just login as your user and issue the command above.

You will have to set KDE up to your personal taste again afterwards though.


General Failure 02-05-2009 09:56 AM

Wolfenstein ET has a native linux version, so don't use wine, just dwonload the linux version. Install the game then by running
Code:

sh <name_of_downloaded_file>
The file should be called something like ETlinux2.60.bla if I remember correctly.

For having the old user run correctly again you could also try(!) removing the /home/<your_username>/.kde/share/config/plasma-appletsrc file. Theoretically you shouldn't have any plasmoids running then.

peteyperson 02-05-2009 12:12 PM

Hey there,

With your notes and those directly below, managed to install ET and get it running. Thank you :-)

Found some new info:
Installation:

chmod +x et-linux-2.60.x86.run (make executable)
sh et-linux-2.60.x86.run (run installer)
http://www.techpowerup.com/downloads...nux_v2.60.html

Regarding problem plasma, I went to the config directory mentioned. There is no plasma file. All files start with 'k' and no 'kplasma'etc.

BTW, I downloaded something that needs compiling (I think). The instructions are a bit beyond me:
GkrellAclock: GkrellM Aclock Plugin
Author: M.R.Muthu Kumar <m_muthukumar@users.sourceforge.net>

install:

make
make install (as root)
make userinstall ( Installs in ~/.gkrellm2/plugins directory.)
Petey

Quote:

Originally Posted by General Failure (Post 3433118)
Wolfenstein ET has a native linux version, so don't use wine, just dwonload the linux version. Install the game then by running
Code:

sh <name_of_downloaded_file>
The file should be called something like ETlinux2.60.bla if I remember correctly.

For having the old user run correctly again you could also try(!) removing the /home/<your_username>/.kde/share/config/plasma-appletsrc file. Theoretically you shouldn't have any plasmoids running then.


General Failure 02-06-2009 03:17 AM

Quote:

Originally Posted by peteyperson (Post 3433232)
Regarding problem plasma, I went to the config directory mentioned. There is no plasma file. All files start with 'k' and no 'kplasma'etc.

That's strange. ;)

Quote:

Originally Posted by peteyperson (Post 3433232)
BTW, I downloaded something that needs compiling (I think). The instructions are a bit beyond me:

make
make install (as root)
make userinstall ( Installs in ~/.gkrellm2/plugins directory.)

That means you have to issue those commands in the directory where you unpacked the source to install the program.

Type
Code:

make
to create the binary file and then
Code:

make userinstall
to install it to your home directory. Typing make install would install it systemwide, but installing it to your home directory is sufficient unless you have several users on this box.

peteyperson 02-07-2009 06:42 AM

Hi,

I've previously gone into Terminal to try these commands. Just did it again, typed: make
and I got
"make: *** No targets specified and no makefile found. Stop."

At this point I get lost. ;)

With the above file, this was an addon to a system analyser, so I know where to copy the files to.

Best,
Petey

Quote:

Originally Posted by General Failure (Post 3433915)
That's strange. ;)



That means you have to issue those commands in the directory where you unpacked the source to install the program.

Type
Code:

make
to create the binary file and then
Code:

make userinstall
to install it to your home directory. Typing make install would install it systemwide, but installing it to your home directory is sufficient unless you have several users on this box.



All times are GMT -5. The time now is 11:00 PM.