LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-20-2006, 08:47 AM   #1
kissme1
LQ Newbie
 
Registered: Dec 2005
Posts: 29

Rep: Reputation: 15
KDE or gnome wont start- SOLVED


well i have installed fedora and whenever i start it start in shell mode i have to login and then type startx to continue i dont start in kde or gnome by default and i am not able to access the login screen option in the Systems\Administratoin menu but if i type init 5 in terminal it starts in another desktop session and then i can see the login screen

also the lock screen option is not working i click on it it starts the screen saver but when i click something and remove the screen saver it doesnt ask for a password or anything is there anyway that i can lock the system when i leave my system cause this way my system is not secure

thanks for reading and waiting for a reply

Last edited by kissme1; 07-21-2006 at 02:19 AM.
 
Old 07-20-2006, 09:57 AM   #2
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
Edit the file /etc/inittab. At the top should be a line
Code:
id:3:initdefault:
Change the 3 to a 5 and it will boot into init 5 by default.

I would look in your control panel or whatever your desktop uses. There should be a screen where you can configure the screensaver. There should be a check box that says "Prompt for Password on Resume" or something like that. Check the box and hit "Apply" or "OK" and it should start prompting you. There also might be an option to set a time before it prompts. Mine I set to like 7 seconds (make sure it isn't set to a couple of minutes or something). That way if it goes to sleep and the screen saver starts, I can just wiggle the mouse real quick and I won't have to enter my password.
 
Old 07-20-2006, 10:19 AM   #3
kissme1
LQ Newbie
 
Registered: Dec 2005
Posts: 29

Original Poster
Rep: Reputation: 15
ok changed the initd file will restart and then tell you if it works or not thanks for the reply
 
Old 07-20-2006, 10:36 AM   #4
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
I hope you mean inittab file... init.d is usually where the startup scripts are.
 
Old 07-21-2006, 02:19 AM   #5
kissme1
LQ Newbie
 
Registered: Dec 2005
Posts: 29

Original Poster
Rep: Reputation: 15
ok done this solution works thanks for helping out
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
After nvidia-glx-config enable Gnome wont start zivs Linux - Newbie 2 03-27-2006 07:07 AM
GNOME wont start in RH9 Keitex Linux - Software 5 01-12-2005 07:29 AM
KDE wont start with autologin petermcp Linux - Software 5 07-03-2004 07:19 AM
Gnome applications wont start after installing with garnome AnthonyRimsky Linux - Software 0 06-08-2004 04:36 AM
Gnome Wont Start. HELP!!! zerologic Linux - Software 0 06-12-2003 08:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration