LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-04-2004, 12:20 PM   #1
LocoMojo
Member
 
Registered: Oct 2004
Distribution: Slackware 12
Posts: 165

Rep: Reputation: 30
KDE file association won't stick


Hello all,

This is my very first post to this forum so please forgive me if I do something wrong.

I'm a total newbie to Linux. Just installed Mandrake 10 last week and totally fell in love with it. Ran into some problems here and there, but I was able to fix most of them with the help of our good friend, Google.

I have this one problem I can't seem to lick. It's a file association issue. Yes, I've searched this forum, but most of what I found had to do with "how to set up a file association". I know how to set up the file association in KDE by going to the control center and all that jazz and I have succeeded in making Firefox my default browser and everything works as it should.

The problem is that the file association for Firefox (text/html) doesn't keep over a logout or a reboot...it reverts back to the defaults on boot or login, i.e., when clicking on a link in an email in Kmail it opens up Konqueror. I imagine there must be some config file somewhere that I need to update and save permanently? When I change the file association it will keep for days and give me no problems whatsoever...it is just after a logout /reboot that I have my problem.

Any help would be very appreciated. Also, any help regarding the use of this forum (if I've done something wrong) would also be appreciated. By the way, if this has already been covered in this forum and I missed it...sorry about that If I haven't given enough information, please just ask and I will tell you...I'm just not sure what info would be pertinent here.

LocoMojo

Mandrake 10
KDE 3.2
Firefox 0.10.1
Kmail 1.6.1
 
Old 10-04-2004, 12:25 PM   #2
pongmaster
Member
 
Registered: Jul 2004
Location: London, England
Distribution: Mandrake 10.1
Posts: 300

Rep: Reputation: 30
Go to: startmenu -> system -> configuration -> configure your desktop.
In the new window go to: components -> file associations.
Set up your preferences here. To stop konqueror opening links from emails and such, elevate firefox to the top of the list and put konqueror at the bottom.
You can do this for other stuff too like setting up mplayer for all your video files and such.
 
Old 10-04-2004, 12:37 PM   #3
LocoMojo
Member
 
Registered: Oct 2004
Distribution: Slackware 12
Posts: 165

Original Poster
Rep: Reputation: 30
Hi pongmaster,

Thanks for your reply.

I have done exactly what you suggested, except I did it via the control center as I didn't see anything about file associations in "configure your desktop".

I elevated Firefox to be first and then when I am done it works flawlessly until I logout or reboot.

The problem for me isn't getting the file association to work, it is getting it to become permanent and sticking over logouts/reboots. I'm getting annoyed with having to re-establish the file association everytime I login.

I'm now wondering if I should maybe do this via root? I didn't try yet as I'm really jittery about becoming root until I know what I'm doing.

Thanks.

LocoMojo
 
Old 11-04-2004, 12:08 PM   #4
pld
Member
 
Registered: Jun 2003
Location: Southern US
Distribution: Ubuntu 5.10
Posts: 206

Rep: Reputation: 30
just a bump because I am having the same problem...

im using kde occasionally, but its an odd problem because i am also using xfce mostly

if i use konqueror as a filemanager, none of the assocations seem to wanna stick.
i'll go in and setup the file association for mplayer for instance. i'll set all my video preferences to use gmplayer to open it, make it up to the top of the list, update it. but it NEVER sticks for me. if i go back in immediately to check, the association is gone, as well as the gmplayer option? anyone find a solution to this?

vanilla fc2 install at the moment.
 
Old 11-04-2004, 02:41 PM   #5
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
Maybe try logging into KDE and going into Session Manger
Select "Start with saved session"
Set up file associations
Go to KDE Button, select "Save Session"
logout/login
 
Old 11-04-2004, 11:54 PM   #6
pld
Member
 
Registered: Jun 2003
Location: Southern US
Distribution: Ubuntu 5.10
Posts: 206

Rep: Reputation: 30
following someone elses suggestion I figured out that using the full path to the program that you want to associate will do the trick. So for adding mplayer, you would use /usr/local/bin/gmplayer

then the association stuck :.
 
Old 11-05-2004, 02:57 AM   #7
LocoMojo
Member
 
Registered: Oct 2004
Distribution: Slackware 12
Posts: 165

Original Poster
Rep: Reputation: 30
Hello all,

Sorry I forgot to get back with you all. I found the answer that worked for me.

I Googled around and found out that file association changes are kept in RAM (don't ask me why)
which means that the change is flushed out during a logout and the file
associations revert to defaults.

I discovered a command called kbuildsycoca which makes changes permanent by
writing them to configs or something like that.

I used kbuildsycoca --noincremental

The noincremental option = "Disable incremental update, re-read everything."

From kbuildsycoca --help-all

Worked like a charm for me, hope this works for you all too

LocoMojo

P.S. - this worked for me in both Mandrake 10 and Slackware 10.

Good luck!

P.P.S. - After posting I realized that I had forgotten to mention that you needed to make the file association change first then issue the command 'kbuildsycoca --noincremental' in CLI. That's probably a given, but I wanted to be sure I was clear.

Last edited by LocoMojo; 11-05-2004 at 03:04 AM.
 
Old 12-28-2004, 10:32 AM   #8
cbonar
Member
 
Registered: Apr 2004
Location: Paris, FRANCE
Distribution: Ubuntu
Posts: 54

Rep: Reputation: 16
Thank you very much (afterwards), LocoMojo, I would never have found this myself. Here follows what it solved for me.

I used to have almost the same problem : I was successfull once in adding firefox as my default program for text/html (don't have a clue how I did it), but the command was "/.../firefox/firefox", and not "/.../firefox/firefox %u" (which is needed to open 'live' URL, not a cached file).
Of course, every time the machine was restarted, the setting was lost, and the old command without %u was used.

With "kbuildsycoca --noincremental", the settings were kept after I reboot.

As a clue, I'm using ReiserFS and Ext3FS, maybe there's a problem with journalized FS ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE Konquerer File association bobinglis Linux - Software 2 01-17-2005 03:17 AM
KDE desktop file association problem neranjana Linux - General 2 10-23-2004 11:01 AM
XMMS .mp3 Association Won't "Stick" in KDE CsHoSi Linux - General 2 09-11-2004 06:39 AM
KDE File Association Issues Eultza Linux - Newbie 7 12-16-2003 04:51 PM
KDE Realplayer permanent file association? jcabral3 Linux - Newbie 1 05-29-2003 08:24 AM


All times are GMT -5. The time now is 10:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration