LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-29-2004, 06:06 PM   #1
j-la
LQ Newbie
 
Registered: Jan 2004
Distribution: SUSE 10.0
Posts: 10

Rep: Reputation: 0
KDE config error: konqueror associated with text/html


Hi, I was trying to update a website I "maintain" for a class I teach...
I was using Konqueror to view my various files, and right-clicked on an html document so that I could use the "open with..." option. I opened it with Kate (I think the standard KDE editor?). Anyway, I mistakenly checked the box that says always associate this file type with this application. Then, whenever I tried to go to any website it opened it up using the editor. To try to fix the problem I repeated the process only this time selecting Konqueror for the application as opposed to Kate. Now, when I try to go to a website I get the following error message:

"There appears to be a configuration error. You have associated Konqueror with text/html, but it can't handle this file type."

I'm new to linux and configuring kde, I'm sure there is a simple solution but I just don't know how to fix it. I've looked around in various system/config menus but don't seem to see what I need. I just want to restore the association to the default.

If anyone could help, I would much appreciate it.
 
Old 01-29-2004, 06:19 PM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hi.

Right click on an html file -> Edit file type -> Embedding -> select "show file in embedded viewer" -> Make sure KHTML is at the top of the priority list in embedding -> apply

That should do it.

Dave
 
Old 01-30-2004, 12:11 AM   #3
j-la
LQ Newbie
 
Registered: Jan 2004
Distribution: SUSE 10.0
Posts: 10

Original Poster
Rep: Reputation: 0
Thanks a lot Dave, that did the trick!
 
Old 01-30-2004, 01:42 AM   #4
j-la
LQ Newbie
 
Registered: Jan 2004
Distribution: SUSE 10.0
Posts: 10

Original Poster
Rep: Reputation: 0
Actually... I'm not out of the woods yet:

It seems most of the time everything works fine. But if I go to a website via the "bookmarks" button in my tool bar it goes to

file:/home/jla/.kde/share/apps/kfmexec/tmp/3158.0

instead of going to the usual http://www.whatever.com address. The site usually looks different and if I try to go to a link it gives me an error message like:

"unable to run the command specified. The file or directory
file:/recent/?somelink does not exist"

If I open up Konqueror first, and then use my bookmarks through the Konqueror window it works fine. But I'd like to be able to use the bookmark button in the tool bar as well. Any help would be much appreciated.
 
Old 01-30-2004, 08:44 AM   #5
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hmmm. I've never used the bookmarks button on the toolbar. Until now.

Mine wanted to use emacs to open new pages, by downloading them first, then displaying the source.

I got this sorted by making sure Konqueror is first in the 'Application Preferences Order' bit in the 'General' tab of the 'Edit File Type' thing for html files, and the Embedding tab still has 'View in Embedded Viewer' selected and KHTML at the top of the list.

I would clear out the /home/jla/.kde/share/apps/kfmexec/tmp/ directory too.

If all else fails, you might want to export your bookmarks, clear the bookmarks, then re-import them.

Dave
 
Old 01-30-2004, 06:44 PM   #6
j-la
LQ Newbie
 
Registered: Jan 2004
Distribution: SUSE 10.0
Posts: 10

Original Poster
Rep: Reputation: 0
Thanks again. I moved Konqueror to the top of the 'Application Preferences Order' in the general tab and everything seems to be working now.
 
Old 01-30-2004, 11:54 PM   #7
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Cool, man.

Glad it's working for you.

Dave
 
Old 02-15-2004, 09:29 AM   #8
ryuuguu
LQ Newbie
 
Registered: Feb 2004
Posts: 4

Rep: Reputation: 0
I also made this same mistake of changing the text/html settings but I unfortunately tried to fix t before reading this forum. I deleted the test/html file type.

I did

Quote:
Right click on an html file -> Edit file type -> Embedding -> select "show file in embedded viewer" -> Make sure KHTML is at the top of the priority list in embedding -> apply
and now if I click on an html file in the file viewer. it open it as a web pages, but when I click on a link I get a dialog box asking if I want to open the file and then a dialog asking which apllication to use. I navigated throught menu presented and choose "Konqueror Web Browser" . but then it downloads the file to a tmp directory and opens it. so further links try to coonect to local files not urls out on the net.

Any suggestions on what more to change or some other place I should put text/html settings back?

Thanks,
Grant
 
Old 03-28-2004, 01:30 PM   #9
jakoblund
LQ Newbie
 
Registered: Mar 2004
Location: Copenhagen
Distribution: gentoo
Posts: 1

Rep: Reputation: 0
Different solution to the problem:
I made an association with Konqueror to text/html, moved it to the top of the list (and it didn't work, as described by J-LA.)

Then (after trying several other things, including show in embedded viewer, and reading this thread,) I clicked 'Edit', and on the 'Application' tab of the dialog I changed the value of the 'Command' field from
Code:
kfmclient openProfile webbrowsing openUrl %u
to the more straight-forward
Code:
konqueror %u
Then I could remove the show in embedded viewer thing, and the file browser works as I want it to.

Phew....
Cheers, Jakob.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Evoke program from html in Konqueror Darkfalz Linux - Software 2 11-17-2005 09:52 AM
how to convert text(html) back to html. d1l2w3 Linux - Software 4 04-08-2005 09:16 PM
Can't launch Konqueror for HTML Sirius78 Linux - Newbie 4 08-28-2004 02:55 AM
Konqueror + file:/usr/share/doc/HTML/index.html jon_k Linux - Software 2 11-25-2003 06:06 AM
konqueror and index.html Domino Linux - General 5 04-19-2002 08:56 AM


All times are GMT -5. The time now is 07:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration