LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-12-2012, 10:56 AM   #1
cristi92b
Member
 
Registered: May 2011
Posts: 86

Rep: Reputation: Disabled
KDE cannot mount cdrom


I try to mount a dvd with dolphin but it tells me:
Code:
An error occurred while accessing 'CD', the system responded: The requested operation has failed.: Error mounting: mount exited with exit code 1: helper failed with:
mount: only root can mount /dev/sr0 on /mnt/cdrom
It's an ATA DVD-RW drive, user is in cdrom and cdrw groups.

USB works.

Code:
# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't 
# needed); notail increases performance of ReiserFS (at the expense of storage 
# efficiency).  It's safe to drop the noatime options if you want and to 
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sda5               /boot                   ext2            noauto,noatime  1 2
/dev/sda6               /                       ext4            noatime         0 1
/dev/sda7               none                    swap            sw              0 0
/dev/sda2               /Windows/C              ntfs            noatime         0 1
/dev/sda3               /Windows/D              ntfs            noatime         0 1
/dev/cdrom              /mnt/cdrom              auto            noauto,ro       0 0
/dev/fd0                /mnt/floppy             auto            noauto          0 0
Also, /dev/sda5 won't mount on /boot
Code:
An error occurred while accessing '64.0 MiB Hard Drive', the system responded: The requested operation has failed.: Error mounting: mount exited with exit code 1: helper failed with:
mount: only root can mount /dev/sda5 on /boot
How can I solve this?
-------------
Code:
$ mount /dev/cdrom /mnt/cdrom
mount: only root can do that
$ mount /dev/sr0 /mnt/cdrom
mount: only root can do that

--------------

KDE version: 4.8.5

Distribution: Gentoo with vanilla kernel 3.2.21

Last edited by cristi92b; 09-12-2012 at 11:48 AM.
 
Old 09-12-2012, 12:04 PM   #2
cristi92b
Member
 
Registered: May 2011
Posts: 86

Original Poster
Rep: Reputation: Disabled
It works, I edited fstab:

Code:
# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't 
# needed); notail increases performance of ReiserFS (at the expense of storage 
# efficiency).  It's safe to drop the noatime options if you want and to 
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sda5               /boot                   ext2            noauto,noatime  1 2
/dev/sda6               /                       ext4            noatime         0 1
/dev/sda7               none                    swap            sw              0 0
/dev/sda2               /Windows/C              ntfs            noatime         0 1
/dev/sda3               /Windows/D              ntfs            noatime         0 1
/dev/cdrom              /mnt/cdrom              auto            noauto,ro,users 0 0
/dev/fd0                /mnt/floppy             auto            noauto          0 0
Problem solved!

added users to /dev/cdrom opts.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome mount cdrom, kde not (((X))) Linux - Desktop 2 03-10-2008 05:53 PM
How does KDE mount my cdrom, any why can't I? EAD Linux - Newbie 9 03-11-2006 04:16 AM
mount cdrom under kde marekjs Slackware 11 05-02-2005 06:23 PM
KDE cdrom mount problem rhinoss Fedora 3 12-11-2004 06:15 PM
FreeBSD 5.1 (KDE 3.1) I can't mount my CDROM selvyn Linux - Hardware 0 02-27-2004 12:27 PM


All times are GMT -5. The time now is 01:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration