LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-30-2015, 01:13 PM   #1
danan
LQ Newbie
 
Registered: May 2015
Posts: 3

Rep: Reputation: Disabled
kali linux didn't recognize wireless networks


Hi,
i'm new in kali linux.
i have an issue with the wifi connections.
installing the newwst version of kali from the official website on virtual box.
plug the USB wireless adapter (TP-LINK).
also, i noticed wlan0 on #ifconfig command.
on the network setting configure NAT (also tried with NAT bridged)

my problem is that - i cannot see any wireless networks.
i followed few guides from youtube and here but with no luck.
it show me that i'm wired connected.
i attached screenshot bellow.
please kindly assist me.


additional information:
#airmon-ng start wlan0
when i type #ifconfig, i saw that wlan0 changed to wlan0mon
and with#airodump-ng command on wlan0mon i didn't see any wireless network as well


iwconfig
Quote:
root@kali:~# iwconfig
eth0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSIDff/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry short limit:7 RTS thrff Fragment thrff
Encryption keyff
Power Managementff

lo no wireless extensions.
lsmod
Quote:
root@kali:~# lsmod | grep rt
rt2800usb 26222 0
rt2x00usb 17642 1 rt2800usb
rt2800lib 81543 1 rt2800usb
rt2x00lib 46315 3 rt2x00usb,rt2800lib,rt2800usb
mac80211 511777 3 rt2x00lib,rt2x00usb,rt2800lib
cfg80211 425751 2 mac80211,rt2x00lib
crc_ccitt 12347 1 rt2800lib
parport_pc 26287 0
parport 35699 1 parport_pc
usbcore 199549 7 rt2x00usb,ohci_hcd,ohci_pci,rt2800usb,ehci_hcd,ehci_pci,usbhid
lsusb
Quote:
root@kali:~# lsusb
Bus 001 Device 003: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 003: ID 80ee:0021 VirtualBox USB Tablet
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
ifconfig

Quote:
root@kali:~# ifconfig
eth0 Link encap:Ethernet HWaddr 08:00:27:dc:d0:01
inet addr:192.168.1.22 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::a00:27ff:fedc:d001/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:68 errors:0 dropped:0 overruns:0 frame:0
TX packets:41 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:7485 (7.3 KiB) TX bytes:4163 (4.0 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:20 errors:0 dropped:0 overruns:0 frame:0
TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1200 (1.1 KiB) TX bytes:1200 (1.1 KiB)

wlan0 Link encap:Ethernet HWaddr 90:f6:52:10:0f:d2
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
iw wlan0 info
Quote:
root@kali:~# iw wlan0 info
Interface wlan0
ifindex 4
type managed
wiphy 1
iwlist scan
Quote:
root@kali:~# iwlist scan
eth0 Interface doesn't support scanning.

wlan0 No scan results

lo Interface doesn't support scanning.
uname -a
Quote:
root@kali:~# uname -a
Linux kali 3.18.0-kali3-amd64 #1 SMP Debian 3.18.6-1~kali2 (2015-03-02) x86_64 GNU/Linux
cat /etc/network/interfaces
Quote:
root@kali:~# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp
thanks

Last edited by danan; 05-30-2015 at 01:15 PM.
 
Old 05-30-2015, 02:24 PM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,406
Blog Entries: 6

Rep: Reputation: Disabled
Hi:

I'm not the best with WiFi.

It's best to wait for a member that has more experience in WiFi.

In the meantime I looked online at TP-Link usb adapters and I found that there are at least 2 models.
The WN722N and the TL-WN725N. There may be more, not sure.
Try to find out which one you have.

When you are using a usb dongle for WiFi you will have to blacklist the onboard WiFi card.

If you have the TL-WN725N model of the TP-Link this should help.
http://brilliantlyeasy.com/ubuntu-li...river-install/
 
Old 05-30-2015, 02:53 PM   #3
danan
LQ Newbie
 
Registered: May 2015
Posts: 3

Original Poster
Rep: Reputation: Disabled
thanks,

the model is : TP-LINK TL-WN7200ND
 
Old 05-30-2015, 03:14 PM   #4
danan
LQ Newbie
 
Registered: May 2015
Posts: 3

Original Poster
Rep: Reputation: Disabled
now i'm facing with another problem:

whe
Quote:
m i tried to connect the wifi adapter to the virutal box machine i get the following error:

Failed to attach the USB device Ralink 802.11 n WLAN [0101] to the virtual machine Kali linux 1.1.0.

USB device 'Ralink 802.11 n WLAN' with UUID {7f34436d-c0a1-4398-88e4-46913d8ad640} is busy with a previous request. Please try again later.

Result Code: E_INVALIDARG (0x80070057)
Component: HostUSBDevice
Interface: IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}
 
Old 05-30-2015, 03:18 PM   #5
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Wheezy/Jessie/Sid, Linux Mint DE
Posts: 4,493

Rep: Reputation: 635Reputation: 635Reputation: 635Reputation: 635Reputation: 635Reputation: 635
Aren't you supposed to use the network connection of the VB host for your guest system? Or are you trying to communicate directly with the hardware on purpose?

jlinkels
 
Old 05-30-2015, 04:14 PM   #6
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Vbox doesn't use the wireless, try
Quote:
ifup eth0
or
Quote:
dhclient eth0
It shows here that you have network address on eth0
Quote:
root@kali:~# ifconfig
eth0 Link encap:Ethernet HWaddr 08:00:27:dc:d0:01
inet addr:192.168.1.22 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::a00:27ff:fedc:d001/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:68 errors:0 dropped:0 overruns:0 frame:0
TX packets:41 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:7485 (7.3 KiB) TX bytes:4163 (4.0 KiB)

Last edited by EDDY1; 05-30-2015 at 04:18 PM.
 
Old 05-30-2015, 05:10 PM   #7
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,004

Rep: Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620
The USB wireless device can only be used by the host or the guest and not both. If iyou wish to use it with the guest you have to stop using it from the host and you may need to install the non-free VirtualBox additions from the Oracle website.
Once you stop using the USB wireless device on the host you connect it to the guest by checking the USB settings for that guest. You do have to ensure that the relevant drivers and firmware, where applicable, are installed in the guest OS in order to use the USB wireless device a you would in an OS running on a real system.
I have successfully used a USB wireless device in a VB guest so I know it is possible.
 
1 members found this post helpful.
Old 05-30-2015, 09:49 PM   #8
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,406
Blog Entries: 6

Rep: Reputation: Disabled
Quote:
Originally Posted by 273 View Post
The USB wireless device can only be used by the host or the guest and not both. If iyou wish to use it with the guest you have to stop using it from the host and you may need to install the non-free VirtualBox additions from the Oracle website.
Once you stop using the USB wireless device on the host you connect it to the guest by checking the USB settings for that guest. You do have to ensure that the relevant drivers and firmware, where applicable, are installed in the guest OS in order to use the USB wireless device a you would in an OS running on a real system.
I have successfully used a USB wireless device in a VB guest so I know it is possible.
Since op has the TP-Link TLWN 7200ND would the Debian non-free firmware work?

Does the onboard nic's drver have to be blacklisted in order for it (the usb dongle) to work in VM?

Last edited by Ztcoracat; 05-30-2015 at 09:50 PM.
 
Old 05-31-2015, 07:17 AM   #9
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,004

Rep: Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620
Quote:
Originally Posted by Ztcoracat View Post
Since op has the TP-Link TLWN 7200ND would the Debian non-free firmware work?

Does the onboard nic's drver have to be blacklisted in order for it (the usb dongle) to work in VM?
I don't know what firmware would be required but a quick google seems to suggest that it may not be needed. There's usually no need to blacklist anything -- the USB wireless device just has to be enabled in the guest. It might be worth setting the network for the guest to "not attached" though to avoid any confusion.
 
1 members found this post helpful.
Old 05-31-2015, 05:18 PM   #10
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,406
Blog Entries: 6

Rep: Reputation: Disabled
Quote:
Originally Posted by 273 View Post
I don't know what firmware would be required but a quick google seems to suggest that it may not be needed. There's usually no need to blacklist anything -- the USB wireless device just has to be enabled in the guest. It might be worth setting the network for the guest to "not attached" though to avoid any confusion.
Thanks 273:-Got it.
 
Old 05-31-2015, 05:24 PM   #11
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,406
Blog Entries: 6

Rep: Reputation: Disabled
danan:

Did the ifup eth0 or the dhclient eth0 command that EDDY1 posted for you work?

If Kali Linux is your guest, what distribution is your host?

If I can find the driver I will post it for you.
Sometimes drivers are hard to find.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] slackware doesn't recognize kali luks partition wigan Linux - Security 1 12-24-2014 03:46 PM
wheezy didn't recognize CDROM piobair Debian 5 08-07-2013 05:31 PM
Ubuntu didn't recognize a sound dtphong_1989 Linux - Hardware 1 07-29-2010 11:34 PM
kernel 2.6 didn't recognize the CDROM, while 2.4 did abd_bela Debian 1 02-01-2006 12:30 PM
SuSE 9.0 didn't recognize kb or mouse walterbyrd Linux - Distributions 2 04-15-2004 12:36 AM


All times are GMT -5. The time now is 10:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration