LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-05-2006, 04:16 AM   #1
obstinatesod
Member
 
Registered: Apr 2005
Location: Shetland
Distribution: PClinuxOS, Suse 10.0, Mandriva, Alinux,
Posts: 126
Blog Entries: 1

Rep: Reputation: 15
K3b won't write to disk


Hi, I have suse 10.0 and can not write cd's with K3b. It seems to do everything it supposed to except actully write to the cd. It says its writing but its not. I went to the Novel site and tried the K3b download from there but the result was the same. If I try to erase a cd it locks up the PC, any ideas? Adrian
 
Old 01-05-2006, 06:16 AM   #2
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Debian + Ubuntu
Posts: 4,358

Rep: Reputation: 57
Try going to the K3B tools menu and run the K3B configuration thingy... it sounds like you either have a permissions problem (ie the user running k3b does not have permissions to write to the device) or it hasn't detected that your CD drive is actually a burner. The configuration tool should help determine (if not fix) which of these it is.
 
Old 01-05-2006, 09:30 AM   #3
obstinatesod
Member
 
Registered: Apr 2005
Location: Shetland
Distribution: PClinuxOS, Suse 10.0, Mandriva, Alinux,
Posts: 126
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Hi Thymox, I get this message when K3b starts,"cdrdao will be run without root privileges
It is highly recommended to configure cdrdao to run with root privileges to increase the overall stability of the burning process.
Solution: Use K3bSetup to solve this problem."
Q where is this set-up? I looked in Tools there is a link in settings "configure k3b" but can't really find the set up, there is a greyed out button under Misc, sub heading system "check system configuration"
 
Old 01-05-2006, 10:03 AM   #4
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Debian + Ubuntu
Posts: 4,358

Rep: Reputation: 57
Try running k3b as root. You should be able to do this by running (from a command line):
Code:
$ kdesu k3b
 
Old 01-05-2006, 12:56 PM   #5
obstinatesod
Member
 
Registered: Apr 2005
Location: Shetland
Distribution: PClinuxOS, Suse 10.0, Mandriva, Alinux,
Posts: 126
Blog Entries: 1

Original Poster
Rep: Reputation: 15
thanks Thymox, when it ran from the command line the only option I got was to alter the write speed,tried that no joy. just says the same when I try, it says 'writing' but doesn't this used to work when I ran suse 9.2 and my pc hasn't changed.

Last edited by obstinatesod; 01-05-2006 at 04:29 PM.
 
Old 01-05-2006, 06:47 PM   #6
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Debian + Ubuntu
Posts: 4,358

Rep: Reputation: 57
OK, well the error message you're getting says to run the cdrdao programme with root privileges. I was hoping you could use k3b's own tools, but you can still do this manually.
  • Open a console/terminal.
  • Become root (use "su" then enter root's password).
  • Run whereis cdrdao and note where the executable file is (it should be /usr/bin/cdrdao but it might be different).
  • Still as root, run chmod +s /usr/bin/cdrdao (obviously substituting /usr/bin/cdrdao for where your real cdrdao executable is located, from step 3).
  • Exit from being root.
  • Try running k3b again as a normal user and see if it still throws up the same error.
Hope this helps.

(Note: the above action is known as "making the file 'setuid'". It's used so that when the file is run, it runs as the person who owns the file (ie root) rather than the person trying to execute it (ie user).)
 
Old 01-06-2006, 03:42 AM   #7
obstinatesod
Member
 
Registered: Apr 2005
Location: Shetland
Distribution: PClinuxOS, Suse 10.0, Mandriva, Alinux,
Posts: 126
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Hi Thymox thank you, before I had got your last post I had uninstalled k3b and reinstalled, it seems to be more functional with grayed out boxes now working, however It still wasn't writing. I followed your instructions and got this message on start up:

" Writing device OPTORITE - CD-RW CW4002 is automounted.
Automounting can cause problems with CD/DVD writing, especially with rewritable media. Although it might all work just fine it is recommended to disable automounting completely for now.
Solution: Replace the automounting entries in /etc/fstab with old-fashioned ones."
also the set up button is attached to this i ran it but can't see what to do? is it about adding permissions?

I do not know replace the automounting entries in /etc/fstab, can you advise please, thanks Adrian



here is the debugging output?

System
-----------------------
K3b Version: 0.12.10

KDE Version: 3.4.2 Level "b"
QT Version: 3.3.4
Kernel: 2.6.13-15.7-default
Devices
-----------------------
OPTORITE CD-RW CW4002 100E (/dev/hdc, ) at /media/cdrecorder [CD-R; CD-RW; CD-ROM] [CD-ROM; CD-R; CD-RW] [SAO; TAO; RAW; SAO/R96P; SAO/R96R; RAW/R16; RAW/R96P; RAW/R96R]

SAMSUNG DVD-ROM SD-616E F505 (/dev/hdd, ) at /media/dvd [CD-ROM; DVD-ROM] [DVD-ROM; CD-ROM] [None]
K3b
-----------------------
Size of filesystem calculated: 921

Used versions
-----------------------
cdrecord: 2.1

cdrecord
-----------------------
/usr/bin/cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
/usr/bin/cdrecord: Permission denied. WARNING: Cannot set priority using setpriority().
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
/usr/bin/cdrecord: Warning: not running as root user, fs= option ignored.
scsidev: '/dev/hdc'
devname: '/dev/hdc'
scsibus: -2 target: -2 lun: -2
Warning: Open by 'devname' is unintentional and not supported.
Linux sg driver version: 3.5.27
/usr/bin/cdrecord: Warning: using inofficial libscg transport code version (okir@suse.de-scsi-linux-sg.c-1.83-resmgr-patch '@(#)scsi-linux-sg.c 1.83 04/05/20 Copyright 1997 J. Schilling').
SCSI buffer size: 64512

cdrecord command:
-----------------------
/usr/bin/cdrecord -v gracetime=2 dev=/dev/hdc speed=12 -tao driveropts=burnfree -eject -multi -xa -tsize=921s -

mkisofs
-----------------------
921
INFO: UTF-8 character encoding detected by locale settings.
Assuming UTF-8 encoded filenames on source filesystem,
use -input-charset to override.

mkisofs command:
-----------------------
/usr/bin/mkisofs -gui -graft-points -volid K3b data project -volset -appid K3B THE CD KREATOR (C) 1998-2005 SEBASTIAN TRUEG AND THE K3B TEAM -publisher -preparer -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-aaria5/k3bL8xsva.tmp -rational-rock -hide-list /tmp/kde-aaria5/k3bNqExgc.tmp -joliet -hide-joliet-list /tmp/kde-aaria5/k3btIfiqb.tmp -full-iso9660-filenames -iso-level 2 -path-list /tmp/kde-aaria5/k3bwbjLxb.tmp

Last edited by obstinatesod; 01-06-2006 at 04:18 AM.
 
Old 01-06-2006, 10:38 AM   #8
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Debian + Ubuntu
Posts: 4,358

Rep: Reputation: 57
You would need to edit your fstab entries. If you make them look like the following, then you can still use the drives, but they won't automatically "mount" when you put a disc in:
Code:
/dev/hdc    /media/cdrecorder    iso9660    ro,user,noauto     0       0
/dev/hdd    /media/dvd    iso9660    ro,user,noauto     0       0
Make sure there are no discs in the drives, or that you have forcibly *unmounted* them before doing this.
 
Old 01-06-2006, 11:06 AM   #9
obstinatesod
Member
 
Registered: Apr 2005
Location: Shetland
Distribution: PClinuxOS, Suse 10.0, Mandriva, Alinux,
Posts: 126
Blog Entries: 1

Original Poster
Rep: Reputation: 15
thanks agian but can you explain how I actuly do it? I opened a file by using Kate, this is it:

/dev/hda3 / reiserfs acl,user_xattr 1 1
/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda2 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/dvd /media/dvd subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/cdrecorder /media/cdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0
none /subdomain subdomainfs noauto 0 0
/dev/cdrecorder2 /media/cdrecorder2 subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/dvd2 /media/dvd2 subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0

Last edited by obstinatesod; 01-07-2006 at 03:04 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
k3b don't let me write (not a permission's problem) tuxtracker Linux - Software 1 01-05-2006 09:36 AM
can not write on new DVD writer with k3b JeTa Linux - Hardware 4 07-12-2005 06:31 PM
K3B won't let my DVD+RW drive write CD-Rs Acid-Face Linux - Newbie 3 11-02-2004 07:56 PM
error message in k3b whan i try to write on disk SlackwareMan Linux - Software 1 08-02-2004 11:04 PM
k3b fails to write dvd Fahiem Linux - Software 2 07-28-2004 04:55 AM


All times are GMT -5. The time now is 11:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration