LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-19-2004, 08:38 PM   #1
Harp00
Member
 
Registered: Jun 2003
Location: Venice Italy
Distribution: Slackware 12.0 kernel 2.6.21.5
Posts: 284

Rep: Reputation: 30
K3b problem


Hi,
I installed k3b on Slackware 9.0, but after i configured it, i run it and this message appeared:

No support for ATAPI with cdrdao
You will not be able to use all your reading devices as copy sources since there is at least one not configured to use SCSI emulation and your system does not support ATAPI with cdrdao.
Solution: The best and recommended solution is to enable ide-scsi (SCSI emulation) for all writer devices. This way you won't have any problems.

What does it mean?
Could anybody explain me what have i to do?
Thank you in advance.
 
Old 01-19-2004, 10:06 PM   #2
Greyweather
Member
 
Registered: Aug 2003
Distribution: Ubuntu 4.10
Posts: 311

Rep: Reputation: 30
If you are using a 2.4.xx generation kernel, such as the one that is installed by default in Slackware, then you must enable scsi emulation at boot-time (lilo) in order to burn cds at all with an IDE or ATAPI drive.

If you have upgraded to the 2.6.x generation of kernels, then you can burn cds without scsi emulation. However you need to do at as a track-at-once burn rather than disk-at-once as the aplication which burns in DOA mode, cdrdao, does not yet have the ability to work on IDE or ATAPI cd writers.

The cvs version of cdrao supposedly works with IDE or ATAPI in the 2.6.x kernel, so you can try that if you want.
 
Old 01-20-2004, 01:20 PM   #3
Harp00
Member
 
Registered: Jun 2003
Location: Venice Italy
Distribution: Slackware 12.0 kernel 2.6.21.5
Posts: 284

Original Poster
Rep: Reputation: 30
I am using 2.4.xx kernel version.
The problem is i am using grub and the boot point is in Hda3 under Red Hat.

Hda1 Windows XP
Hda2 Swap
Hda3 Red Hat
Hda4 Slackware

How have i to modify grub in order to enable SCSI emulation?
 
Old 01-20-2004, 03:02 PM   #4
Greyweather
Member
 
Registered: Aug 2003
Distribution: Ubuntu 4.10
Posts: 311

Rep: Reputation: 30
Go into grub.conf and add hdc=ide-scsi to the end of your kernel line. This assumes hdc is your cd burner. In my case it was hdd instead.
 
Old 01-21-2004, 09:54 AM   #5
Harp00
Member
 
Registered: Jun 2003
Location: Venice Italy
Distribution: Slackware 12.0 kernel 2.6.21.5
Posts: 284

Original Poster
Rep: Reputation: 30
I already have this line.
This is my grub.conf in /boot/grub

default=0
timeout=10
splashimage=(hd0,2) /boot/grub/splash.xpm.gz
title Red Hat Linux
root (hd0,2)
kernel /boot/vmlinuz-2.4.20-18.9 ro root =LABEL=/ hdc=ide-scsi
title Windows XP
rootnoverify (hd0,0)
chainloader +1
title Slackware
root (hd0,3)
kernel /boot/vmlinuz-ide-2.4.20 ro root=/dev/hda4 hdc=ide-scsi
 
Old 01-21-2004, 02:17 PM   #6
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Do you have any other optical devices?
Quote:
You will not be able to use all your reading devices as copy sources since there is at least one not configured to use SCSI emulation and your system does not support ATAPI with cdrdao.
Enable scsi emulation for them too: 'hdd=ide-scsi' (assuming it's on Secondary master). Ex:
Code:
default=0
timeout=10
splashimage=(hd0,2) /boot/grub/splash.xpm.gz
title Red Hat Linux
root (hd0,2)
kernel /boot/vmlinuz-2.4.20-18.9 ro root =LABEL=/ hdc=ide-scsi hdd=ide-scsi
title Windows XP
rootnoverify (hd0,0)
chainloader +1
title Slackware
root (hd0,3)
kernel /boot/vmlinuz-ide-2.4.20 ro root=/dev/hda4 hdc=ide-scsi hdd=ide-scsi
 
Old 01-23-2004, 11:32 AM   #7
Harp00
Member
 
Registered: Jun 2003
Location: Venice Italy
Distribution: Slackware 12.0 kernel 2.6.21.5
Posts: 284

Original Poster
Rep: Reputation: 30
Thank you very much aaa
K3b seems to work correctly now.
Can you also tell me why i get this message when i try to mount a CDrom

mount /dev/cdrom
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Will k3b convert mp3's to wavs for burning audio cds? And prob with k3b 0.11 Alvis Linux - Software 5 08-02-2007 08:38 AM
FC3 - K3b not recognizing mp3s w/ k3b-mp3 installed! Forezt Linux - Software 2 07-25-2006 06:43 PM
k3b problem bruse Linux - Newbie 3 09-14-2005 08:02 AM
k3b problem koriel Linux - Software 2 07-14-2005 04:14 AM
k3b problem archish Slackware 6 12-04-2003 04:06 PM


All times are GMT -5. The time now is 08:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration