LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 07-01-2003, 04:39 AM   #1
JC404
Member
 
Registered: Dec 2002
Distribution: Red Hat 9
Posts: 123

Rep: Reputation: 15
K3B Dependency Questions


I received a long message in terminal but technically the problems are as follows:

checking for pthread_create in -lpthread... yes
checking for extra includes... no
checking for extra libs... no
checking for libz... -lz
checking for libpng... -lpng -lz -lm
checking for libjpeg6b... no
checking for libjpeg... no
configure: WARNING: libjpeg not found. disable JPEG support.
checking for Qt... configure: error: Qt (>= Qt 3.0.3) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
[root@localhost k3b]# cd \

I looked for libjpeg on the 3 RedHat 9 discs and found the following files:
libjpeg-devel-6b-26.i386.rpm
libjpeg-6b-26.i386.rpm

The problem is that they're either installed or doesn't run properly (displays "Preparing System Update" and then disappears).

In http://www.ijg.org/ which is supposedly (?) the group that develops this, there are files under http://www.ijg.org/files/ but start with jpeg instead of lib. Are these the correct files to download? I checked the 3 RedHat 9 discs again and these files aren't there under RPMS.

For the Qt error, these files are found under the RedHat 9 discs under RPMS:
qt-ODBC-3.1.1-6.i386.rpm
qt2-Xt-2.3.1-13.i386.rpm
qt2-devel-2.3.1-13.i386.rpm
qt2-designer-2.3.1-13.i386.rpm
qt2-static-2.3.1-13.i386.rpm

Again, they either only display "Preparing System Update" then closes prematurely or are already installed.

What am I doing wrong?
 
Old 07-01-2003, 06:45 AM   #2
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 12.04, Fedora 17, Mint 16, Chakra
Posts: 3,618

Rep: Reputation: Disabled
rpm is very closemouthed about its error[condition]s.

Try man rpm. If I remember correctly, you can specify options -v (verbose) but certainly -qa (query all?). So try rpm -qa | grep Qt* to find out what Trolltech-software is installed -- as opposed to what is on your discs. Same for libjpeg*
 
Old 07-02-2003, 12:22 AM   #3
JC404
Member
 
Registered: Dec 2002
Distribution: Red Hat 9
Posts: 123

Original Poster
Rep: Reputation: 15
I downloaded the software off the Trolltech site. Here's what happened:

checking for libpng... -lpng -lz -lm
checking for libjpeg6b... no
checking for libjpeg... no
configure: WARNING: libjpeg not found. disable JPEG support.
checking for Qt... configure: error: Qt (>= Qt 3.0.3) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
[root@localhost k3b]# rpm -qa | grep qt
qtcups-2.0-15
qt-3.1.1-6
[root@localhost k3b]#
 
Old 07-02-2003, 03:30 AM   #4
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 12.04, Fedora 17, Mint 16, Chakra
Posts: 3,618

Rep: Reputation: Disabled
Quote:
Originally posted by JC404 I downloaded the software off the Trolltech site.
Fine. Which version, and what exact name? Did you install it without any errors? You don't say...
Quote:
Originally posted by JC404
Please check your installation!

Quote:
Originally posted by JC404
For more details about this problem, look at the end of config.log.!
Well, did you? What's it say?
Quote:
Originally posted by JC404
root@localhost k3b]# rpm -qa | grep qt
qtcups-2.0-15
qt-3.1.1-6
[root@localhost k3b]#
Yeah, sure.
Qt, Linux is case sensitive...
 
Old 07-02-2003, 04:19 AM   #5
mhearn
Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
you need qt-devel installed
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Will k3b convert mp3's to wavs for burning audio cds? And prob with k3b 0.11 Alvis Linux - Software 5 08-02-2007 07:38 AM
FC3 - K3b not recognizing mp3s w/ k3b-mp3 installed! Forezt Linux - Software 2 07-25-2006 05:43 PM
rpm dependency questions giovannym Linux - Newbie 1 07-08-2005 05:24 PM
how to solve failed dependency when dependency exists dwcramer Linux - Newbie 2 08-24-2004 09:03 PM
libc.so.6 dependency questions giovannym Linux - Newbie 5 07-10-2004 02:12 AM


All times are GMT -5. The time now is 11:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration