LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   k3b and group permission (http://www.linuxquestions.org/questions/linux-newbie-8/k3b-and-group-permission-540073/)

wongdg 03-23-2007 09:10 PM

k3b and group permission
 
I am rather confused with setting group permission for cd burning. Initially intended to burn my cd with k3b (the GUI frontend), it failed to detect cdrecord and cdrdao, both of which i have installed.

Running k3b from terminal returns the following:
wongdg@dg-bbc-debian:~$ k3b
find: /dev/.static: Permission denied
k3b: WARNING: KGenericFactory: instance requested but no instance name or about data passed to the constructor!
k3b: ERROR: (K3bSongManager) Can't open file /home/wongdg/.kde/share/apps/k3b/songlist.xml
kdecore (KAction): WARNING: KActionCollection::KActionCollection( QObject *parent, const char *name, KInstance *instance )
k3b: ERROR: (K3b

I decided to test my user permission to execute its backend - cdrecord, directly.

Still I had no luck with it:
wongdg@dg-bbc-debian:~$ cdrecord
bash: /usr/bin/cdrecord: Permission denied

even though I had added myself in the group "cdrom" (set by k3b as the burning group)
dg-bbc-debian:/usr/bin# less /etc/group |grep cdrom
cdrom:x:24:hal,wongdg

a listing of which groups i have added myself:
dg-bbc-debian:/usr/bin# less /etc/group |grep wongdg
cdrom:x:24:hal,wongdg
staff:x:50:wongdg
azureus:x:114:wongdg
wongdg:x:1000:

So i am wondering do i need to adduser --system myself in order for it to work??

Thanks to anyone who can shed a light on this issue.

In fact the same thing happens with my firefox which i have made its files to belong to group "staff" and user "root". I added myself to group "staff", but it just won't connect to internet, though pages on localhost work ok.

Wilson

lavacano201014 03-24-2007 07:44 PM

For the CD burning problem: Figure out what device file is your burner.
As root (or with sudo): chmod 777 <input device here>

For the Firefox problem: Make sure the Internet settings are all working. Try other methods you find, and as a last resort:
As root (or with sudo): chmod 777 /firefoxdir/firefox

Replace /firefoxdir with whereever Firefox was installed.

mdmaddux 08-02-2007 07:16 PM

Thank you. Simple permission change -- /dev/hdc to 777...
Just too easy.
But works like a charm.

'loha


All times are GMT -5. The time now is 08:10 AM.