LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-11-2007, 11:14 AM   #1
cnybud
LQ Newbie
 
Registered: Mar 2007
Posts: 2

Rep: Reputation: 0
Just a tad frustrated


I am using SUSE 10.2 if this is relevant.

Okay I have an external USB 2.0 hard drive, with 200GB of space. It used to be a back up hard drive for my windows computer but when I ditched Windows yesterday (I hope for good) I put everything that was on the hard drive on DVD and erased the disk.

Now I want to use this harddrive as a back up source for my new machine. I tried using the partitioner in Yast, and I thought I had done things right but whenever I try to write something to the disk it says no can do , not enough permissions. WHat the heck does that mean? WHy do i need permission to access my own hard drive? None of the other folders and such are like this with the exception of lost and found and root, which I can understand.

Any help at all would be appreciated.

(By the way if it matters any at all I had bought a new Vista system with 2gb of ram, core 2 duo processor, and a 500 gb hard drive in raid, and dumped Vista for SUSE. My friends think I am nuts, but I gotta try something else, nd right now a Mac is out of my price range)
 
Old 03-11-2007, 12:02 PM   #2
anupamsr
Member
 
Registered: Sep 2004
Location: India
Distribution: Kubuntu, Archlinux, Suse, Gentoo, Mandrake
Posts: 370

Rep: Reputation: 30
There could be a couple of possibilities:
1. Your USB 2.0 hard disk in NTFS. This may happen because most of the vendors sell pre formatted NTFS hard disks. I personally, hence, format all the harddisks in FAT32, if I am planning to use them in Windows, otherwise ext3.
2. You really don't have permissions. Have you mounted the harddisk as root and trying to write as a user or something?

Following outputs will be good (after mounting):
$ mount
$ ls -l /path/to/hard/disk
 
Old 03-11-2007, 12:27 PM   #3
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Random thoughts:
If you are using CD or DVD for backup, I would always make at least 2 copies. If the data is critical, some would say also re-copy the disks at regular intervals.

If Linux is becoming your dominant OS, then format everything ext3. Windows can read this using something like ext2fsd.

Using ext3, you can set the permissions on the external USB drive just as you would on the internal(s). As already noted, you need to check to see that the drive is not getting mounted read-only.

/etc/mtab shows what is actually mounted
/etc/fstab is the instructions for mounting
 
Old 03-11-2007, 12:35 PM   #4
cnybud
LQ Newbie
 
Registered: Mar 2007
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks.

I formatted the hard drive in fat 32 and now I can read and write to it. Amazing. I do appreciate the help.
 
Old 03-11-2007, 04:32 PM   #5
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 83
Just as an FYI, note that FAT32 cannot support POSIX permissions (ie, the different permission levels to access a file, namely those granted to the user, group, and others) These permissions are visible as the familiar r (read), w (write), and x (execute) privileges for each type of user.

In brief, using FAT32 for backup purposes is OK as long as the files you are copying to it don't need to retain the specific original permissions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I am frustrated (HELP) dimsun Linux - Newbie 3 11-02-2004 09:29 PM
Please help, very frustrated! m3s3lf Linux - Newbie 10 10-28-2004 10:50 AM
Frustrated Linuxfrog Linux - Hardware 2 06-23-2004 06:06 PM
I turned off a tad too many services... need to "restore settings" wondering how... Justin33 Linux - Newbie 2 10-29-2003 08:02 PM
To lighten' your mood a tad... taz.devil General 8 04-10-2002 12:30 AM


All times are GMT -5. The time now is 12:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration