LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-13-2010, 06:20 PM   #1
st0rmchaser
LQ Newbie
 
Registered: Mar 2009
Posts: 5

Rep: Reputation: 0
Joe Editor Question


Greetings,

I'm not a newbie to Linux, but I'm a newbie to LQ. I've searched the internet for an answer to an issue I'm having with JOE, to no avail.

For my editing purposes, I HATE word wrap. I've read the man page extensively and nothing I try works.

To disable word wrap, it says, simply edit the joerc file and place --wordrap in the first column. Done. It works for .pl, and it works for .c (seems to be built in for C). Bottom line, I cannot disable word wrap for all text files, or at least the ones I want to edit. Has anyone solved this?

Thanks.
 
Old 11-14-2010, 03:04 AM   #2
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
your symptoms are the default behavior. any files than has .c .h or .p suffix will have wordwrap disabled.

wordwrap can be dynamically toggled with ctrl-T W

putting --wordwrap globally should have cleared the option - you are right. have you tried invoking it on the CLI?

Put:

*
--wordwrap

in the second section.

you want to be sure that your options are not overwritten by subsequent entries.
 
Old 11-14-2010, 09:54 AM   #3
st0rmchaser
LQ Newbie
 
Registered: Mar 2009
Posts: 5

Original Poster
Rep: Reputation: 0
joe --wordrwap

Invoking ^Tw has always worked but is a nuisance.

*
--wordwrap

... really should be working! I have no idea why the thing has gone brain dead. Hopefully Joe is aware of this and would issue a patch, but I did install the latest version just to make sure he hadn't already. He hadn't.

Invoking --wordwrap from the command line is what I'm doing now with the help of a one-line script.

Thanks...
 
Old 01-07-2017, 03:41 AM   #4
vwal
LQ Newbie
 
Registered: Aug 2009
Location: North Texas, U.S.
Distribution: Ubuntu, CentOS
Posts: 7

Rep: Reputation: 0
Lightbulb The solution here!

Old thread, but if someone stumbles across this (like I did).. I also have used an alias for a long time to disable wordwrap, like so:

Code:
joe() { /usr/bin/joe --linums --wordwrap -nonotice -backpath ~/edit-cache/ "$@" }
But.. it only disables the wordwrap for the first file; if I were to add "--wordwrap" in front of every file as a "local option" it would work, but how to separate the "global-options" from the "local-options" of the first filename, as the man page points out:

Code:
joe [global-options] [ [local-options] filename ]...
But, alas, that was not necessary. I found the answer on Joe's support forums:

Quote:
Find ftyperc. It should be in the same place as the installed joerc. "mkdir $HOME/.joe" . Copy ftyperc to "$HOME/.joe" . Edit it and remove any offending "-wordwrap"s.
And indeed, on my Ubuntu system in /etc/joe/ there is ftyperc file. Once I added a space in front of all of the occurrences of -wordwrap in that file (hence commenting them out per Joe's conf file format), all files now have the wordwrap disabled by default (previously only the first file had the wordwrap disabled per my alias)! This system is a single-user system, so I edited /etc/joe/ftyperc file directly, but on multi-user systems you may want to follow the suggestion to copy the ftyperc file to your home directory, and make the overrides to comment out/delete -wordwrap occurrences out there.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Question in Vi editor Ajit Gunge Linux - Newbie 6 02-01-2010 12:21 PM
LXer: Joe Barr, Linux.com Editor - Obituary by Mark Kent LXer Syndicated Linux News 0 07-30-2008 12:41 PM
LXer: In memoriam: Linux evangelist and Linux.com editor Joe Barr LXer Syndicated Linux News 0 07-11-2008 03:50 PM
JOE editor displaying garbage under screen MaXxX2 Linux - Software 1 10-28-2004 05:27 AM
vi editor question lpriyamb Linux - Software 4 09-23-2003 01:22 AM


All times are GMT -5. The time now is 07:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration