LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-19-2012, 01:27 PM   #1
oldunixgeek
LQ Newbie
 
Registered: Nov 2011
Location: Oregon
Distribution: Slackware
Posts: 5

Rep: Reputation: Disabled
jedit - How to type non-English characters?


This has nothing to do with pot or whitney houston, so I'm posting
here rather than in 'General'. It's a newbie-kinda-question, anyway.

I need to type a nice, formal letter to a foreign consulate in
Spanish, and I've set character encoding to iso-8859-15, but jedit
fails to explain the obvious to a moron like me: How do I type
the non-English characters? What freakin' keys do I hit?

I've been Googling and man paging (xmodmap, etc) for hours and
still haven't the foggiest idea! I'm probably searching for the
wrong things...duh.

I'm running Slackware 13.37 if it makes any difference.

Many thanks for specific, by-the-numbers help.
 
Old 02-19-2012, 01:33 PM   #2
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
Why not just copy and paste from google translate or similar translation web site ?

Else, I think you need a spanish keyboard layout in X
(Option "XkbLayout" "es"), but I don't know exact settings
 
Old 02-19-2012, 02:09 PM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,683

Rep: Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284Reputation: 3284
Ref. post #2. Any latin keybord layout in X :
? A section in /etc/X11/xorg.conf ?
Or keyboard layout in the KDE control center ?
... and your US keybord will type latin characters :

The ]} key can do ~ ^ ( For e.g.: Espaa , Park Gel ).

The += key : `

Etc. etc.

.

Last edited by knudfl; 02-19-2012 at 02:15 PM.
 
Old 02-19-2012, 02:34 PM   #4
oldunixgeek
LQ Newbie
 
Registered: Nov 2011
Location: Oregon
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: Disabled
Thanks Cedrik, but this is the first of several sure-to-be very lengthy
letters, so I'm not going to copy and paste a zillion characters. I want
to be able to simply type in Spanish.

Without bringing X down and back up everytime I want to switch between
languages, either.

knudfl: When I type those characters into jedit, I just get those
characters...nothing else. I don't run KDE or any desktop dealie,
just fvwm.

Addendum to o/p:

'mined' is the answer (has great documentation!), but requires
function keys and mine (for some reason probably even unknown
to HP/Compaq) don't work, so I'm back to fiddling with jedit.

Isn't there anyone out there who regularly types in something
besides English on a standard US-101-key keyboard? There HAS
to be! Please....?!?!?
 
Old 02-19-2012, 02:59 PM   #5
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,789

Rep: Reputation: 1590Reputation: 1590Reputation: 1590Reputation: 1590Reputation: 1590Reputation: 1590Reputation: 1590Reputation: 1590Reputation: 1590Reputation: 1590Reputation: 1590
Hi,

Have a look at this post here at LQ

Regards
 
Old 02-20-2012, 12:24 PM   #6
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 4,512

Rep: Reputation: 1407Reputation: 1407Reputation: 1407Reputation: 1407Reputation: 1407Reputation: 1407Reputation: 1407Reputation: 1407Reputation: 1407Reputation: 1407
What you need to do is to enable a Compose key. You can then get "" by typing <Compose><'><a>, "" with <Compose><~><n>, and even "" with <Compose><?><?>. A convenient key to use is the Windows menu key, but feel free to use anything that's spare.

Presumably you will have to set it up with xmodmap; I don't suppose fvwm will do it! Incidentally, why iso-8859-15 when everyone has been using UTF-8 for years?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
non-english characters with ntfs-3g in slackware 13 jmcustiel Slackware 16 10-22-2009 02:16 PM
Cant type non-english characters in mysql monitor ifmn Programming 2 09-08-2008 06:20 PM
Displaying non-English characters in Mdk 10.1 kenhall4 Mandriva 1 03-11-2005 01:53 AM
Portuguese characters on Redhat 9 in english fbenites Linux - Newbie 3 10-29-2003 11:35 AM
Input non-english characters gigsvoo Linux - General 2 12-29-2002 09:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration