LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-15-2012, 01:39 PM   #1
gnunewbie
LQ Newbie
 
Registered: Mar 2012
Posts: 5

Rep: Reputation: Disabled
JDK 1.4 installation problems on 64 bit GNU/Linux


I'm trying to install JDK 1.4 (j2sdk-1_4_2_10-linux-ia64-rpm.bin) on a 64 bit GNU/Linux. When I get past the License agreement, I get the following error:


Unpacking...
tail: cannot open `+511' for reading: No such file or directory
Checksumming...
1
The download file appears to be corrupted. Please refer
to the Troubleshooting section of the Installation
Instructions on the download page for more information.
Please do not attempt to install this archive file.

Note: I have already successfully installed JDK 1.6 in the same path and I do not have access to the root.

Any ideas?

Thanks
 
Old 03-16-2012, 06:36 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,633

Rep: Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268
Welcome to LQ.

j2sdk-1_4_2_10-linux-ia64-rpm.bin : A corrupt old package ?

Old versions : http://www.oracle.com/technetwork/ja...ve-139210.html
> http://www.oracle.com/technetwork/ja...14-419411.html

> http://www.oracle.com/technetwork/ja...4.2_10-oth-JPR

> j2sdk-1_4_2_10-linux-ia64-rpm.bin

Or use an updated version like : j2sdk-1_4_2_19-linux-ia64-rpm.bin

.
 
Old 03-16-2012, 08:45 AM   #3
gnunewbie
LQ Newbie
 
Registered: Mar 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
Thanks Knudfl, but when I tried to install the j2sdk-1_4_2_19-linux-ia64-rpm.bin, I got the following error after license acceptance:


Do you agree to the above license terms? [yes or no]
yes
Unpacking...
Checksumming...
0
0
Extracting...
./j2sdk-1_4_2_19-linux-ia64-rpm.bin: line 442: ./install.sfx.29101: cannot execute binary file
Done.

Thanks
 
Old 03-16-2012, 09:02 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,633

Rep: Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268
Which Linux OS are you using ? ? Name and version, please.
Which shell are you using ? Bash ?

Sometimes a file suffix .bin will work better with the command 'sh <name>.bin',
like : sh j2sdk-1_4_2_19-linux-ia64-rpm.bin

I can check the package next week, and may be come up with a solution.

.
 
Old 03-16-2012, 09:26 AM   #5
gnunewbie
LQ Newbie
 
Registered: Mar 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
The uname gave this

Linux 2.6.18-238.19.1.el5 #1 SMP Sun Jul 10 08:43:41 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux

I'm using Bash.

I tried the sh j2sdk-1_4_2_19-linux-ia64-rpm.bin and the same thing happened.

Note: I also tried installing the j2sdk-1_4_2_19-linux-ia64.bin and the same thing happened.

Thanks,

Priya
 
Old 03-17-2012, 04:40 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,633

Rep: Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268
OK, one more thing : Which software is it, that requires the old java 1.4 ?
(Most often you will be able to use java 1.5 ( or 1.6 ) with all old software.)

And : At the time when java 1.4 was used, all applications were 32bits, not 64 ?

All available java 1.4 rpm packages, I can find from that time, are 32bits.
> http://rpm.pbone.net > Search >> Advanced Search :
Check all >>> keyword = j2sdk-1.4
Example : j2sdk-1.4.2_12-fcs.i586.rpm
ftp://ftp.icm.edu.pl/vol/rzm2/linux-...2-fcs.i586.rpm

.

Last edited by knudfl; 03-17-2012 at 05:12 AM.
 
Old 03-19-2012, 11:52 AM   #7
gnunewbie
LQ Newbie
 
Registered: Mar 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
I was not able to install that version. It gave:

-bash-3.2$ ./j2sdk-1.4.2_12-fcs.i586.rpm
-bash: ./j2sdk-1.4.2_12-fcs.i586.rpm: cannot execute binary file

It did not work with the sh command as well. Same error.

I'm actually trying to install JReports 7.3 which needs jdk 1.4.2.

Thank you again.
 
Old 03-19-2012, 12:14 PM   #8
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,633

Rep: Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268
Well, when you have no root access, an rpm package cannot be installed.
( j2sdk-1.4.2_12-fcs.i586.rpm ).


32bits : May be try with a j2sdk-1_4_2_19-linux-i586.bin
http://www.oracle.com/technetwork/ja...4.2_30-sol-JPR

.
 
Old 03-19-2012, 01:20 PM   #9
gnunewbie
LQ Newbie
 
Registered: Mar 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
I tried both sh and ./ ways to execute the j2sdk-1_4_2_19-linux-i586.bin file and I got the following error this time around:


Do you agree to the above license terms? [yes or no]
yes
Unpacking...
Checksumming...
0
0
Extracting...
UnZipSFX 5.40 of 28 November 1998, by Info-ZIP (Zip-Bugs@lists.wku.edu).
unzipsfx: cannot find myself! [./install.sfx.26005]
Done.
 
Old 03-20-2012, 05:39 PM   #10
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,633

Rep: Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268Reputation: 3268
OK, another suggestion.
Unpack j2sdk-1.4.2_12-fcs.i586.rpm in your /home/<name>/,
like : mkdir java4 && cd java4/ &&
rpm2cpio j2sdk-1.4.2_12-fcs.i586.rpm | cpio -idmv

.. Will provide :
java4/usr/java/j2sdk1.4.2_12/jre/bin/java ,
java4/usr/java/j2sdk1.4.2_12/jre/lib/i386 , etc. etc.

.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Sun JDK 7 on Redhat 5.4 64 bit Linux prajakta_s_c Red Hat 1 09-06-2011 03:30 PM
LXer: Running 32-bit Applications on 64-bit Debian GNU/Linux LXer Syndicated Linux News 2 01-06-2010 12:26 PM
32 bit JDK vs 64 bit JDK paragkalra Linux - Software 4 11-28-2007 05:36 AM
JDK 1.6.0 32-bit and 64-bit on Same System (FC6)? sancho Fedora 3 01-23-2007 06:20 AM


All times are GMT -5. The time now is 08:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration