LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Java error - Debian GNU/Linux 6.0 Squeeze/sid (http://www.linuxquestions.org/questions/linux-newbie-8/java-error-debian-gnu-linux-6-0-squeeze-sid-811340/)

DebianUserfg 05-31-2010 04:11 PM

Java error - Debian GNU/Linux 6.0 Squeeze/sid
 
Hi guys, I'm trying to play Runescape on Debian 6.0, I have the following Java packages installed:

sun-java6-bin
sun-java6-jre
sun-java6-plugin

I get the following error in Java's console:

Code:

Java Plug-in 1.6.0_20
Using JRE version 1.6.0_20-b02 Java HotSpot(TM) Server VM
User home directory = /home/fox
----------------------------------------------------
c:  clear console window
f:  finalize objects on finalization queue
g:  garbage collect
h:  display this help message
l:  dump classloader list
m:  print memory usage
o:  trigger logging
q:  hide console
r:  reload policy configuration
s:  dump system and deployment properties
t:  dump thread list
v:  dump thread stack
x:  clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------


load: class loader.class not found.
java.lang.ClassNotFoundException: loader.class
        at sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:219)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
        at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Plugin2ClassLoader.java:532)
        at sun.plugin2.applet.Plugin2Manager.createApplet(Plugin2Manager.java:2940)
        at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Plugin2Manager.java:1444)
        at java.lang.Thread.run(Thread.java:619)
Caused by: java.net.ConnectException: Network is unreachable
        at java.net.PlainSocketImpl.socketConnect(Native Method)
        at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
        at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
        at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
        at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
        at java.net.Socket.connect(Socket.java:529)
        at sun.net.NetworkClient.doConnect(NetworkClient.java:161)
        at sun.net.www.http.HttpClient.openServer(HttpClient.java:394)
        at sun.net.www.http.HttpClient.openServer(HttpClient.java:529)
        at sun.net.www.http.HttpClient.<init>(HttpClient.java:233)
        at sun.net.www.http.HttpClient.New(HttpClient.java:306)
        at sun.net.www.http.HttpClient.New(HttpClient.java:323)
        at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:860)
        at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:801)
        at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:726)
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1049)
        at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:373)
        at sun.plugin2.applet.Applet2ClassLoader.getBytes(Applet2ClassLoader.java:535)
        at sun.plugin2.applet.Applet2ClassLoader.access$000(Applet2ClassLoader.java:51)
        at sun.plugin2.applet.Applet2ClassLoader$1.run(Applet2ClassLoader.java:192)
        at java.security.AccessController.doPrivileged(Native Method)
        at sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:189)
        ... 6 more
Exception: java.lang.ClassNotFoundException: loader.class

Runescape fails to load, I have tried loading Runescape in both Epiphany and Iceweasel, no success... What can I do to fix this? or is this just an error with the Debian 6.0?

Thank you

rokytnji 05-31-2010 06:25 PM

You can refer to my post HERE

I had the same error running AntiX 8.5. The install script (kmathern script) works for Debian Sid also.

craigevil 05-31-2010 08:00 PM

take a look at squeeze : in case you have no network connection with java apps ... - http://www.linuxquestions.org/questi...a-apps-778366/


All times are GMT -5. The time now is 05:02 AM.