LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Java 1.4.0 SDK install problem (http://www.linuxquestions.org/questions/linux-newbie-8/java-1-4-0-sdk-install-problem-89418/)

insom 09-04-2003 10:51 PM

Java 1.4.0 SDK install problem
 
Hey,

I am running Mandrake 9 and i am an extreme newbie to linux. I extracted an rpm for linux 1.4.0., now I am trying to compile a file in /home/simon/Documents. typing javac Simple.java does not work (I will sort that out later, i heard it has something to do with .bash_profile, or classpath or something...) so i was looking at another thread here and a guy said he used

/usr/java/j2sdk1.4.X/bin/javac Simple.java

but for me, when I try that I get this message...

Error: failed /usr/java/j2sdk1.4.0/jre/lib/i386/client/libjvm.so, because libstdc++-libc6.1-1.so.2: cannot open shared object file: No such file or directory

So, this is probably a really simple problem (caused as a result of me not having a clue as to what I am doing), but i would really appreciate if I could get some help with this. Thanks!

Simon

osprey0331 09-05-2003 12:49 AM

you will need to set a parameter in the .bash_profile or in the .profile used to source to define the java classpath so that when you run the javac is knows where to find the classes and libraries...try inserting the lines to either your .bash_profile, .bashrc or .profile

JAVA_HOME=[location of jdk]; export JAVA_HOME
CLASSPATH=$JAVA_HOME/class; export CLASSPATH

muneebs123 09-05-2003 02:04 AM

i aslo had been facing this problem. The only way to solve it for all the user is to goto /etc and then edit bashrc
In the bottom of the file write
export PATH="/usr/java/jdk1.4/bin/":$PATH
export JAVAHOME="/usr/java/jdk1.4//"
export CLASSPATH=".:/usr/java/jdk1.4/"

shinu_scorpion 09-05-2003 05:01 AM

Friend
Another way is
goto
1./etc/profile
2.Set
pathmunge (path of j2sdk*.*/bin)
3. Reboot the system


All times are GMT -5. The time now is 08:46 AM.