LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-18-2005, 06:38 AM   #1
polemon
Member
 
Registered: Jun 2005
Distribution: Fedora 18, Ubuntu 11.10, Ubuntu Server 11.10, DamnSmallLinux 3.4.4, FreeDOS 1.1, OpenBSD 5.0
Posts: 194

Rep: Reputation: 31
Angry Japanese Input System does not work


Hi, i need to use the Japanese Input system under FC4 but it just refuses to work.
I successfully installed Kinput2, Canna, and even Im-ja.
Everything seem to work, no errors, configuration can be done without problems.
I even placed the Im-Ja applet on my panel, the GNOME keyboard indicator and
the KDE keyboard tool.
The problem is, i can't switch to the japanese conversion systemnot with the applet on the panel and not by the Key kombination Shift+Space.
I ran the im-ja-conf so it knows it is needed.
it just won't work.
when i try to change they keaboard layout in the Keyboard preference in GNOME, i get this error:

Code:
Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
60802000

If you report this situation as a bug, please include:
- The result of <b>xprop -root | grep XKB</b>
- The result of <b>gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd</b>
xprop -root | grep XKB yields:
Code:
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "de", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "jp", "", ""
and gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd yields:
Code:
 layouts = [de]
 model = pc105
 overrideSettings = false
 options = []
The KDE Program and the GNOME program seem to correlate, where the KDE Layout switcher is in charge. i can switch between the german and Japanese input. when i switch to japanese, is till can't enter any Kanam but the basic layout changes to QWERTY.
Then i need to change layout in the GNOME tool to " " (it's just a blank space), THEN i can directly input some Katakana.

I read somewher in the forums, that i need to change my LC_CTYPE variable to ja_JP.UTF-8.
Somtimes it's LC_ALL they wrote.
I declared both (they were undefined before). but nothing has changed.

please help if you can, I'm totally confused by now
 
Old 09-18-2005, 11:00 PM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 52
just sugestions even though i know very little about this
add
export LANG=ja_JP
export LC_CTYPE=ja_JP
to .bash_profile in your home directory
or startx with
LANG=ja_JP LC_CTYPE=ja_JP startx
or
export LANG=ja_JP
export LC_CTYPE=ja_JP
startx
you also have to make sure the canna server is starting at boot or start it manually
look in top or kde system guard and see if canna is running
 
Old 09-19-2005, 09:55 AM   #3
polemon
Member
 
Registered: Jun 2005
Distribution: Fedora 18, Ubuntu 11.10, Ubuntu Server 11.10, DamnSmallLinux 3.4.4, FreeDOS 1.1, OpenBSD 5.0
Posts: 194

Original Poster
Rep: Reputation: 31
THAN YOU!!!
it was the LC_CTYPE variable that needs to be in .bash_profile!

I can enter Kana without any problems now, I'll try to fix the conversion issue now.

However, The Problem that pops up everytime i log in, or change keyboard settings, is not gone (I persume it has a different cause than Japanese Input).

Thanks again,

--polemon
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ctrl+Shift Unicode input gone, after installing Japanese Input Methodes polemon Linux - Newbie 1 09-20-2005 05:17 PM
japanese input system UltraSoul Solaris / OpenSolaris 5 05-07-2005 02:37 PM
Japanese input? clausawits Fedora 4 08-02-2004 06:59 AM
Japanese Input Phil Healey Linux - General 3 07-18-2003 01:10 PM
Japanese input Bernhard Linux - General 0 01-29-2002 06:33 AM


All times are GMT -5. The time now is 09:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration