LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 07-07-2004, 04:30 PM   #16
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30

GJITEN is installed and nearly configured. It works quite nicely, as far as I can see after a few minutes of trying.

Now there is one problem I can't find a solution to.
I have two users on this machine, myself and my wife.

When I run gjiten with my user id, it works. When it is run with my wife's ID it does not take Japanese input.

Does it have to do with ja_JP stuff?
 
Old 07-07-2004, 04:34 PM   #17
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30
I was exporting wrong things....

export LC_ALL=ja_JP

fixed all problems! Thanks to every contributor to this post!

Last edited by linuxfond; 07-07-2004 at 04:35 PM.
 
Old 07-07-2004, 04:52 PM   #18
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30
I was too happy to quickly
As I reboot, the problems come back regardless whether I run exports or not.

Now as I try to run gjiten with my wife's ID, I get
(process:1995): Gdk-WARNING **:
locale not supported by C library....
Using the fallback 'C' locale...
-bash-2.05b$

gjiten doesn't take Japanese input.
 
Old 07-07-2004, 04:59 PM   #19
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by Kroenecker
3 What else... to get Openoffice to properly display Japanese characters, I made and alias soffice='export GDK.... =1 soffice' where I edited some environmental variable that lets Openoffice know that it should use ...maybe utf8 encoding or something. Nonetheless, I went from illegible toolbar entries and filenames to something useable.
I feel I have to do something wih GDK, but I don't know what. I am right?
 
Old 07-08-2004, 11:10 AM   #20
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30
Just an extra detail: in order to input japanese, I have to call a program via shell script saved in /usr/local/bin

Here are the contents of this script (japanese.bash):
#!/bin/bash
XMODIFIERS="@im=kinput2"
LANGUAGE=en_us.UTF-8
LC_CTYPE=ja_JP.UTF-8 ${1+"$@"}&
exit

To call KMail in order to input Japanese I have to call it: $ japanese.bash kmail

When I call KMail via this script, KMail sometimes disguises Japanese emails in my inbox. However, if I call it directly (without the japanese.bash), these emails appear in the correct encoding.

Having said this, I suspect that my japanese.bash has to be improved. Do you have any suggestions?
Are there any other fixes?


N.B. Here is the output of set.
LANG=en_BE.UTF-8
LANGUAGE=en_BE.UTF-8:en_GB:en
LC_ADDRESS=en_BE.UTF-8
LC_COLLATE=en_BE.UTF-8
LC_CTYPE=en_BE.UTF-8
LC_IDENTIFICATION=en_BE.UTF-8
LC_MEASUREMENT=en_BE.UTF-8
LC_MESSAGES=en_BE.UTF-8
LC_MONETARY=en_BE.UTF-8
LC_NAME=en_BE.UTF-8
LC_NUMERIC=en_BE.UTF-8
LC_PAPER=en_BE.UTF-8
LC_TELEPHONE=en_BE.UTF-8
LC_TIME=en_BE.UTF-8

I am also not sure if I should change something here... set is the same with other IDs on this PC. Can this be different, should it be?

Last edited by linuxfond; 07-08-2004 at 11:16 AM.
 
Old 07-08-2004, 05:46 PM   #21
Kroenecker
Member
 
Registered: May 2003
Location: The States
Distribution: Gentoo
Posts: 245

Rep: Reputation: 30
Quick note:

This is what I used to get soffice showing me the proper fonts. I don't know that this will fix your current problem.

alias soffice='GDK_USE_XFT=1 soffice'

Gotta go to work.

Good luck!

By the way, I assume that you have looked through the documentation for gjiten. (Not to be condescending or anything. Really.)

http://gjiten.sourceforge.net/gjiten...html#ximerrors

Last edited by Kroenecker; 07-08-2004 at 05:57 PM.
 
Old 07-09-2004, 06:44 AM   #22
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30
SHAME ON ME!
I did not read carefully ximerrors.
Of course, now it works.
 
Old 07-09-2004, 07:06 AM   #23
Kroenecker
Member
 
Registered: May 2003
Location: The States
Distribution: Gentoo
Posts: 245

Rep: Reputation: 30
It would be nice if you posted what you had to do to fix everything. I know that I am going to try gjiten etc after I compile LFS 5.1.1.

Anyway, glad to hear that you are smooth sailing.
 
Old 07-09-2004, 09:32 AM   #24
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30
OK, I will try to rewind back in my memory. I hope every step was conscious.
Now some Japanese complain about my emails being gisguised. They do not seem to be able to solve the problem by switching between encodings. What could be the reason?
 
Old 07-09-2004, 09:39 AM   #25
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Original Poster
Rep: Reputation: 30
gjiten installation was straightforward.

./configure, make, make install.
Once it is installed you need to run it $gjiten
At the first run it askes to configure it. You need to tell it where the dictionaries are (dictionaries should be in utf-8, so I had to convert them into utf-8!)
Gjiten doesn't automatically detect where the dictionaries are, and by default it thinks it is in gjiten folder. I donno why, in my case it was in kiten. I run slocate edict and kanjidic in order to figure out the correct paths.
After that I enabled LC_ALL=jp_JP in Gjiten (there is section under Fonts tab).
This is necessary in order to input Japanese. In any case I have to run it via japanese.bash
That's it.

Now, the problem was with my wife's ID, where gjiten did not receive Japanese input, unless I run export LC_ALL=jp_JP. The problem was solved after you pointed me to the ximerrors of the manual. I forgot to enable LC_ALL in the gjiten itself.

Last edited by linuxfond; 07-09-2004 at 09:40 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kmail - how to get it to see old Kmail folders? pseudofilosofen Suse/Novell 1 04-19-2005 05:52 AM
Kmail - how to get it to see old Kmail folders? pseudofilosofen Suse/Novell 1 04-18-2005 01:53 PM
Japanese input? clausawits Fedora 4 08-02-2004 06:59 AM
Japanese Input Phil Healey Linux - General 3 07-18-2003 01:10 PM
AIM in Japanese??? phishead Linux - General 1 01-06-2002 05:25 PM


All times are GMT -5. The time now is 06:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration