LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-22-2003, 05:12 AM   #1
sph90457
Member
 
Registered: Oct 2003
Location: UK
Posts: 52

Rep: Reputation: 15
It was working and now I have a bad superblock...


Hello,

I have a pc with a 80 gig wd hd that is split 40 gig xp 40 gig win m/e (hda) and a maxtor 40 gig hd split 20 gig win m/e 20 gig Redhat 9......

I installed m/e on the second drive incase I lost my first and could just unplug power from the primary and then boot from that.....It worked when I first set it up fine......

Then I installed redhat9, to boot RH9 I use a floppy..... and this two has been working for about 2 weeks.....

last night I finally got my onboard lan/nic to work and went to bed a happy chap....

Then I tried to boot up this morning and got the following:-

mounting root file system
hdb2: bad access :block= 2, count= 2
end_request: I/O error, dev 03:42 (hdb), sector 2
ext3-fs: unable to read superblock
mount: error 22 mounting ext3
pivot: pivot_root (/sysroot,/sysroot/initrd) failed: 2
umount /initrd/proc failed: 2
free unused kernel mem: 128k freed
kernel panic: no init found. try passing init= option to kernel......

I had something similar a few weeks back and thought i'd broke something so I re-installed.

Pls tell me that this has knackered everything....I will be very unhappy if I have to re-install win m/e and all the crap with it and then do a full rh9 re-install.....

pls help......I was just getting the feel for linux and then something like this puts you right off
 
Old 10-22-2003, 05:37 AM   #2
Caysho
Member
 
Registered: Sep 2002
Location: Perth Australia
Distribution: OpenWRT, debian, Ubuntu
Posts: 135
Blog Entries: 20

Rep: Reputation: 15
http://www.linuxquestions.org/questi...ead+superblock
has some info.
 
Old 10-22-2003, 06:22 AM   #3
sph90457
Member
 
Registered: Oct 2003
Location: UK
Posts: 52

Original Poster
Rep: Reputation: 15
weird

I tried logging in about 10 times and still no joy....

I unplugged my primary hd and tried again and still no joy......

then when I tried it again I typed linux text (dunno why)..... and the bloomin thing booted up fine.....

I plugged my primary master back in and rebooted and at the linux prompt hit enter like I normally do and it booted fine......

What a weird system......

least its working again for the moment....

cheers

Ran.
 
Old 10-22-2003, 06:50 PM   #4
sph90457
Member
 
Registered: Oct 2003
Location: UK
Posts: 52

Original Poster
Rep: Reputation: 15
Grrrrrrrrrrrrrr !!!!!!!!!!!! :(

I've come home and booted my pc up and its doing the same thing again....

for some reason it thinks my maxtor 40 gig drive is a 136 gig and if I change it and do an auto detect in the bios it reckons it's a 4 gig...........

This is well crap.......my other pc that has a dedicated 10 gig hd works evrytime.........

Not a happy camper -----------------------------AGAIN
 
Old 10-22-2003, 06:57 PM   #5
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
A long shot, but-

Do you have the Master/Slave jumpers on the drive(s) set correctly?
 
Old 10-22-2003, 07:24 PM   #6
Caysho
Member
 
Registered: Sep 2002
Location: Perth Australia
Distribution: OpenWRT, debian, Ubuntu
Posts: 135
Blog Entries: 20

Rep: Reputation: 15
to me it sounds like the hard drive's electronics are screwy, if the BIOS is reporting it incorrectly.

ime jumper settings cause the drives to be longer in detection, but they still report correctly - unless it's some BIOS time out problem related to jumpers causing it to default to 4 GB, someting I haven't seen or heard of before.

have you got another pc you can check the drive in ?
 
Old 10-22-2003, 09:01 PM   #7
sph90457
Member
 
Registered: Oct 2003
Location: UK
Posts: 52

Original Poster
Rep: Reputation: 15
Weird

I changeed it in the bios to a lba drive and it reported 4 gig in the bios.....

I rebooted into xp and checked the drive and it said that it was full and needed formatting...hmmmm me thought.........

I went back into the bios and selected auto and it came up with maxtor 40 gig.....I exited the bios and it booted off floppy fine......

I have my drives on cable select because I could not get the maxtor jumper switch to be a slave.....you have two of the little black connector for the setting at the back and the one that you need to bridge to be a slave is not there... according to the pictures on the top of the hd thats how its meant to be, and I have had it working before but I couldn't remember how so I set them to cable select - maybe it has something to do with that........


Ran.
 
Old 10-22-2003, 09:32 PM   #8
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
Yes, it would. The cable select option requires a special cable; if you're just using a regular IDE cable, you'll have problems.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: wrong fs type, bad option, bad superblock on /dev/hdc3 Lordandmaker Linux - Hardware 15 06-05-2011 09:55 AM
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, Adil_uk Linux - Hardware 9 02-16-2005 06:50 PM
mount: wrong fs type, bad option, bad superblock on /dev/sdb1 pmoreira Linux - Hardware 5 02-26-2004 11:31 AM
wrong fs type, bad option, bad superblock on /dev/hdb1, ldare Linux - Hardware 1 02-12-2004 10:03 PM
wrong fs type, bad option, bad superblock on /dev/cdrom, or too many mounted file sy TheCyberDude Linux - Software 1 02-11-2002 01:44 PM


All times are GMT -5. The time now is 10:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration