LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-30-2004, 10:50 AM   #16
feuer
LQ Newbie
 
Registered: Aug 2003
Posts: 11

Original Poster
Rep: Reputation: 0

I copied the install shield files to ~/c/Program Files/Common Files$ and changed to bit depth to 16. Unfortunatelly these things didn't solve the problem...

Same errors occur every time I try to install SPWaW:
Code:
err:wave:OSS_WaveOutInit /dev/mixer1: No such device
err:wave:OSS_WaveInInit /dev/mixer1: No such device
fixme:ntdll:NtQueryInformationToken (0x50,2,0x41a710c0,4096,0x406cf77c): stub
err:msg:DispatchMessageA BeginPaint not called on WM_PAINT for hwnd 0x10023!
err:msg:DispatchMessageA BeginPaint not called on WM_PAINT for hwnd 0x10023!
err:msg:DispatchMessageA BeginPaint not called on WM_PAINT for hwnd 0x10023!
err:dc:DCE_FreeWindowDCE [0x30030] GetDC() without ReleaseDC()!
err:msg:DispatchMessageA BeginPaint not called on WM_PAINT for hwnd 0x10023!
err:dc:DCE_FreeWindowDCE [0x40030] GetDC() without ReleaseDC()!
err:msg:DispatchMessageA BeginPaint not called on WM_PAINT for hwnd 0x10023!
err:msg:DispatchMessageA BeginPaint not called on WM_PAINT for hwnd 0x10023!
err:msg:DispatchMessageA BeginPaint not called on WM_PAINT for hwnd 0x10023!
err:msg:DispatchMessageA BeginPaint not called on WM_PAINT for hwnd 0x10023!
err:msg:DispatchMessageA BeginPaint not called on WM_PAINT for hwnd 0x10023!
err:msg:DispatchMessageA BeginPaint not called on WM_PAINT for hwnd 0x10023!
err:msg:DispatchMessageA BeginPaint not called on WM_PAINT for hwnd 0x10023!
err:msg:DispatchMessageA BeginPaint not called on WM_PAINT for hwnd 0x10023!
err:msg:DispatchMessageA BeginPaint not called on WM_PAINT for hwnd 0x10023!
wine: Unhandled exception (thread 000b), starting debugger...
WineDbg starting on pid a
Can't find file for ELF 'wine-kthread' ((nil))
Loaded debug information from ELF 'wine-pthread' ((nil))
Breakpoint 1 at 0x4000c690 (_end+0x3fefa180)
Loaded debug information from ELF '/usr/local/lib/libwine.so.1' (0x40027000)
No debug information in ELF '/lib/tls/libpthread.so.0' (0x4003f000)
No debug information in ELF '/lib/tls/libc.so.6' (0x4004f000)
No debug information in ELF '/lib/tls/libdl.so.2' (0x40188000)
No debug information in ELF '/lib/tls/libm.so.6' (0x4018b000)
No debug information in ELF '/lib/ld-linux.so.2' (0x40000000)
Loaded debug information from ELF '/usr/local/lib/wine/ntdll.dll.so' (0x401af000)
Loaded debug information from ELF '/usr/local/lib/libwine_unicode.so.1' (0x4022e000)
No debug information in ELF '/lib/tls/libnss_compat.so.2' (0x40330000)
No debug information in ELF '/lib/tls/libnsl.so.1' (0x40338000)
No debug information in ELF '/lib/tls/libnss_nis.so.2' (0x4034d000)
No debug information in ELF '/lib/tls/libnss_files.so.2' (0x40357000)
Loaded debug information from ELF '/usr/local/lib/wine/kernel32.dll.so' (0x40480000)
Loaded debug information from ELF '/usr/local/lib/wine/winmm.dll.so' (0x406d0000)
Loaded debug information from ELF '/usr/local/lib/wine/user32.dll.so' (0x40743000)
Loaded debug information from ELF '/usr/local/lib/wine/gdi32.dll.so' (0x40898000)
Loaded debug information from ELF '/usr/local/lib/wine/advapi32.dll.so' (0x40923000)
Loaded debug information from ELF '/usr/local/lib/wine/version.dll.so' (0x40957000)
Loaded debug information from ELF '/usr/local/lib/wine/lz32.dll.so' (0x40971000)
Loaded debug information from ELF '/usr/local/lib/wine/comdlg32.dll.so' (0x40987000)
Loaded debug information from ELF '/usr/local/lib/wine/shell32.dll.so' (0x40a10000)
Loaded debug information from ELF '/usr/local/lib/wine/ole32.dll.so' (0x40aa1000)
Loaded debug information from ELF '/usr/local/lib/wine/rpcrt4.dll.so' (0x40b21000)
Loaded debug information from ELF '/usr/local/lib/wine/shlwapi.dll.so' (0x40b6e000)
Loaded debug information from ELF '/usr/local/lib/wine/comctl32.dll.so' (0x40bcc000)
Loaded debug information from ELF '/usr/local/lib/wine/winspool.drv.so' (0x40c83000)
Loaded debug information from ELF '/usr/local/lib/wine/oleaut32.dll.so' (0x40caa000)
No debug information in ELF '/usr/lib/libjpeg.so.62' (0x40d4c000)
Loaded debug information from ELF '/usr/local/lib/wine/wsock32.dll.so' (0x40d6a000)
Loaded debug information from ELF '/usr/local/lib/wine/ws2_32.dll.so' (0x40d87000)
Loaded debug information from ELF '/usr/local/lib/wine/iphlpapi.dll.so' (0x40daf000)
Loaded debug information from ELF '/usr/local/lib/wine/netapi32.dll.so' (0x40dcf000)
No debug information in ELF '/usr/lib/libfreetype.so.6' (0x40e08000)
No debug information in ELF '/usr/lib/libz.so.1' (0x40e75000)
No debug information in ELF '/usr/lib/libfontconfig.so.1' (0x40e86000)
No debug information in ELF '/usr/lib/libexpat.so.1' (0x40ead000)
Loaded debug information from ELF '/usr/local/lib/wine/x11drv.dll.so' (0x40ecd000)
No debug information in ELF '/usr/X11R6/lib/libSM.so.6' (0x40f62000)
No debug information in ELF '/usr/X11R6/lib/libICE.so.6' (0x40f6b000)
No debug information in ELF '/usr/X11R6/lib/libXrandr.so.2' (0x40f82000)
No debug information in ELF '/usr/lib/libXrender.so.1' (0x40f86000)
No debug information in ELF '/usr/X11R6/lib/libXv.so.1' (0x40f8e000)
No debug information in ELF '/usr/X11R6/lib/libXext.so.6' (0x40f93000)
No debug information in ELF '/usr/X11R6/lib/libX11.so.6' (0x40fa1000)
No debug information in ELF '/usr/lib/tls/libGL.so.1' (0x41068000)
No debug information in ELF '/usr/lib/tls/libGLcore.so.1' (0x410d1000)
No debug information in ELF '/usr/lib/libXcursor.so.1' (0x41635000)
No debug information in ELF '/usr/X11R6/lib/X11/locale/lib/common/xlcDef.so.2' (0x41626000)
No debug information in ELF '/usr/X11R6/lib/X11/locale/lib/common/ximcp.so.2' (0x41682000)
Loaded debug information from ELF '/usr/local/lib/wine/imm32.dll.so' (0x416a0000)
Loaded debug information from ELF '/usr/local/lib/wine/wineoss.drv.so' (0x416bd000)
Loaded debug information from ELF '/usr/local/lib/wine/msacm.drv.so' (0x416fe000)
Loaded debug information from ELF '/usr/local/lib/wine/msacm32.dll.so' (0x41716000)
Loaded debug information from ELF '/usr/local/lib/wine/midimap.drv.so' (0x41850000)
No debug information in ELF '/lib/libnss_db.so.2' (0x418ca000)
No debug information in ELF '/usr/lib/libdb3.so.3' (0x419b4000)
No debug information in 32bit DLL 'E:\irsetup.exe' (0x400000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\NTDLL.DLL' (0x401d0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\KERNEL32.DLL' (0x404b0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\ADVAPI32.DLL' (0x40930000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\GDI32.DLL' (0x408b0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\USER32.DLL' (0x40770000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\WINMM.DLL' (0x406e0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\LZ32.DLL' (0x40980000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\VERSION.DLL' (0x40960000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\RPCRT4.DLL' (0x40b40000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\OLE32.DLL' (0x40ac0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHLWAPI.DLL' (0x40b90000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\COMCTL32.DLL' (0x40be0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHELL32.DLL' (0x40a30000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\WINSPOOL.DRV' (0x40c90000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\COMDLG32.DLL' (0x409a0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\OLEAUT32.DLL' (0x40cd0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\IPHLPAPI.DLL' (0x40dc0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\WS2_32.DLL' (0x40d90000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\WSOCK32.DLL' (0x40d70000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\NETAPI32.DLL' (0x40de0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\X11DRV.DLL' (0x40ee0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\IMM32.DLL' (0x416b0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\WINEOSS.DRV' (0x416d0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\MSACM32.DLL' (0x41720000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\MSACM.DRV' (0x41710000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\MIDIMAP.DRV' (0x41860000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\IR32_32.DLL' (0x10000000)
Unhandled exception: page fault on read access to 0x00000271 in 32-bit code (0x401e9a7b).
In 32-bit mode.
0x401e9a7b (MODULE_InitDLL+0x10b [loader.c:697] in NTDLL.DLL): movl     0x264(%ebx),%eax
697         if (TRACE_ON(relay))
Wine-dbg>WineDbg terminated on pid a
Hmm...I think there is something wrong with the register. Because these erros occur when SPWaW installer is trying to "Register files":
Code:
wine: Unhandled exception (thread 000b), starting debugger...
WineDbg starting on pid a
Can't find file for ELF 'wine-kthread' ((nil))
Loaded debug information from ELF 'wine-pthread' ((nil))
Breakpoint 1 at 0x4000c690 (_end+0x3fefa180)
Loaded debug information from ELF '/usr/local/lib/libwine.so.1' (0x40027000)
No debug information in ELF '/lib/tls/libpthread.so.0' (0x4003f000)
No debug information in ELF '/lib/tls/libc.so.6' (0x4004f000)
....
....
etc.
Any ideas how to fix this?
 
Old 03-30-2004, 11:02 AM   #17
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Sorry, no (I'm so not a Wine coder)-- but they might well have an idea on the Wine User's Mailing List. A few developers hang out there, as well as users who may have had this problem. Wine is just too complex-- if the solution is not relatively obvious, it's best to ask the experts.

If you do find a solution there, don't forget to post it here, too .

However, I can definitely see that it seems to be a sound problem causing the crash-- you'll notice that the only debug info that is loaded comes from sound-related modules.

Have you tried using winearts driver instead of wineoss? It's a stab in the dark, but then, using Wine so often is....
 
Old 03-30-2004, 02:07 PM   #18
feuer
LQ Newbie
 
Registered: Aug 2003
Posts: 11

Original Poster
Rep: Reputation: 0
I tried using winearts driver instead of wineoss ----> No help at all
I also tried to comment out all the sound drivers etc. in ~/.wine/config ---> No effect

I'll try that Mailing list, thanks for the URL
 
Old 05-11-2004, 02:46 PM   #19
leadazide
Member
 
Registered: Apr 2004
Location: Germany
Distribution: SuSE 11.0, Ubuntu 7.10
Posts: 390

Rep: Reputation: 30
Sometimes my CVS WineX crashes when arts is running. Killing artsd solves the problem. But yours report
Quote:
Originally posted by feuer
Code:
err:wave:OSS_WaveOutInit /dev/mixer1: No such device
err:wave:OSS_WaveInInit /dev/mixer1: No such device

...strange...
Go to /dev dir as root and look if you have mixer1 present
if not create a symlink
 
Old 05-11-2004, 04:30 PM   #20
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
What kernel is this? Are you using ALSA or OSS drivers by default? If ALSA, did you also enable (if kernel-based ALSA) or install/load OSS emulation?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wine Issues rejeK Linux - Software 7 12-20-2004 04:41 PM
Wine issues BenRichards Linux - Software 5 09-21-2004 10:03 AM
help me please (wine issues) crettis Linux - Newbie 3 10-16-2003 01:45 PM
Wine Issues JC404 Linux - Software 2 07-04-2003 10:07 PM
wine and WinMX issues Micro-Shock Linux - Software 0 01-09-2003 04:02 PM


All times are GMT -5. The time now is 12:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration