LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-09-2013, 06:41 PM   #1
ndayis
LQ Newbie
 
Registered: Dec 2013
Posts: 2

Rep: Reputation: Disabled
Wink Issues with libodbc


I am new at RedHat, but I was trying to install some package on a redhat server and then I run into an error:

Failed dependencies:
libodbc.so.1() (64bit) is needed by <package-name>.

It looks like I need to install libodbc.so.1. I tried many suggestions online including using "yum provides" command, I tried to search redhat-compatible libodbc.so.1 for manual installation everywhere-on the net but I am out of luck.

Can anyone help me please?
 
Old 12-09-2013, 06:59 PM   #2
berndbausch
Senior Member
 
Registered: Nov 2013
Location: Tokyo
Distribution: Redhat/Centos, Ubuntu, Raspbian, Fedora
Posts: 1,687

Rep: Reputation: 353Reputation: 353Reputation: 353Reputation: 353
Quote:
Originally Posted by ndayis View Post
I am new at RedHat, but I was trying to install some package on a redhat server and then I run into an error:

Failed dependencies:
libodbc.so.1() (64bit) is needed by <package-name>.

It looks like I need to install libodbc.so.1. I tried many suggestions online including using "yum provides" command, I tried to search redhat-compatible libodbc.so.1 for manual installation everywhere-on the net but I am out of luck.

Can anyone help me please?
Not me but Bing (or, if you are so inclined, Google). Using Bing, the second search result of "libodbc redhat" matches your description.
 
Old 12-09-2013, 08:26 PM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Quote:
I was trying to install some package on a redhat server
If RHEL 6 : No "libodbc.so.1".

"libodbc.so.1" is an older file that was present in RHEL 5.
Provided by the package unixODBC-2.2.12-xx.


RHEL version check : $ cat /etc/redhat-release

-
 
Old 12-10-2013, 09:56 AM   #4
ndayis
LQ Newbie
 
Registered: Dec 2013
Posts: 2

Original Poster
Rep: Reputation: Disabled
Thank you guys for your suggestions. I tried your ideas but that libodbc.so is still not getting installed. Any other suggestion will be greatly appreciated.

Last edited by ndayis; 12-10-2013 at 10:30 AM.
 
Old 12-10-2013, 11:06 AM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Quote:
I was trying to install some package ..
? Which package is it about ? ?
 
Old 12-10-2013, 06:22 PM   #6
berndbausch
Senior Member
 
Registered: Nov 2013
Location: Tokyo
Distribution: Redhat/Centos, Ubuntu, Raspbian, Fedora
Posts: 1,687

Rep: Reputation: 353Reputation: 353Reputation: 353Reputation: 353
Quote:
Originally Posted by ndayis View Post
Thank you guys for your suggestions. I tried your ideas but that libodbc.so is still not getting installed. Any other suggestion will be greatly appreciated.
You're description is insufficient. As a start, you need to tell us:
  • What OS version you are on (Red Hat Enterprise Linux x.x or something else?)
  • What's the software, and version, that depends on libodbc
  • Why is it so hard to install the unixODBC package. yum install unixODBC doesn't work? What does it say?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS issues, Downloading issues, Web issues. UbuntuHelp Linux - Networking 1 08-28-2012 08:34 AM
rpm could not find libodbc.so manojg Linux - Software 4 01-27-2011 03:57 PM
ATI Ain in Wonder 8500DV LINUX LIVE boot issues (and TV issues) Flashmahn Linux - Hardware 1 03-09-2009 07:40 AM
Dell m1210 Linux issues (having issues getting network working under Ubuntu) thebert Linux - Newbie 4 03-14-2008 04:47 PM
how to install libodbc++ and unixODBC on RedHat7.3 and RedHat9? marmarchi Linux - Software 1 10-24-2004 08:43 AM


All times are GMT -5. The time now is 09:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration