LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-16-2008, 12:17 PM   #1
pietruszewski
Member
 
Registered: Jul 2007
Location: London, Ontario, Canada
Distribution: Debian
Posts: 79

Rep: Reputation: 15
Issues with compiz-fusion, sound, and other stuff


I recently ordered a bare-bones AMD system (athlon x2 4200, 1GB ram, onboard NVIDIA Geforce6, ethernet and sound), and I started setting up and configuring my Debian Etch system on it. I'm not a complete 'n00b' as they say, I've been using linux for almost a year but I've been relying a lot on google searches for my problems.

1.I've disabled gdm auto-start because sometimes I need to do things out of X, but when it gets to the last stage right before 'COMPUTER LOGIN:' it reads:

lo: Disabled Privacy Extensions
IPv6 over IPv4 tunneling driver
(Hangs here for a minute or so)
eth'n': No IPv6 routers present
('n' is replaced by a number that constantly changes. Sometimes it is eth17 or eth19 and sometimes it is roeth21)

2. I can't seem to get sound working - I wish I could give more information but I really don't know. Help me out!

3. And lastly I've started playing around with Compiz-Fusion since this is a fairly fast computer. One issue I'm having is when I log in, emerald theme manager doesn't start. The gnome default themer takes over.
I've added 'emerald --replace' to my start up applications, but when I boot up i still have to 'Alt-F2 - emerald --replace' my way into it. Anybody else experience a similar problem?

Last edited by pietruszewski; 04-16-2008 at 12:18 PM.
 
Old 04-17-2008, 12:36 PM   #2
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,121

Rep: Reputation: 494Reputation: 494Reputation: 494Reputation: 494Reputation: 494
If you are not using IPv6, disable it. There are a variety of ways of doing that. Here is a link on how to disable it.

http://www.ducea.com/2006/06/01/disa...fault-kernels/

I have a similar system, i have had it about 2 months. I installed Mandriva 2008, and everything worked out or the box. I'm not suggesting you give up on Debain, I would bet you can get everything working.

Sound, my system uses the Intel-HDA driver for the Nvidia sound hardware. Here is my audio hardware from the command 'lspci'

Quote:
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
and the sound driver from /sbin/lsmod | grep snd

Quote:
snd_seq_dummy 3492 0
snd_seq_oss 29280 0
snd_seq_midi_event 6816 1 snd_seq_oss
snd_seq 45968 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 7244 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 37344 0
snd_mixer_oss 14624 1 snd_pcm_oss
snd_hda_intel 280220 4
snd_pcm 68996 3 snd_pcm_oss,snd_hda_intel
snd_timer 19460 3 snd_seq,snd_pcm
snd_page_alloc 8456 2 snd_hda_intel,snd_pcm
snd_hwdep 7332 1 snd_hda_intel
snd 43972 15 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_pcm,snd_timer,snd_hwd ep
soundcore 6592 1 snd
Look to see if you have any of the above loaded. If not, try to modprobe soundcore and snd_hda_intel . If they load, turn up the volume, open a mixer and make sure you are not muted.

I use KDE, not Gnome, so I can't help much with what is happening with Emerald. I have it loaded, and it works like a charm.

Hope this helps.
 
Old 04-17-2008, 02:01 PM   #3
pietruszewski
Member
 
Registered: Jul 2007
Location: London, Ontario, Canada
Distribution: Debian
Posts: 79

Original Poster
Rep: Reputation: 15
Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
this is the same sound card I have. When I type /sbin/lsmod | grep snd I get:

snd_hda_intel 23708 0
snd_hda_codec 184192 1 snd_hda_intel
snd_pcm_oss 48672 0
snd_mixer_oss 21888 1 snd_pcm_oss
snd_pcm 89096 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_timer 29192 1 snd_pcm
snd 65256 6 snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore 15392 1 snd
snd_page_alloc 15504 2 snd_hda_intel,snd_pcm


When I modprobe'd soundcoire and snd_hda_intel I was returned no error messages. But when I try to open Volume Control I get:
No volume control GStreamer plugins and/or devices found.
 
Old 04-17-2008, 04:00 PM   #4
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,121

Rep: Reputation: 494Reputation: 494Reputation: 494Reputation: 494Reputation: 494
After reading other posts, it appears you may not have GStreamer plugins installed. Have you installed them?
 
Old 04-17-2008, 09:06 PM   #5
pietruszewski
Member
 
Registered: Jul 2007
Location: London, Ontario, Canada
Distribution: Debian
Posts: 79

Original Poster
Rep: Reputation: 15
I'm not quite sure which ones to get - synaptic returns a lot of different kinds, some of which I already have installed.
 
Old 04-17-2008, 10:02 PM   #6
pietruszewski
Member
 
Registered: Jul 2007
Location: London, Ontario, Canada
Distribution: Debian
Posts: 79

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by camorri View Post
If you are not using IPv6, disable it. There are a variety of ways of doing that. Here is a link on how to disable it.

http://www.ducea.com/2006/06/01/disa...fault-kernels/
This worked flawlessly by the way.
 
Old 04-17-2008, 10:25 PM   #7
indienick
Senior Member
 
Registered: Dec 2005
Location: London, ON, Canada
Distribution: Arch, Ubuntu, Slackware, OpenBSD, FreeBSD
Posts: 1,853

Rep: Reputation: 65
The joy of Linux: For every graphical application, there's a text-based counterpart.

Don't worry about using gnome-alsa-mixer just yet. Pop over into a TTY, and run sudo alsaconf. After that's done, run alsamixer; the sound levels should be non-muted and fairly audible, but it's good to check, anyways.

As for installing Gstreamer plugins, install the following:
Code:
* gstreamer0.10-alsa
* gstreamer0.10-ffmpeg
* gstreamer0.10-gnomevfs
* gstreamer0.10-plugins-base
* gstreamer0.10-plugins-good
* gstreamer0.10-plugins-ugly
* gstreamer0.10-x
 
Old 04-18-2008, 04:02 AM   #8
pietruszewski
Member
 
Registered: Jul 2007
Location: London, Ontario, Canada
Distribution: Debian
Posts: 79

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by indienick View Post
Don't worry about using gnome-alsa-mixer just yet. Pop over into a TTY, and run sudo alsaconf. After that's done, run alsamixer; the sound levels should be non-muted and fairly audible, but it's good to check, anyways.
alsaconf doesn't detect any soundcard, and alsamixer doesn't start because I have no sound device initialized =(.
 
Old 04-18-2008, 08:13 AM   #9
indienick
Senior Member
 
Registered: Dec 2005
Location: London, ON, Canada
Distribution: Arch, Ubuntu, Slackware, OpenBSD, FreeBSD
Posts: 1,853

Rep: Reputation: 65
Hmm...if you run aptitude (or synaptic), which ALSA packages are installed?
 
Old 04-18-2008, 09:12 AM   #10
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,121

Rep: Reputation: 494Reputation: 494Reputation: 494Reputation: 494Reputation: 494
pietruszewski reported the following alsa driver installed - snd_hda_intel 23708 0
 
Old 04-18-2008, 01:05 PM   #11
pietruszewski
Member
 
Registered: Jul 2007
Location: London, Ontario, Canada
Distribution: Debian
Posts: 79

Original Poster
Rep: Reputation: 15
When I do a search for alsa in synaptic I get:

Code:
alsa-base
alsamixergui
alsa-utils
gnome-alsamixser
gstreamer0.10-alsa
gstreamer0.8-alsa
libasound2
libpt-plugins-alsa
libsdl1.2debian-alsa
linux-sound-base
xfce4-mixer-alsa
 
Old 04-21-2008, 11:12 AM   #12
pietruszewski
Member
 
Registered: Jul 2007
Location: London, Ontario, Canada
Distribution: Debian
Posts: 79

Original Poster
Rep: Reputation: 15
Can anybody help me out?
 
Old 04-21-2008, 12:18 PM   #13
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,121

Rep: Reputation: 494Reputation: 494Reputation: 494Reputation: 494Reputation: 494
There is something strange about this:

Quote:
snd_hda_intel 23708 0
snd_hda_codec 184192 1 snd_hda_intel
Nothing is using the sound driver, snd_hda_intel. Compare it to what I listed, and things should be using the driver. I have 4 things using the driver. ( my sound works, same sound hardware ).

I wished I could help more, but for now all I can suggest is to unload all the sound stuff, and then re-load it. Possibly we can have a look at the Alsa site, there is some documentation there on how to do PD.
 
Old 04-22-2008, 10:46 AM   #14
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,121

Rep: Reputation: 494Reputation: 494Reputation: 494Reputation: 494Reputation: 494
I had a look at the ALSA Wiki. It seems there are different kenenl modules used for different chip sets.

My system has the Realtek ALC883 chip set. There are several others. Some use the snd_hda_intel module, and others use the AC'97 module.

I'm wondering if you have the correct module loaded. If you bring up alsamixer-gui on the top it shows the ACL 883 chip on mine. Can you take a look and see what is reported on your system, and post back? I'm not sure if there may be other ways of knowing what chip set you have.
 
Old 04-23-2008, 10:10 AM   #15
pietruszewski
Member
 
Registered: Jul 2007
Location: London, Ontario, Canada
Distribution: Debian
Posts: 79

Original Poster
Rep: Reputation: 15
It won't let me open alsamixer because supposedly I don't have a sound device.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I just can see white in compiz-fusion!! brevleq Linux - Desktop 7 03-20-2008 11:13 AM
Compiz fusion does nothing bottled leaf Linux - Software 7 02-27-2008 12:43 AM
Redhat 9 compiz-fusion? LinuxNewbie999 Red Hat 3 02-24-2008 05:45 AM
Ubuntu+compiz-fusion up and running...how about the sound now! ItsTimeToMoveOn Linux - Newbie 12 01-19-2008 03:12 PM
Compiz-Fusion help tekgek Linux - Desktop 10 10-24-2007 10:39 PM


All times are GMT -5. The time now is 07:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration