LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-14-2010, 08:33 AM   #1
Peterken
Member
 
Registered: Apr 2007
Location: Belgium
Distribution: Debian
Posts: 63

Rep: Reputation: 20
Question issues with 82845G Graphics Controller


Hi,

I have installed the latest debian on a dell optiplex gx260 which has a 82845G chipset and there are some strange problems.
The system is configured with autologon as a standard user.

Sometimes, after logging on, the screen goes black but if I connect to it with vnc, I get a working desktop.
Yesterday I booted it without a display attached to it and now I cannot set it to the right screen resolution anymore (1440 x 900) which was working fine before.

I have googled and searh the forum but cannot find the right information.
According to Intel, the latest driver should be in the distro but I cannot find any details about that (version/date).

grep Driver /etc/X11/xorg.conf returns
Code:
Driver		"kbd"
Driver		"mouse"
/usr/bin/lspci | grep VGA returns
Code:
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)
xrandr returns
Code:
Screen 0: minimum 320 x 200, current 1280 x 800, maximum 1280 x 1280
VGA connected 1280x800+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1280x800       60.0* 
   1280x768       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        59.9
Any suggestions on solving this are more then welcome!
Peter
 
Old 01-14-2010, 09:53 AM   #2
neonsignal
Senior Member
 
Registered: Jan 2005
Location: Melbourne, Australia
Distribution: Debian Jessie (Fluxbox WM)
Posts: 1,387
Blog Entries: 52

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
The contents of Xorg.0.log will give you some information about what is happening on startup.

I didn't expect that your /etc/X11/xorg.conf would have anything in it on a clean install. You could try renaming it (so you can reinstate it if you need to), and create an xorg.conf that is empty. On Debian Lenny, an empty xorg.conf is the default; the content means that some later configuration changes have been made.
 
1 members found this post helpful.
Old 01-14-2010, 10:25 AM   #3
Peterken
Member
 
Registered: Apr 2007
Location: Belgium
Distribution: Debian
Posts: 63

Original Poster
Rep: Reputation: 20
Hi neonsignal, thank you for your reply!
Attaching Xorg.0.log doesn't work due to an 'invalid file' error... (pasting here is also a no go since the file has 600 lines of text)

I just copied & deleted the original xorg.conf, rebooted but no difference.
 
Old 01-14-2010, 11:20 AM   #4
Peterken
Member
 
Registered: Apr 2007
Location: Belgium
Distribution: Debian
Posts: 63

Original Poster
Rep: Reputation: 20
Now I get a 'failed to start x server' error...
 
Old 01-14-2010, 05:32 PM   #5
neonsignal
Senior Member
 
Registered: Jan 2005
Location: Melbourne, Australia
Distribution: Debian Jessie (Fluxbox WM)
Posts: 1,387
Blog Entries: 52

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
Quote:
I just copied & deleted the original xorg.conf
I assume you mean you created a new xorg.conf that is empty. I don't think X will start if you have no xorg.conf file at all.

If they behaviour continues to vary even though you haven't made any changes, it may indicate a hard drive (or memory issue), rather than some particular problem with the X setup.

In order to attach Xorg.0.log to a forum post, I think you would have to rename it to 'Xorg.txt'.

Last edited by neonsignal; 01-14-2010 at 06:06 PM.
 
1 members found this post helpful.
Old 01-14-2010, 05:40 PM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
# 5
Quote:
I don't think X will start if you have no xorg.conf
' xorg.conf ' isn't a must with the latest xorg.

Other threads about Dell GX 260 : Intel Graphics issues ..
http://www.linuxquestions.org/questi...-gx260-771584/

.. and ..
http://www.linuxquestions.org/questi...-gx260-769120/
.. where two examples, xorg.conf are attached.
.....
 
1 members found this post helpful.
Old 01-14-2010, 08:12 PM   #7
Peterken
Member
 
Registered: Apr 2007
Location: Belgium
Distribution: Debian
Posts: 63

Original Poster
Rep: Reputation: 20
Ok, it was indeed a matter of extension that kept me from uploading the logfile so now it's enclosed.

Does it show somewhere if this problem is related to a bad HD/memory - even though I don't think that this is a problem since the system has worked flawlessly before.

No, I didn't recreate xorg.conf and it seems that knudfl is right because after that error message I rebooted and got it working again.
Recreating it leaves it empty anyway.

Is it normal that before I was able to choose 1440x900 and now I'm not?
Attached Files
File Type: txt Xorg.0.txt (27.6 KB, 6 views)
 
Old 01-14-2010, 08:53 PM   #8
neonsignal
Senior Member
 
Registered: Jan 2005
Location: Melbourne, Australia
Distribution: Debian Jessie (Fluxbox WM)
Posts: 1,387
Blog Entries: 52

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
It does happen that X sometimes doesn't detect all the possible resolutions (some devices do not quite follow the standard). The automatically detected settings can be overridden by setting up xorg.conf, but I just wanted to be sure that you could at least get X starting reliably without it.

If X is starting consistently, ignore my suggestion about other devices failing.

If you have a look in your /etc/X11 directory, you may find older versions of xorg.conf with some working settings. The relevant sections are the Monitor section (particularly HorizSync and VertRefresh), and the Screen section (particularly the Display resolutions).

I'm don't know what changed your xorg.conf in the first place.

Last edited by neonsignal; 01-14-2010 at 08:56 PM.
 
1 members found this post helpful.
Old 01-14-2010, 09:18 PM   #9
Peterken
Member
 
Registered: Apr 2007
Location: Belgium
Distribution: Debian
Posts: 63

Original Poster
Rep: Reputation: 20
Well, X starts most of the times but I wouldn't call it reliable since sometimes the screen just goes black.
On the other hand, if having autologon enabled I can see through vnc that the system works.

Is it normal that before logging on (autologon disabled) there are different display settings compared to being logged in?
I noticed that the image is not at the same place -> refresh rate?

There are no older version of xorg.conf and the one I've created remains empty.

Code:
ls -l /etc/X11/
total 68
drwxr-xr-x 2 root root  4096 2009-12-24 04:46 app-defaults
-rw-r--r-- 1 root root    13 2009-12-24 04:46 default-display-manager
drwxr-xr-x 6 root root  4096 2009-12-24 04:41 fonts
-rw-r--r-- 1 root root 17394 2009-04-20 15:31 rgb.txt
drwxr-xr-x 2 root root  4096 2010-01-06 16:13 twm
lrwxrwxrwx 1 root root    13 2009-12-24 04:51 X -> /usr/bin/Xorg
drwxr-xr-x 2 root root  4096 2009-12-24 04:46 xinit
drwxr-xr-x 2 root root  4096 2009-12-24 04:46 xkb
-rw-r--r-- 1 root root     0 2010-01-15 01:27 xorg.conf
drwxr-xr-x 2 root root  4096 2009-12-24 04:34 Xresources
drwxr-xr-x 2 root root  4096 2009-12-24 04:51 xserver
-rwxr-xr-x 1 root root  3517 2008-03-08 05:13 Xsession
drwxr-xr-x 2 root root  4096 2010-01-06 20:13 Xsession.d
-rw-r--r-- 1 root root   265 2007-02-13 11:02 Xsession.options
-rw------- 1 root root   614 2009-12-24 04:34 Xwrapper.config
display:~#
Uhm... how come it says 'total 68'?
 
Old 01-14-2010, 09:40 PM   #10
neonsignal
Senior Member
 
Registered: Jan 2005
Location: Melbourne, Australia
Distribution: Debian Jessie (Fluxbox WM)
Posts: 1,387
Blog Entries: 52

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
Quote:
Is it normal that before logging on (autologon disabled) there are different display settings compared to being logged in?
Yes, that is normal, the display manager shows the login screen in a low resolution, since different logins may have different X settings (and not all necessarily work on all displays).

Quote:
I wouldn't call it reliable since sometimes the screen just goes black.
You probably need to follow up the links that knudfl provided, and see if this corresponds to the same issues that others have had. You might also find an xorg.conf with settings for your graphics.

Quote:
Uhm... how come it says 'total 68'
That's just the size of the directory, not the number of files in it.
 
1 members found this post helpful.
Old 01-14-2010, 09:54 PM   #11
Peterken
Member
 
Registered: Apr 2007
Location: Belgium
Distribution: Debian
Posts: 63

Original Poster
Rep: Reputation: 20
Ok I used the puppylinux configuration and I can now select other resolutions as well.
Should I just go ahead and see what it brings?

The only thing is that my mouse is not functioning but with vnc it is, how is this possible?
 
Old 01-14-2010, 10:05 PM   #12
neonsignal
Senior Member
 
Registered: Jan 2005
Location: Melbourne, Australia
Distribution: Debian Jessie (Fluxbox WM)
Posts: 1,387
Blog Entries: 52

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
If the xorg.conf you tried is working, then go with it.

Some of it is not relevant to your system, but you can always edit it if you need to, as you learn what different parts of it mean. 'man xorg.conf' will give you a description, but there is a fair bit to read through.

Quote:
The only thing is that my mouse is not functioning but with vnc it is, how is this possible?
The mouse driver is also set up by xorg.conf, and the xorg.conf you tried had a specific setup which doesn't match yours. It works with vnc because vnc isn't using the mouse driver on the target computer, it is using the mouse driver on the computer you are jumping in from.

You can have a fairly minimal mouse setup in xorg.conf, and the system will (hopefully) work out the rest, eg
Code:
Section "InputDevice"
	Identifier	"Mouse0"
	Driver		"mouse"
EndSection

Last edited by neonsignal; 01-14-2010 at 10:10 PM.
 
1 members found this post helpful.
Old 01-14-2010, 10:20 PM   #13
Peterken
Member
 
Registered: Apr 2007
Location: Belgium
Distribution: Debian
Posts: 63

Original Poster
Rep: Reputation: 20
at first it was working, I selected 1440x900 as resolotion, rebooted and the image was darker then it should be. Rebooted once again and got a 'failed to start x server' error again - see the enclosed logfile.

Rebooting again bypasses the error again...

Ok, thanks A LOT for helping out! Gotta go to bed now since it's 4:37 a.m. over here!
Attached Files
File Type: txt Xorg.0.log.txt (28.8 KB, 4 views)

Last edited by Peterken; 01-14-2010 at 10:38 PM. Reason: added info
 
Old 01-14-2010, 11:17 PM   #14
neonsignal
Senior Member
 
Registered: Jan 2005
Location: Melbourne, Australia
Distribution: Debian Jessie (Fluxbox WM)
Posts: 1,387
Blog Entries: 52

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
Another couple of things to try (it might be a problem with the intel driver).

In xorg.conf, try replacing this line:
Code:
Driver      "intel"
with
Code:
Driver      "i810"
If that doesn't help (or doesn't work at all), go back to the intel driver and try uncommenting the acceleration line:
Code:
Option      "NoAccel"
If the 'no acceleration' solves the problem, it points to a driver issue. The system will work without the acceleration, but it will significantly slow down desktop effects and may make 3D games unusable.
 
Old 01-16-2010, 05:15 AM   #15
Peterken
Member
 
Registered: Apr 2007
Location: Belgium
Distribution: Debian
Posts: 63

Original Poster
Rep: Reputation: 20
Thanks for your tips: I just changed those settings in my xorg.conf file and it's a big improvement!
I also activated the no acceleration option immediately since the system doesn't need any 3-D related stuff.
Rebooted the system about 20 times and now it's a lot more consistent.

There is one issue though: the colors are still not what they should be. I tried to change the refresh rates in the monitor section according to the display connected but that didn't go well.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SVGATextMode with Intel 82845G Graphics Controller vpv Linux - Desktop 2 10-31-2008 03:51 AM
Intel 82845G Graphics Controller Linucec Ubuntu 5 07-10-2008 07:03 PM
Intel 82Q963/Q965 integrated graphics controller issues jaredhanks Linux - Hardware 0 02-07-2008 08:59 PM
graphics driver problem with intel 82845G/gl/ge/pe/gv? kittaanna SUSE / openSUSE 1 05-14-2006 06:19 PM
RH 7.3 and Intel® 82845G Graphics Controller nilch Linux - Hardware 2 01-29-2003 04:41 AM


All times are GMT -5. The time now is 08:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration