LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-29-2013, 05:12 AM   #1
Brofessor
LQ Newbie
 
Registered: Jul 2013
Posts: 5

Rep: Reputation: Disabled
Issues Installing RequestTracker (best practical) on Linux Mint 15


Hello,

First, i am new to linux in everyway possible.
I am working on a small ticket tracking project for our sysadmin team.
Having used RT (http://bestpractical.com/rt/) at another company (i did not set it up) i thought it would be a good idea to set it up at my new job aswell.

I have used the following guides to get myself started:
Quote:
Bestpractical.com/docs/rt/4.0/readme.html
Community.linuxmint.com/tutorial/view/486
http://www.sudobash.net/bash-how-to-...n-on-ubuntu-2/
I am using Linux Mint 15 at the moment.
Everything is going fine untill i run the command: sudo make install.
I end up with the following error:

Quote:
/usr/bin/install: cannot stat ‘etc/acl.Pg’: No such file or directory
/usr/bin/install: cannot stat ‘etc/acl.Oracle’: No such file or directory
/usr/bin/install: cannot stat ‘etc/acl.mysql’: No such file or directory
/usr/bin/install: cannot stat ‘etc/schema.Pg’: No such file or directory
/usr/bin/install: cannot stat ‘etc/schema.Oracle’: No such file or directory
/usr/bin/install: cannot stat ‘etc/schema.mysql’: No such file or directory
/usr/bin/install: cannot stat ‘etc/schema.SQLite’: No such file or directory
/usr/bin/install: cannot stat ‘etc/initialdata’: No such file or directory
make: *** [etc-install] Error 1
I tried putting the files there manually, this does not fix the issue.
The install command is run using the sudo command.

Searching google has not shown any results, nor a search on this forum.

I hope someone is able to help me out.

(my apologies of this is posted in the wrong section)
 
Old 07-30-2013, 12:54 AM   #2
textillis
Member
 
Registered: May 2013
Location: Northern Rivers, NSW, Australia
Distribution: Slackware64-current, Mint Nadya
Posts: 299

Rep: Reputation: 2
Quote:
Originally Posted by Brofessor View Post
Hello,

First, i am new to linux in everyway possible.
I am working on a small ticket tracking project for our sysadmin team.
Having used RT (http://bestpractical.com/rt/) at another company (i did not set it up) i thought it would be a good idea to set it up at my new job aswell.

I have used the following guides to get myself started:


I am using Linux Mint 15 at the moment.
Everything is going fine untill i run the command: sudo make install.
I end up with the following error:



I tried putting the files there manually, this does not fix the issue.
The install command is run using the sudo command.

Searching google has not shown any results, nor a search on this forum.

I hope someone is able to help me out.

(my apologies of this is posted in the wrong section)
Which package are you installing?
When I use synaptic on mint 14 to search for "request tracker" (without quotes) it returns:
request-tracker4 latest version: 4.0.6-4 Description: Apache2 specific files for request-tracker, 22.9MB download, for a 120 packet download which will occupy nearly 80MB when installed.
Is that what you are trying to install?
 
Old 07-30-2013, 01:41 AM   #3
Brofessor
LQ Newbie
 
Registered: Jul 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by textillis View Post
Which package are you installing?
When I use synaptic on mint 14 to search for "request tracker" (without quotes) it returns:
request-tracker4 latest version: 4.0.6-4 Description: Apache2 specific files for request-tracker, 22.9MB download, for a 120 packet download which will occupy nearly 80MB when installed.
Is that what you are trying to install?
Hi,

I am trying to install rt-4.0.13.tar.gz downloaded from http://bestpractical.com/rt/.
I don't know if that is what you ment, like i said i'm totally new to all of this and i'm just following the guides from that website + what i could find on the internet.

Here is the total "make install" output, i dont know if it is of any use to solving my issue:

Quote:
/usr/bin/perl ./sbin/rt-test-dependencies --verbose --with-mysql --with-fastcgi
perl:
>=5.8.3(5.14.2) ...found
users:
rt group (www-data) ...found
bin owner (root) ...found
libs owner (root) ...found
libs group (bin) ...found
web owner (www-data) ...found
web group (www-data) ...found
CLI dependencies:
Term::ReadKey ...found
Getopt::Long >= 2.24 ...found
HTTP::Request::Common ...found
Term::ReadLine ...found
Text::ParseWords ...found
LWP ...found
CORE dependencies:
DateTime >= 0.44 ...found
Class::ReturnValue >= 0.40 ...found
Text::Quoted >= 2.02 ...found
Regexp::IPv6 ...found
HTML::TreeBuilder ...found
CSS::Squish >= 0.06 ...found
Encode >= 2.39 ...found
DateTime::Locale >= 0.40 ...found
Module::Versions::Report >= 1.05 ...found
MIME::Entity >= 5.425 ...found
Digest::SHA ...found
List::MoreUtils ...found
DBI >= 1.37 ...found
Locale::Maketext::Lexicon >= 0.32 ...found
Devel::StackTrace >= 1.19 ...found
Digest::base ...found
HTML::FormatText ...found
Text::Password::Pronounceable ...found
Devel::GlobalDestruction ...found
Time::ParseDate ...found
File::Temp >= 0.19 ...found
Locale::Maketext >= 1.06 ...found
Tree::Simple >= 1.04 ...found
Text::Template >= 1.44 ...found
Scalar::Util ...found
HTML::Quoted ...found
HTML::Scrubber >= 0.08 ...found
File::Spec >= 0.8 ...found
DBIx::SearchBuilder >= 1.59 ...found
Sys::Syslog >= 0.16 ...found
Mail::Mailer >= 1.57 ...found
File::ShareDir ...found
Regexp::Common ...found
Digest::MD5 >= 2.27 ...found
Cache::Simple::TimedExpiry ...found
File::Glob ...found
Class::Accessor >= 0.34 ...found
Locale::Maketext::Fuzzy ...found
Time::HiRes ...found
Text::Wrapper ...found
Regexp::Common::net::CIDR ...found
Net::CIDR ...found
Log:ispatch >= 2.23 ...found
UNIVERSAL::require ...found
Email::Address ...found
DASHBOARDS dependencies:
HTML::RewriteAttributes >= 0.05 ...found
URI >= 1.59 ...found
MIME::Types ...found
FASTCGI dependencies:
FCGI::ProcManager ...found
FCGI >= 0.74 ...found
GPG dependencies:
PerlIO::eol ...found
GnuPG::Interface ...found
ICAL dependencies:
Data::ICal ...found
MAILGATE dependencies:
Pod::Usage ...found
Getopt::Long ...found
LWP::UserAgent ...found
MASON dependencies:
Storable >= 2.08 ...found
CSS::Squish >= 0.06 ...found
Apache::Session >= 1.53 ...found
Errno ...found
Devel::StackTrace >= 1.19 ...found
IPC::Run3 ...found
CGI::Cookie >= 1.20 ...found
Text::WikiFormat >= 0.76 ...found
XML::RSS >= 1.05 ...found
HTML::Mason >= 1.43 ...found
Digest::MD5 >= 2.27 ...found
JSON ...found
MYSQL dependencies:
DBD::mysql >= 2.1018 ...found
PSGI dependencies:
CGI::Emulate::PSGI ...found
CGI >= 3.38 ...found
CGI::PSGI >= 0.12 ...found
HTML::Mason::PSGIHandler >= 0.52 ...found
Plack >= 0.9971 ...found
Plack::Handler::Starlet ...found
SMTP dependencies:
Net::SMTP ...found
USERLOGO dependencies:
Convert::Color ...found

All dependencies have been found.
/usr/bin/install -c -m 0755 -o root -g www-data -d /opt/rt4/etc
/usr/bin/install -c -m 0440 -o root -g www-data etc/RT_Config.pm /opt/rt4/etc/RT_Config.pm
[ -f /opt/rt4/etc/RT_SiteConfig.pm ] || /usr/bin/install -c -m 0640 -o root -g www-data etc/RT_SiteConfig.pm /opt/rt4/etc/RT_SiteConfig.pm
Installed configuration. About to install RT in /opt/rt4
/usr/bin/install -c -m 0755 -d /opt/rt4/var/log
/usr/bin/install -c -m 0755 -d /opt/rt4/share/fonts
/usr/bin/install -c -m 0755 -d /opt/rt4/share/po
/usr/bin/install -c -m 0770 -d /opt/rt4/var/mason_data
/usr/bin/install -c -m 0770 -d /opt/rt4/var/mason_data/cache
/usr/bin/install -c -m 0770 -d /opt/rt4/var/mason_data/etc
/usr/bin/install -c -m 0770 -d /opt/rt4/var/mason_data/obj
/usr/bin/install -c -m 0770 -d /opt/rt4/var/session_data
/usr/bin/install -c -m 0755 -d /opt/rt4/share/html
/usr/bin/install -c -m 0755 -d /opt/rt4/local/html
/usr/bin/install -c -m 0755 -d /opt/rt4/local/etc
/usr/bin/install -c -m 0755 -d /opt/rt4/local/lib
/usr/bin/install -c -m 0755 -d /opt/rt4/local/plugins
/usr/bin/install -c -m 0755 -d /opt/rt4/local/po
[ -d /opt/rt4/lib ] || /usr/bin/install -c -m 0755 -d /opt/rt4/lib
( cd lib && find . -type d -print ) | while read dir ; do \
/usr/bin/install -c -m 0755 -d "/opt/rt4/lib/$dir" ; \
done
( cd lib && find . -type f -print ) | while read file ; do \
/usr/bin/install -c -m 0644 "lib/$file" "/opt/rt4/lib/$file" ; \
done
[ -d /opt/rt4/etc ] || /usr/bin/install -c -m 0755 -d /opt/rt4/etc
for file in acl.Pg acl.Oracle acl.mysql schema.Pg schema.Oracle schema.mysql schema.SQLite initialdata ; do \
/usr/bin/install -c -m 0644 "etc/$file" "/opt/rt4/etc/" ; \
done
/usr/bin/install: cannot stat ‘etc/acl.Pg’: No such file or directory
/usr/bin/install: cannot stat ‘etc/acl.Oracle’: No such file or directory
/usr/bin/install: cannot stat ‘etc/acl.mysql’: No such file or directory
/usr/bin/install: cannot stat ‘etc/schema.Pg’: No such file or directory
/usr/bin/install: cannot stat ‘etc/schema.Oracle’: No such file or directory
/usr/bin/install: cannot stat ‘etc/schema.mysql’: No such file or directory
/usr/bin/install: cannot stat ‘etc/schema.SQLite’: No such file or directory
/usr/bin/install: cannot stat ‘etc/initialdata’: No such file or directory
make: *** [etc-install] Error 1
 
Old 07-30-2013, 06:26 AM   #4
Brofessor
LQ Newbie
 
Registered: Jul 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
Alright, i tried a different approach.
I create a new virtualbox and followed the guide from this site: http://cloud101.eu/blog/2012/03/01/r...ebian-squeeze/
Everything is set up nicely, no errors during the install.
Now, when i go to mint-virtualbox2/rt as per step
Quote:
Now when you surf to yourwebsite.com/rt (if you used the default parameter here), you will get a login screen. Use username 'root' and the password you configured in the install screen.
i get a 500 internal server error.

The following is from the apache2 logs:
Quote:
[Tue Jul 30 13:15:12 2013] [warn] [client 127.0.0.1] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
[Tue Jul 30 13:15:12 2013] [error] [client 127.0.0.1] Premature end of script headers: rt-server.fcgi
Now my question is; how do i solve this? I've tried google, but no luck so far.
 
Old 07-30-2013, 08:05 AM   #5
Brofessor
LQ Newbie
 
Registered: Jul 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Brofessor View Post
Alright, i tried a different approach.
I create a new virtualbox and followed the guide from this site: http://cloud101.eu/blog/2012/03/01/r...ebian-squeeze/
Everything is set up nicely, no errors during the install.
Now, when i go to mint-virtualbox2/rt as per step i get a 500 internal server error.

The following is from the apache2 logs:


Now my question is; how do i solve this? I've tried google, but no luck so far.
Alright, i got it working!
I had to install the rt4-fcgi package using synaptic package manager.
 
Old 07-30-2013, 11:59 AM   #6
textillis
Member
 
Registered: May 2013
Location: Northern Rivers, NSW, Australia
Distribution: Slackware64-current, Mint Nadya
Posts: 299

Rep: Reputation: 2
>Brofessor,
Sorry I took so long to get back; but it turns out that you helped yourself.
Well done!
More power to you.
Cheers
 
Old 07-31-2013, 01:38 AM   #7
Brofessor
LQ Newbie
 
Registered: Jul 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by textillis View Post
>Brofessor,
Sorry I took so long to get back; but it turns out that you helped yourself.
Well done!
More power to you.
Cheers
Thanks!
Now i just need to figure out how to set up email connection.
Which is going to be an even bigger issue, i think :').
If i figure it out, ill update this thread.
 
Old 07-31-2013, 08:04 AM   #8
textillis
Member
 
Registered: May 2013
Location: Northern Rivers, NSW, Australia
Distribution: Slackware64-current, Mint Nadya
Posts: 299

Rep: Reputation: 2
>Brofessor

Start a new thread with a succinct, descriptive subject line.

Then give as much relevant detail as possible:

1. kind of connection
2. email client

for starters.

Then, just before you hit "submit", press the button under the subject line that
says: "see other threads matching your query" or something to that effect.

You'll be pleasantly surprised at how often your problem has already been encountered, discussed and solved before you ran into it.

Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux Mint MATE/Cinammon tasbar issues sdraw108 Linux - Newbie 1 01-02-2013 10:25 AM
Dependency issues in Linux Mint 13 m0stlyharmless Linux Mint 2 06-13-2012 05:42 PM
Issues with installing VLMC, Lightworks and Cinelerra on Linux Mint Helena fkasmani Linux - Software 0 06-19-2011 04:30 AM
[SOLVED] Linux Mint Debian Install issues, HazMat117 Linux - Desktop 1 01-03-2011 07:22 AM
re installation of grub in Linux mint after installing xp over mint sampad.sarangi General 1 01-15-2008 05:37 PM


All times are GMT -5. The time now is 10:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration