LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-17-2014, 12:39 AM   #1
pshapard
LQ Newbie
 
Registered: Dec 2014
Posts: 4

Rep: Reputation: Disabled
Unhappy Issue with Redhat 7


I'm fairly new to linux, redhat and suse, and i'm very new to redhat 7. My issue is when i edit the ifcfg-enp4s0f0 file for the nic on an emulex adapter(Nic/FCoE), then reboot the system, I'm unable to ping the onboard nic0, the same nic i use to telnet/ssh and ftp into the system. I know there is a 70-persistent-net.rules file in previous versions of redhat, and when i edit the ifcfg file in previous versions, i delete the persistent file, reboot, and all is well. I have both the systemctl disabled and iptables masked. Below are the commands i used.

systemctl stop firewalld
systemctl disable firewalld

systemctl mask iptables.

So, what am i missing? Is there a persistent-net.rules file (or something like it) that i need to delete to restore functionality to my ninc0.

Thank you for your time and await a response.
Patrick.
 
Old 12-18-2014, 05:34 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,827

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
am i right in assuming that this is a DESKTOP install and not a headless SERVER( no GUI) install

the gnome3 DE uses "networkmanager" and NOT ifup/ifdown

use the manager in the DE
 
Old 12-18-2014, 06:19 PM   #3
pshapard
LQ Newbie
 
Registered: Dec 2014
Posts: 4

Original Poster
Rep: Reputation: Disabled
John,
This is a Desktop GUI install. I did try the manager DE. Did not work. I edited the ifcfg-enp4s0f0/ifcfg-enp4s0f1 files. I added a static ip address, netmask, and NM_CONTROLLED=no. What I did find that worked was I installed the drivers and ocm for our emulex 10 adapter. I installed medusa/DT tools, i disabled selinux, and other stuff. At the end of configuring the SUT, I then disabled firewalld and applied the the following to iptables.

iptables -I INPUT -j ACCEPT

iptables -F
iptables -X
iptables -t nat -F
iptables -t nat -X
iptables -t mangle -F
iptables -t mangle -X
iptables -P INPUT ACCEPT
iptables -P FORWARD ACCEPT
iptables -P OUTPUT ACCEPT

/sbin/service iptables save

This worked for me. But if I apply the above iptables in the beginning of setting up the SUT, then instaled medusa and assigned static ip to the nic ports, then i lose all conectivity to the SUT.

The key here for me is applying iptables above and disabling firewalld, it worked. Meaning, I'm am able to telnet/ftp into the sut.

Thank you for you response.

Kind Regards,
Patrick.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
java on RedHat issue. janel10 Linux - Software 5 05-15-2009 11:22 AM
redhat 6.2 issue boingy Linux - Hardware 1 02-20-2006 08:29 AM
RedHat 8 installation issue nom the unwise Red Hat 2 03-20-2005 08:47 PM
Wireless issue with redhat 9 rascal2003 Linux - Newbie 2 11-24-2003 12:07 PM
Redhat 8.0 Monitor Issue timsson Linux - General 1 03-03-2003 07:47 PM


All times are GMT -5. The time now is 03:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration