LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 04-08-2009, 04:55 AM   #1
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,443
Blog Entries: 6

Rep: Reputation: 51
Issue during SVN Installation on Fedora 10?


I followed the following steps :
Code:
Installing SubVersion on Fedora Linux
To install subversion on Linux and make it available over Apache, I took the following steps:
Install subversion on Fedora
yum install subversion
Install mod_dav_svn
yum install mod_dav_svn
Create the SVN Repository
mkdir /svn/repos
svnadmin create /svn/repos/sandbox
Change ownership of the folder to Apache
chown -R apache.apache /svn
Create /svn/repos/sandbox/svnauth file

[/]
user1 = rw
user2 = r
Here, user user1 will have read-write access while user user2 will have read-only access to the entire repository.
Create /svn/repos/sandbox/svnpass file
htpasswd -bcm /svn/repos/sandbox/svnpass user1 passwordUser1
htpasswd -bm /svn/repos/sandbox/svnpass user2 passwordUser2
htpasswd has the following usage
Usage:
htpasswd [-cmdpsD] passwordfile username
htpasswd -b[cmdpsD] passwordfile username password
 
htpasswd -n[mdps] username
htpasswd -nb[mdps] username password
-c Create a new file.
-n Don’t update file; display results on stdout.
-m Force MD5 encryption of the password.
-d Force CRYPT encryption of the password (default).
-p Do not encrypt the password (plaintext).
-s Force SHA encryption of the password.
-b Use the password from the command line rather than prompting for it.
-D Delete the specified user.
On Windows, NetWare and TPF systems the ‘-m’ flag is used by default.
On all other systems, the ‘-p’ flag will probably not work.
Add the following to your apache config file
Code:
<Location /svn/sandbox>
DAV svn
SVNPath /svn/repos/sandbox
AuthType Basic
AuthName "Subversion Repository"
AuthUserFile /svn/repos/sandbox/svnpass
Require valid-user
AuthzSVNAccessFile /svn/repos/sandbox/svnauth
</Location>
Restart Apache
httpd restart
Tried visiting http://www.yourserver.com/svn/sandbox But when tried providing credentials it just receive and show the cursor again at username. After few attempts it shows
Code:
"Authorization failed due to bad password or your browser doesnt know how to open the File
[/code]

Followed these steps but couldn't access during when it asked me for username / passwd which says that

Authrpization Failed due to BAd password or your browser doesnt support

Last edited by your_shadow03; 04-08-2009 at 04:58 AM.
 
Old 04-08-2009, 05:32 AM   #2
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,443
Blog Entries: 6

Original Poster
Rep: Reputation: 51
I can see logs and it says :
File : /var/log/messages
Code:
Apr  8 14:57:49 localhost setroubleshoot: SELinux is preventing access to files with the default label, default_t. For complete SELinux messages. run sealert -l c4ffde43-6c1b-4e6a-8075-a693836e05d9
Apr  8 14:57:52 localhost setroubleshoot: SELinux is preventing access to files with the default label, default_t. For complete SELinux messages. run sealert -l c4ffde43-6c1b-4e6a-8075-a693836e05d9
Apr  8 14:57:55 localhost setroubleshoot: SELinux is preventing access to files with the default label, default_t. For complete SELinux messages. run sealert -l c4ffde43-6c1b-4e6a-8075-a693836e05d9
Apr  8 14:59:12 localhost setroubleshoot: SELinux is preventing access to files with the default label, default_t. For complete SELinux messages. run sealert -l c4ffde43-6c1b-4e6a-8075-a693836e05d9
Apr  8 14:59:15 localhost setroubleshoot: SELinux is preventing access to files with the default label, default_t. For complete SELinux messages. run sealert -l c4ffde43-6c1b-4e6a-8075-a693836e05d9
Apr  8 15:01:01 localhost setroubleshoot: SELinux is preventing access to files with the default label, default_t. For complete SELinux messages. run sealert -l c4ffde43-6c1b-4e6a-8075-a693836e05d9
I have disabled the se linux but its not working !!!

Last edited by your_shadow03; 04-08-2009 at 06:22 AM.
 
Old 04-22-2009, 03:08 AM   #3
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,443
Blog Entries: 6

Original Poster
Rep: Reputation: 51
Any Idea why its behaving so?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Issue with SVN? your_shadow03 Linux - Server 1 12-17-2008 11:55 PM
CruiseControl+SVN Issue !!!! ajeetraina Linux - Server 1 11-01-2008 10:31 PM
SVN timestamp issue kingtermite Linux - Server 3 07-14-2008 04:30 PM
SVN Server Access Issue??? ajeetraina Linux - Server 1 03-27-2008 07:59 AM


All times are GMT -5. The time now is 05:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration