LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-29-2011, 01:04 AM   #1
edomingox
Member
 
Registered: Mar 2009
Posts: 49

Rep: Reputation: 15
Is there a way in Grub to enable USB 1.0 instead of USB 2.0?


I'm getting a USB error -71 and I found that disabling ehci_hcd allows my USB port to be usable. When the server boots up, ehci is automatically loaded and once that happens, the USB is rendered useless. Is there a command in Grub to downgrade the USB version?

Another option would be to make an .img to load up without USB 2.0 and using USB 1.0 but I don't know how to make one.
 
Old 04-29-2011, 02:20 AM   #2
toothandnail
Member
 
Registered: Apr 2007
Location: Oxfordshire, UK
Distribution: Arch, Sparky, Salix64
Posts: 93

Rep: Reputation: 8
Quote:
Originally Posted by edomingox View Post
I'm getting a USB error -71 and I found that disabling ehci_hcd allows my USB port to be usable. When the server boots up, ehci is automatically loaded and once that happens, the USB is rendered useless. Is there a command in Grub to downgrade the USB version?

Another option would be to make an .img to load up without USB 2.0 and using USB 1.0 but I don't know how to make one.
You don't say what distribution you are using, which makes it a bit difficult....

Most distributions have a mechanisim for blacklisting kernel modules. Have a look in /etc for whatever your distro uses for the purpose and put the ehci_hcd module in the blacklist. That should sort the problem out.

Paul.
 
Old 04-29-2011, 04:57 AM   #3
edomingox
Member
 
Registered: Mar 2009
Posts: 49

Original Poster
Rep: Reputation: 15
Forgot. I'm using Fedora 8. I know I can do the modprobe -r ehci_hcd to remove it and it works fine. But the problem I have is that command only works after the kernel is loaded. I get no keyboard response after it passes the Grub menu. So, whenever I get an error with the superblock or going through fsck, I cannot interact through IPMI remotely.

I know Grub has the nousb command. I don't want to do that. I already tried irqpoll and that didn't work.
 
Old 04-29-2011, 06:23 AM   #4
toothandnail
Member
 
Registered: Apr 2007
Location: Oxfordshire, UK
Distribution: Arch, Sparky, Salix64
Posts: 93

Rep: Reputation: 8
In Fedora (if I remember correctly, haven't run it for a long time), you need to modify /etc/modeprobe.conf. Syntax should be:

Code:
alias ehci_hcd off
That should prevent the module loading in the first place. I'm not sure if that has any effect if the module is loading due to an intrd. If that is the case, rebuilding the initrd might be your only option.

Paul

Last edited by toothandnail; 04-29-2011 at 06:25 AM.
 
Old 04-30-2011, 10:51 AM   #5
edomingox
Member
 
Registered: Mar 2009
Posts: 49

Original Poster
Rep: Reputation: 15
i believe the module is built into the kernel. ya, i think i'll have to rebuild the initrd. I never done it before so i'm unsure how to successfully do it. I don't have a test machine to do it on.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB: Booting from USB; Creating the Ultimate Bootable USB Stick Jinouchi Linux - Software 2 04-07-2010 04:17 PM
Easy-Peasy USB install of slack-based zorOS-3.6 for grub/syslinux usb noburn iso2 cd linus72 Linux - General 0 07-16-2009 09:31 PM
move grub to usb + mount encrypted devices from usb question Lancelot1 Linux - Security 1 02-26-2009 09:51 AM
Enable USB? jmkelm08 Linux - Hardware 19 07-14-2006 05:45 PM
HP Deskjet (USB) & CUPS & Slackware 9.1: Unable to open USB device "usb:/dev/usb/lp0&qu arnostienen Slackware 2 01-29-2004 03:22 PM


All times are GMT -5. The time now is 11:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration