LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-21-2012, 08:59 AM   #1
hitsware
LQ Newbie
 
Registered: Jul 2012
Posts: 9

Rep: Reputation: Disabled
Is there a software midisynth built into Alsa ?


I can get
{ speaker-test }
to produce sound, but
{ amidi -S "90 3C 45" }
gives me
' cannot open port "default":
inappropriate ioctl for device '
 
Old 07-21-2012, 01:19 PM   #2
i_joh
Member
 
Registered: Apr 2005
Distribution: Debian
Posts: 82

Rep: Reputation: 5
Quote:
Originally Posted by hitsware View Post
I can get
{ speaker-test }
to produce sound, but
{ amidi -S "90 3C 45" }
gives me
' cannot open port "default":
inappropriate ioctl for device '
Install timidity. On Debian 6.0 it sets up a software synth. You have to install some soundfont package too though.
 
Old 07-21-2012, 02:49 PM   #3
hitsware
LQ Newbie
 
Registered: Jul 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
> Install timidity.

Then there is no built in midi-synth ?
 
Old 07-21-2012, 04:20 PM   #4
i_joh
Member
 
Registered: Apr 2005
Distribution: Debian
Posts: 82

Rep: Reputation: 5
Quote:
Originally Posted by hitsware View Post
> Install timidity.

Then there is no built in midi-synth ?
There doesn't appear to be. I use timidity to play midi. It works like a software synth giving music in games like OpenTTD.
 
Old 07-21-2012, 06:48 PM   #5
hitsware
LQ Newbie
 
Registered: Jul 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
> There doesn't appear to be. I use timidity to play midi.
> It works like a software synth giving music in games like OpenTTD.

I may have a more rudimentary problem.
When I type:

$ aconnect -o

I get:

ALSA lib seq_hw.c:457snd_seq_hw_open) /dev/snd/seq failed:
No such file or directory

What am I missing here ?
 
Old 07-22-2012, 04:54 AM   #6
i_joh
Member
 
Registered: Apr 2005
Distribution: Debian
Posts: 82

Rep: Reputation: 5
I've got timidity and timidity-daemon installed. Install those. Then install soundfonts, say freepats. Or you could get CT4MGM.SF2 from a Creative installation disc to get classic Creative MIDI sound. If you get the creative soundfont, put the following in /etc/timidity/timidity.cfg:

Code:
soundfont /usr/local/creative_soundfonts/CT4MGM.SF2
Then try again. It sounds to me you don't have a synth at all.
 
Old 07-22-2012, 05:29 AM   #7
i_joh
Member
 
Registered: Apr 2005
Distribution: Debian
Posts: 82

Rep: Reputation: 5
Here are the MIDI kernel modules that my system has loaded:

snd_seq_midi
snd_rawmidi
snd_seq_midi_event
snd_seq
snd_seq_device

Code:
lsmod | grep mid
Would tell you if you have any modules loaded. If not, load them with modprobe.
 
Old 07-22-2012, 12:04 PM   #8
hitsware
LQ Newbie
 
Registered: Jul 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
>snd_seq_midi
>snd_rawmidi
>snd_seq_midi_event
>snd_seq
>snd_seq_device

Thanks !
Where do I find them ?
 
Old 07-22-2012, 08:37 PM   #9
i_joh
Member
 
Registered: Apr 2005
Distribution: Debian
Posts: 82

Rep: Reputation: 5
Quote:
Originally Posted by hitsware View Post
>snd_seq_midi
>snd_rawmidi
>snd_seq_midi_event
>snd_seq
>snd_seq_device

Thanks !
Where do I find them ?
Just run modprobe <name of module>. The modules should be on your system already.
 
Old 07-22-2012, 09:14 PM   #10
hitsware
LQ Newbie
 
Registered: Jul 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
> The modules should be on your system already.

Thanks. Evedently they're not.
Is there a way to list the modules available ?
 
Old 07-23-2012, 10:12 AM   #11
i_joh
Member
 
Registered: Apr 2005
Distribution: Debian
Posts: 82

Rep: Reputation: 5
Yeah they're in /lib/modules. What distro are you using?
 
Old 07-23-2012, 10:40 AM   #12
hitsware
LQ Newbie
 
Registered: Jul 2012
Posts: 9

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by i_joh View Post
Yeah they're in /lib/modules. What distro are you using?
I found them. I had forgotten to use 'sudo'. TinyCore
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
2.6 built-in alsa doesn't work simopal6 Linux - Hardware 4 03-05-2007 06:35 AM
how to specify built-in alsa drivers? slinky2004 Linux - Hardware 6 01-22-2006 02:09 AM
software management question (rpms and self-built) steyr Linux - General 1 12-30-2003 11:25 AM
2.6.0 minus built-in ALSA drivers + ALSA 1.0.0rc2 Tino27 Slackware 3 12-19-2003 06:13 PM


All times are GMT -5. The time now is 03:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration