LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-08-2007, 08:22 AM   #1
madmanbob
LQ Newbie
 
Registered: Oct 2005
Location: Dordogne, France
Distribution: SUSE 10.2 64 bit
Posts: 29

Rep: Reputation: 15
Is there a problem with Grub? SUSE 10.2


I have 2 rebuilt PCs both running with two hard discs.
The first has SATA discs and a 64 bit cpu. Windows is on the first disc and I installed SUSE 10.2 64 bit on the second disk. Grub will not let me boot the Windows disk. It just freezes up.
The second PC belongs to my wife and has two IDE disks. As before, windows is on the first. I downloaded the CDs for SUSE 10.2 32 bit, and installed it on the second Hard disk. Once again I cannot boot windows anymore.
I was for a few months running SUSE 10 on a similar machine and this had no problem with Grub, giving me the option of booting into windows on the first disk or Linux on the second.
What I would like to know is if there is something different with 10.2 that gives me the same problem on two different machines with two different CD sets?
I think that if people want to play with Linux before making the decision to move from Windows then this will be a major obstacle. On my PC I can get into either OS by unplugging one of the drives, but there is no way that my wife will want to do this.
If I was more knowledgeable about Grub, could I get around this problem? I don't want to go back to SUSE 10 now that I have tried 10.2 and am not sure that that would be the solution anyway.
 
Old 04-08-2007, 10:40 AM   #2
Larry Webb
LQ Veteran
 
Registered: Jul 2006
Location: Crystal Beach, Texas
Distribution: Suse for mail +
Posts: 5,100
Blog Entries: 7

Rep: Reputation: 229Reputation: 229Reputation: 229
As far as I know grub installs the same, here is a tutorial that should help you http://www.linuxquestions.org/linux/...ading_in_Linux
 
Old 04-08-2007, 11:05 AM   #3
madmanbob
LQ Newbie
 
Registered: Oct 2005
Location: Dordogne, France
Distribution: SUSE 10.2 64 bit
Posts: 29

Original Poster
Rep: Reputation: 15
Thanks Larry, I'll look into it this evening. I have managed to find the menu.lst inside /boot/grub and it looks different to the help page, but I will see what I can do. What a learning curve this is going to be!
 
Old 04-08-2007, 04:00 PM   #4
madmanbob
LQ Newbie
 
Registered: Oct 2005
Location: Dordogne, France
Distribution: SUSE 10.2 64 bit
Posts: 29

Original Poster
Rep: Reputation: 15
OK on advice and much reading this is what I have got.
The /boot/grub/menu.lst look like this:

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.2
root (hd0,1)
kernal /boot/vmlinuz root=/dev/sdb2 vga=0x31a resume=/dev/sdb1 splash=silent
showopts
initrd /boot/initrd

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 10.2
root (hd0.1)
kernal /boot/vmlinuz root=/dev/sdb2 vga=normal shopopts ide=nodma apm=off acpi=off
noresume edd=off 3
initrd /boot/initrd


There is no mention of the windows drive, both drives are SATA drives.

I have added this bit to see what it does:

title Windows XP
rootnoverify (hd0,0)
chainloader (hd1,0)+1


When I booted with this bit in the menu.lst, it showed Windows as an option, but when I chose that option, it won't boot into windows.
My question now is, have I got it nearly correct and am I missing something?
 
Old 04-08-2007, 04:47 PM   #5
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
If Windows is on the first partition of the first drive you just need:

Code:
title Windows XP
 rootnoverify (hd0,0)
 chainloader +1
Trying to chainload off (hd1,0) makes no sense as Windows is not on the second hard drive (remember, GRUB numbers hard drives from 0, not 1).
 
Old 04-08-2007, 05:21 PM   #6
madmanbob
LQ Newbie
 
Registered: Oct 2005
Location: Dordogne, France
Distribution: SUSE 10.2 64 bit
Posts: 29

Original Poster
Rep: Reputation: 15
Tried that, but still does not work. I am beginning to understand this a little more now and looked at a file on /boot/grub/ which said only:
(hd1) /dev/sda
(hd0) /dev/sdb

The linux is on the sdb and the windows on the sda. I have tried changing the rootnoverify line to have (hd0,0), (hd1,0), (hd1,1) and (hd0,1). I have also changed the chainloader line to read just +1 with all these options and still cannot get it to work.
If I unplug the Linux hard drive it will boot strait into windows, so I know there is not a problem there.
 
Old 04-08-2007, 05:25 PM   #7
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,289

Rep: Reputation: 126Reputation: 126
Have you tried remapping your drives in the windows section?

Example:
Code:
title Windows XP
      rootnoverify    (hd1,0)
      map (hd0) (hd1)
      map (hd1) (hd0)
      makeactive
      chainloader +1
 
Old 04-08-2007, 05:39 PM   #8
madmanbob
LQ Newbie
 
Registered: Oct 2005
Location: Dordogne, France
Distribution: SUSE 10.2 64 bit
Posts: 29

Original Poster
Rep: Reputation: 15
I tried the map command lines as you have suggested, (I saw this on another thread) but I tried putting them below the chainloader, which didn't work, so I moved then to above the rootnoverify line which didn't work either.
Both ways the grub loader failed when it got to the map command.
 
Old 04-08-2007, 06:16 PM   #9
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,289

Rep: Reputation: 126Reputation: 126
Added:
Quote:
I tried the map command lines as you have suggested, (I saw this on another thread) but I tried putting them below the chainloader
Just to verify, does that mean that you have not tried it the way I posted?
(end added)

Have you tried root instead of rootnoverify? Is your root statement with (hd0,0) or (hd1,0)? It might help if you'd boot linux and run fdisk -l to make exactly sure of the partitions on the doze drive.

I'm not a grub expert, but here is what I understand of the grub lines I posted. If you look at it this way, do you think there should be a change to it for your situation?

rootnoverify (hd1,0) doze root is located on the first partition of the second BIOS drive
map (hd0) (hd1)
map (hd1) (hd0) after root is defined above swap hd0 and hd1 so that doze sees hd0 and not hd1 when it boots
makeactive make this swapped root active
chainloader +1 chainload to the second bios drive

One thing that you might try is to add "boot" after the chainloader statement.

Last edited by Quakeboy02; 04-08-2007 at 06:17 PM.
 
Old 04-08-2007, 06:41 PM   #10
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,403

Rep: Reputation: 2011Reputation: 2011Reputation: 2011Reputation: 2011Reputation: 2011Reputation: 2011Reputation: 2011Reputation: 2011Reputation: 2011Reputation: 2011Reputation: 2011
Post #1
Quote:
Grub will not let me boot the Windows disk. It just freezes up.
Post #4
Quote:
here is no mention of the windows drive,
Say what ???.
Nobody is going to be able to help without proper info - let's see the (full) output from the following, from one machine.
Code:
/sbin/fdisk -l
cat /boot/grub/menu.lst
(lower case ell in both commands).

I would have expected the stanza from Quakeboy02 to work - presuming first partition on "first" disk.
 
Old 04-09-2007, 07:52 AM   #11
madmanbob
LQ Newbie
 
Registered: Oct 2005
Location: Dordogne, France
Distribution: SUSE 10.2 64 bit
Posts: 29

Original Poster
Rep: Reputation: 15
Thanks for all the replies. I ended up having to reload linux last night, my fault I think. I have now decided to leave the system how it is and change the hard drives around in the BIOS if I need to boot into Windows.
I think that part of my problem is that I was logging on as root and changing the menu.lst file using kwrite and then saving it. Perhaps this is not the correct way to do things, but I am still learning.
The only reason that I need to use windows now is to play the odd game.
Thanks again.
 
Old 04-09-2007, 10:59 AM   #12
junglistno1
Member
 
Registered: Apr 2007
Posts: 36

Rep: Reputation: 15
im been having the exact same problems, when my pc boots up i get a selection of:-

suse 10.2
windows
suse 10.2 (fail safe)

Suse works o.k but windows doesn't now just comes up with:-
rootnoverify (hd0,0)
chainloader (hd1,0)+1

its really strange coz when i first installed suse GRUB didnt work and i had to boot of cd, my pc always booted to windows. then it just started working a day or so later!

anyone got any ideas what might cure this?
 
Old 04-10-2007, 07:23 AM   #13
madmanbob
LQ Newbie
 
Registered: Oct 2005
Location: Dordogne, France
Distribution: SUSE 10.2 64 bit
Posts: 29

Original Poster
Rep: Reputation: 15
I have at last found a work around. The answer was a small program called GAG. I have set it up and installed it and I now have the choice of booting into Windoze or into Grub. Am I happy? You bet I am.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub problem - cannot boot Suse 10.1 Kenchie SUSE / openSUSE 5 12-15-2006 12:44 PM
Grub problem - cannot boot Suse 10.0 Kenchie SUSE / openSUSE 3 03-01-2006 08:50 PM
problem reinstalling grub in suse thearchitect Linux - Newbie 1 08-21-2005 04:33 PM
SUSE - Grub Problem Harryc Linux - Newbie 3 05-01-2004 12:32 PM
SuSE boot problem grub and 2.6.3 deuce868 Linux - General 1 03-01-2004 03:44 AM


All times are GMT -5. The time now is 04:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration