LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-20-2010, 08:53 PM   #1
PureRumble
LQ Newbie
 
Registered: Mar 2007
Posts: 14

Rep: Reputation: 0
Is my connection problems due to "UP BROADCAST RUNNING MULTICAST"?


Hi all.

I have kubuntu 9.10 on my laptop. My question is regarding the wireless connection.

I have a wireless modem (NOT a router) that I connect to.

When I startup kubuntu and choose my (wireless) network to connect to through the network manager, I get an unstable and sluggish download speed.

It is a good speed for a few seconds (sometimes even longer) but then it hits rock bottom (really no download at all) for many seconds. Then it goes up again for a few seconds, just to go back to zero again, and so on. This keeps repeating forever.

A screenshot of system monitor's network diagrams would really show mountains intervened by flat valleys.

I took note of relevant parts of ifconfig's and iwconfig's outputs.

Then I do

ifconfig wlan0 down
ifconfig wlan0 up

after that I choose my wireless network to connect to through the network manager again.

Now I have excellent and stable download speed. No problems at all (unless the speed can even be better than what I observe but I doubt this).

Now, remember I said I took note of ifconfig's and iwconfig's outputs? Well I produce their outputs again and the only difference I can observe is that ifconfig says "UP BROADCAST RUNNING MULTICAST" for wlan0 instead of "UP BROADCAST MULTICAST" as it said for the same interface before I did ifconfig down and up.

QUESTION 1: Is the broacast-thingie what's causing my troubles? What is it anyway?

If I restart kubuntu then I have the same problem going on again.

QUESTION 2: How can I fix this permanently?

Thx!

//PureRumble
 
Old 02-21-2010, 11:03 AM   #2
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: Debian 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,766

Rep: Reputation: Disabled
/proc/net/wireless

#man iwconfig

you can tweak many things : freq, bit rate ...
 
Old 02-21-2010, 07:28 PM   #3
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,542
Blog Entries: 23

Rep: Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943
Hi,

How about sharing the outputs?

Does no good for a description since there is possible omissions or misdiagnosis.

The modem your are using is a broadband or DSL with a wireless device?
 
Old 02-23-2010, 01:29 PM   #4
PureRumble
LQ Newbie
 
Registered: Mar 2007
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by onebuck View Post
Hi,

How about sharing the outputs?

Does no good for a description since there is possible omissions or misdiagnosis.

The modem your are using is a broadband or DSL with a wireless device?
Hi! Thx for helping out!

It is a DSL wireless modem, and like I said before it is not a router.

Now I'll give some output!

Recall that the problem (sluggish download speed) goes away after I have done ifconfig wlan0 down followed by ifconfig wlan0 up (I obtain a stable download speed). I wanna know why so I can make the change permanent!

So here is the output of ifconfig & iwconfig before I do ifconfig wlan0 down & up:

output of ifconfig:
Code:
	eth0      Link encap:Ethernet  HWaddr 90:e6:ba:72:8f:52  
						UP BROADCAST MULTICAST  MTU:1500  Metric:1
						RX packets:0 errors:0 dropped:0 overruns:0 frame:0
						TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
						collisions:0 txqueuelen:1000 
						RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
						Interrupt:28 Base address:0x2000 

	lo        Link encap:Local Loopback  
						inet addr:127.0.0.1  Mask:255.0.0.0
						inet6 addr: ::1/128 Scope:Host
						UP LOOPBACK RUNNING  MTU:16436  Metric:1
						RX packets:44 errors:0 dropped:0 overruns:0 frame:0
						TX packets:44 errors:0 dropped:0 overruns:0 carrier:0
						collisions:0 txqueuelen:0 
						RX bytes:2640 (2.6 KB)  TX bytes:2640 (2.6 KB)

	wlan0     Link encap:Ethernet  HWaddr 1c:4b:d6:33:df:81  
						inet addr:213.113.64.50  Bcast:213.113.65.255  Mask:255.255.254.0
						inet6 addr: fe80::1e4b:d6ff:fe33:df81/64 Scope:Link
						UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
						RX packets:10 errors:0 dropped:0 overruns:0 frame:0
						TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
						collisions:0 txqueuelen:1000 
						RX bytes:1126 (1.1 KB)  TX bytes:4607 (4.6 KB)

	wmaster0  Link encap:UNSPEC  HWaddr 1C-4B-D6-33-DF-81-00-00-00-00-00-00-00-00-00-00  
						UP RUNNING  MTU:0  Metric:1
						RX packets:0 errors:0 dropped:0 overruns:0 frame:0
						TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
						collisions:0 txqueuelen:1000 
						RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
output of iwconfig:
Code:
	lo        no wireless extensions.

	eth0      no wireless extensions.

	wmaster0  no wireless extensions.

	wlan0     IEEE 802.11bgn  ESSID:"B2_private_71"  
						Mode:Managed  Frequency:2.462 GHz  Access Point: 00:01:38:A2:10:D7   
						Bit Rate=54 Mb/s   Tx-Power=20 dBm   
						Retry  long limit:7   RTS thr:off   Fragment thr:off
						Encryption key:8145-7298-23
						Power Management:on
						Link Quality=67/70  Signal level=-43 dBm  
						Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
						Tx excessive retries:0  Invalid misc:0   Missed beacon:0
And here is the output of ifconfig & iwconfig after that I've done ifconfig wlan0 down & up.

output of ifconfig:
Code:
	eth0      Link encap:Ethernet  HWaddr 90:e6:ba:72:8f:52  
						UP BROADCAST MULTICAST  MTU:1500  Metric:1
						RX packets:0 errors:0 dropped:0 overruns:0 frame:0
						TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
						collisions:0 txqueuelen:1000 
						RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
						Interrupt:28 Base address:0x2000 

	lo        Link encap:Local Loopback  
						inet addr:127.0.0.1  Mask:255.0.0.0
						inet6 addr: ::1/128 Scope:Host
						UP LOOPBACK RUNNING  MTU:16436  Metric:1
						RX packets:44 errors:0 dropped:0 overruns:0 frame:0
						TX packets:44 errors:0 dropped:0 overruns:0 carrier:0
						collisions:0 txqueuelen:0 
						RX bytes:2640 (2.6 KB)  TX bytes:2640 (2.6 KB)

	wlan0     Link encap:Ethernet  HWaddr 1c:4b:d6:33:df:81  
						inet addr:213.113.64.50  Bcast:213.113.65.255  Mask:255.255.254.0
						inet6 addr: fe80::1e4b:d6ff:fe33:df81/64 Scope:Link
						UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
						RX packets:40 errors:0 dropped:0 overruns:0 frame:0
						TX packets:47 errors:0 dropped:0 overruns:0 carrier:0
						collisions:0 txqueuelen:1000 
						RX bytes:4458 (4.4 KB)  TX bytes:8851 (8.8 KB)

	wmaster0  Link encap:UNSPEC  HWaddr 1C-4B-D6-33-DF-81-00-00-00-00-00-00-00-00-00-00  
						UP RUNNING  MTU:0  Metric:1
						RX packets:0 errors:0 dropped:0 overruns:0 frame:0
						TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
						collisions:0 txqueuelen:1000 
						RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
output of iwconfig:
Code:
	lo        no wireless extensions.

	eth0      no wireless extensions.

	wmaster0  no wireless extensions.

	wlan0     IEEE 802.11bgn  ESSID:"B2_private_71"  
						Mode:Managed  Frequency:2.462 GHz  Access Point: 00:01:38:A2:10:D7   
						Bit Rate=54 Mb/s   Tx-Power=20 dBm   
						Retry  long limit:7   RTS thr:off   Fragment thr:off
						Encryption key:8145-7298-23
						Power Management:on
						Link Quality=48/70  Signal level=-62 dBm  
						Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
						Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Does this tell you guys why the problem all of a sudden goes away? Do you need me to share anymore output?

Thx for reading!

//PureRumble

Last edited by PureRumble; 02-23-2010 at 01:31 PM.
 
Old 02-27-2010, 03:21 PM   #5
PureRumble
LQ Newbie
 
Registered: Mar 2007
Posts: 14

Original Poster
Rep: Reputation: 0
Bump + an update.

I don't think this is related to security settings, since I changed the protocol from WEP to WPA PSK and the problem still remains.

So I just wanna know why doing ifconfig wlan0 down+up solves this problem.

Anyone?
 
Old 02-28-2010, 01:10 AM   #6
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Rep: Reputation: 146Reputation: 146
When i do:- ifconfig

It reports the same thing as you. I don't think its a problem.
 
Old 12-21-2014, 01:17 PM   #7
prarxol
LQ Newbie
 
Registered: Dec 2014
Posts: 1

Rep: Reputation: Disabled
Use

sudo dhclient eth0

then internet will work.

Once you use other modes to use internet (like wireless, usb tethering) and get to ethernet, you may get this problem. I had same problem and it was solved using above command.

Thanks,
PT
 
Old 12-21-2014, 02:36 PM   #8
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 2,404

Rep: Reputation: Disabled
I can see no significant differences in the output from ifconfig/ifwonfig before and after you took the interface down and back up. If anything, the reported link quality was better before the interface reset.

Disabling and re-enabling the interface will cause entries in the routing table to be removed and re-inserted. In your case, it will also cause some background daemon to renew the DHCP lease and thereby re-insert the default gateway entry.

Could you post the output from route -n before and after you reset the wlan0 interface?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Issue with vnc server "tightVNC: VNC server closed connection", due to Screensaver frenchn00b General 1 07-30-2009 07:55 AM
net working eth0 eth1 wlan0 "no connection" "no LAN" "no wi-fi" Cayitano Linux - Newbie 5 12-09-2007 08:11 PM
eth0: UP BROADCAST MULTICAST but *not* RUNNING!... romasport Linux - Newbie 1 06-30-2004 12:48 PM
Up Broadcast Running Multicast code_noc Linux - General 2 10-16-2003 11:52 AM
Up Broadcast Notrailers Running Multicast snocked Linux - Networking 2 02-15-2003 11:27 PM


All times are GMT -5. The time now is 12:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration