LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-26-2003, 04:09 AM   #1
Baran
Member
 
Registered: Aug 2003
Location: Tampere-FINLAND
Distribution: Mandrake 10.1
Posts: 105

Rep: Reputation: 15
Is konsole different under KDE 3.1


I guess I have a problem with my KDE 3.1, when I open a console under KDE and write

ldconfig

for instance it gives an error, (this is same for other commands under /sbin)

file or command not found

however it works well if I do

/sbin/ldconfig

but isn't /sbin in the path? if I am not using KDE, I can call

ldconfig

directly. I guess I must add /sbin to a configuration file of KDE3.1. Am I right? If I am how should I correct this?

thank you for your help...
 
Old 09-26-2003, 06:04 AM   #2
UltimaGuy
Member
 
Registered: Aug 2003
Location: Chennai, India
Distribution: PCLinuxOS .92, FC4
Posts: 840

Rep: Reputation: 30
I have never heard this before. Maybe you are logging in as a different user and switching over to root using su?

If that is the case you have to use su - <Enter> in order for root's environment to be imported. Then you can just type ldconfig and it will work.

Am I correct?
 
Old 09-26-2003, 06:43 AM   #3
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,656

Rep: Reputation: Disabled
You can test that by typing
Code:
echo $PATH
and look for /sbin.

Please remember that commands are case sensitive ...
 
Old 10-02-2003, 07:18 AM   #4
Baran
Member
 
Registered: Aug 2003
Location: Tampere-FINLAND
Distribution: Mandrake 10.1
Posts: 105

Original Poster
Rep: Reputation: 15
I wrote

echo $PATH

and I couldn't see /sbin there, it seems that it is missing

how can I add /sbin to the PATH?
 
Old 10-02-2003, 07:26 AM   #5
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,656

Rep: Reputation: Disabled
Type
Code:
export PATH=$PATH:/sbin
and test whether it works.

To make it permanent, edit the original PATH declaration. For individual users it is set in ~/.bash but there is also a global .bash, I just don't remember where it lies ... (locate .bash )
 
Old 10-06-2003, 04:40 PM   #6
Baran
Member
 
Registered: Aug 2003
Location: Tampere-FINLAND
Distribution: Mandrake 10.1
Posts: 105

Original Poster
Rep: Reputation: 15
Thanks JZL240I-U, I guess you solved the problem I made the PATH permanent by adding the line to .bash_profile file which is located in my home directory. Now everything is fine.
Thanks again..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE/Konsole Casket Linux - Newbie 3 10-08-2005 11:24 PM
KDE- Konsole Fonts Anmol Debian 3 08-07-2005 01:15 AM
no fonts in KDE konsole chess Slackware 1 05-23-2005 07:21 PM
KDE 3.2 Konsole Terminal jam222 Linux - Newbie 5 02-26-2004 04:52 PM
KDE Konsole Krappy Linux - Software 5 10-14-2002 09:41 PM


All times are GMT -5. The time now is 07:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration