LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-10-2011, 10:13 AM   #1
darthpinguim
Member
 
Registered: Feb 2011
Location: Belo Horizonte - MG - Brasil
Distribution: Ubuntu 12.04 / Debian 6
Posts: 32

Rep: Reputation: 0
Question Is it possible to configure GRUB2 booting time?


Hi folks!
I've been facing this problem since the release of Ubuntu 9.10 (I guess), as GRUB was changed into GRUB2.
In earlier Ubuntu releases it was possible to configure the booting menu loaded from /boot/grub in the "menus.lst" file. In this file it was possible to change the booting menu time, even to "0" (zero), what would make the menu to stay on display.
Now, in GRUB2 there's no "menus.lst" file anymore. There's a file "boot.cfg", which I think would be the "menus.lst" similar in the newer Ubuntu versions. I've made a copy of this file, so that I could try changing it in order to change booting time. I succeeded in increasing the boot menu time, but could not change it so that there would be no time in the menu. Is there anything that can be done to set this time to "0" (zero), so that it won't boot directly to the first OS in the list?

With attention
darthpinguim "May the Linux Force be with you!"
 
Old 02-10-2011, 10:22 AM   #2
rafatmb
LQ Newbie
 
Registered: Feb 2011
Posts: 27

Rep: Reputation: 3
To configure that, edit the file: /etc/default/grub.

Change the line GRUB_TIMEOUT=10 to the time you want.

Then run update-grub to apply.
 
Old 02-10-2011, 10:25 AM   #3
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,412
Blog Entries: 2

Rep: Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995
You should not modify the grub.cfg-file. This file is auto-generated, and all your changes will be lost the next time an update issues the update-grub command.
If you want to modify Grub's behavior you should modify /etc/default/grub instead. There is an option named GRUB_TIMEOUT. If you set this to zero the time-out should be disabled.
Remember to do
Code:
sudo update-grub
every time you have modified that file, so that Grub can generate a new grub.cfg.
 
Old 02-10-2011, 12:54 PM   #4
darthpinguim
Member
 
Registered: Feb 2011
Location: Belo Horizonte - MG - Brasil
Distribution: Ubuntu 12.04 / Debian 6
Posts: 32

Original Poster
Rep: Reputation: 0
Hey there! Thanks for the replies.
I have already done that, and that's something I've mentioned above.
I can increase the boot menu time, by increasing the number in "GRUB_TIMEOUT=x". I've done that, and it worked fine.
But my question was about the possiblity of setting off the boot menu time, so that if I turn my computer on and leave for a while (before selecting the OS), when I get back the boot menu will still be on my screen.
If I set the time to zero (GRUB_TIMEOUT=0) then the computer boots directly to the first operating system in the list. Therefore, the menu won't be displayed.
 
Old 02-10-2011, 01:07 PM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,412
Blog Entries: 2

Rep: Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995
I just had a look at the Grub 2 manual, especially the part about the config-file. The right value for GRUB_TIMEOUT is -1 to disable the time-out.
I hope this will help you.
 
Old 02-11-2011, 06:32 AM   #6
darthpinguim
Member
 
Registered: Feb 2011
Location: Belo Horizonte - MG - Brasil
Distribution: Ubuntu 12.04 / Debian 6
Posts: 32

Original Poster
Rep: Reputation: 0
Thanks TobiSGD!
Now it worked out. Helped a lot!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting FreeBSD iso grub2 jmc1987 Linux - Newbie 3 01-20-2011 08:03 PM
[SOLVED] grub2 indirect booting from separate partition Larry Webb Linux - General 9 12-19-2010 12:35 PM
booting remastersys iso using grub2 anandogc Linux - Software 5 08-27-2010 07:39 AM
grub2 ./configure error nwtlnxqstns Linux - Newbie 3 07-07-2010 08:41 PM
[SOLVED] Problem in Booting Linux(GRUB2) Kcghost Linux - Software 1 12-04-2009 06:11 PM


All times are GMT -5. The time now is 06:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration