LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-21-2004, 03:05 AM   #1
jing
Member
 
Registered: May 2004
Location: Singapore
Posts: 30

Rep: Reputation: 15
Unhappy Is it not adviceable to upgrade glibc?


When I tried to

Code:
rpm -ivh pvfs-1.6.0-1.i386.rpm
I got this error
Code:
error: failed dependencies: libc.so.6(GLIBC_2.3) is needed by pvfs-1.6.0-1
This means my libc needs an update, is that right?
Does anyone happens to know where I can get it?
And I've heard that upgrading glibc is going to cause a lot of problems, can a like me do it?

Thanks in advance.
 
Old 07-21-2004, 03:17 AM   #2
bahramH
Member
 
Registered: Apr 2004
Location: France
Distribution: Mandrake
Posts: 67

Rep: Reputation: 15
Some of your other programs can rely on older version of glibc, and refuse to work after an update. I got this problem with Mathematica 4.1 and I had to install the older version in paralel.

But if you don't update, many new programs would not install. So I advise you to go ahead and give it a try.
 
Old 07-21-2004, 03:20 AM   #3
jing
Member
 
Registered: May 2004
Location: Singapore
Posts: 30

Original Poster
Rep: Reputation: 15
But I can't seems to find libc.so.6(GLIBC_2.3), anyone happens to know where I can find it?

Thanks
 
Old 07-21-2004, 04:27 AM   #4
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
unless your distro vendor provides an updated package, its not a good idea to upgrade it manually.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
newb question on GNU glibc-2.3.1 upgrade to GNU glibc-2.3.2 clindy528 Slackware 1 11-10-2005 06:49 AM
GLIBC Upgrade steveoelliott Slackware 10 06-22-2005 01:32 AM
upgrade glibc-2.2.4 to glibc-2.3.2 on redhat 7.2 Shuja Red Hat 0 07-28-2004 06:10 AM
how to upgrade from glibc 2.2.4 to 2.3.x lpriyamb Linux - Software 1 09-12-2003 05:44 AM
How to upgrade glibc? PeteRossi Slackware 2 06-14-2002 12:03 PM


All times are GMT -5. The time now is 03:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration