LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-28-2003, 08:45 AM   #1
stevsurf
LQ Newbie
 
Registered: Jun 2003
Distribution: Red Hat 9
Posts: 6

Rep: Reputation: 0
IRQ Conflict


I run dual boot Windows95/Linux Redhat 9 on a computer with a PnP Bios.

Under Linux there is an IRQ conflict between the serial mouse on COM1 and the PnP modem on COM3 where both want to use IRQ 4. There is no conflict under Windows, where the modem uses IRQ 10.

I would like to change the IRQ for either the mouse or the modem. I have tried using setserial to change IRQ for ttyS0 (mouse on COM1), but get an error message that the mouse is in use and so the IRQ cannot be changed.

Linux does not allow me to make changes to the file /proc/isapnp where the IRQ 4 is listed for the modem.

Please has anyone suggestions for resolving the conflict.
Thank you.
 
Old 09-28-2003, 09:23 AM   #2
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
I had this sort of thing in the past before retiring my modem and ISA soundcard. I think I found some setting in the BIOS which reserved certain IRQs for PnP or hardwired devices, and fixed the problem.

There is also a kernel parameter 'isapnp_reserve_irq=' which I don't recall ever using, but looks promising.

Finally there is a set of tools called 'isapnp' or 'isapnptools' which use a configuration file to negotiate with any PnP devices on start-up. I seem to recall I found understanding this pretty heavy going.
 
Old 09-28-2003, 09:51 AM   #3
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
Be careful with this advice, possibly wait for someone to comment on it before acting:

As far as I can tell

/dev/modem

is a symbolic link to a com/serial port

you can ls -l /dev/modem to see which one it's linked to at the moment probably ttyS0 same as your mouse or possibly ttyS2

As it's a symbolic link my guessing is you can delete it and recreate it again pointing to the a different serial port

ln -s /dev/ttyS1 /dev/modem

or ttyS3


There's probably a way to do it graphically but as I say this is a hunch and might not even work, hang in there and wait for an other opinion

Last edited by Looking_Lost; 09-28-2003 at 09:54 AM.
 
Old 10-02-2003, 09:18 AM   #4
stevsurf
LQ Newbie
 
Registered: Jun 2003
Distribution: Red Hat 9
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
There is also a kernel parameter 'isapnp_reserve_irq=' which I don't recall ever using, but looks promising.
Please tell me in which file the isapnp_reserve_irq statement should go.

Thank you.
 
Old 10-02-2003, 09:25 AM   #5
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
what is on com 2? if nothing, put your mouse there.
or
change the bios setting "Plug n' Play OS installed" to no
or
change the bios setting for serial port 1 to a different irq
or
change the bios settings to reserve irq's 3 and 4.
 
Old 10-02-2003, 12:59 PM   #6
stevsurf
LQ Newbie
 
Registered: Jun 2003
Distribution: Red Hat 9
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks whansard for your suggestions. Unfortunately COM 2 is not available for the mouse. I would prefer not to change the bios settings as linux is part of a dual boot computer.

Can the COM1 irq setting be changed without changing the bios and before resources are assigned to the Mouse?
 
Old 10-02-2003, 02:06 PM   #7
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
the plug n play os setting in the bios does the following.
if set to yes, then plug n' play devices are not initialized.
if set to no, they are initialized and given the resources
they need.

most of these settings will not mess up windows, but
windows will likely go through a hardware detection
when you start it next time.
 
Old 10-03-2003, 02:01 AM   #8
toloban
Member
 
Registered: Sep 2003
Location: D.F.
Distribution: Fedora Core
Posts: 35

Rep: Reputation: 16
I had the same problem. My modem jumpers were set to IRQ 3 and port 4, and this was the only way it worked in Windows. But it didn't under Linux.

I used BIOS setup to use IRQ 4 for both internal serial ports, and it worked, but things got a bit messed up because now COM 2 became COM 3

Serial driver version 5.05c (2001-07-08) with MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI enabled
ttyS0 at 0x03f8 (irq = 4) is a 16550A
ttyS2 at 0x03e8 (irq = 4) is a 16550A
ttyS3 at 0x02e8 (irq = 3) is a 16550A

I have a drawing tablet attached to port 2 so I had to change everything in my XF86Config from /dev/ttyS1 to /dev/ttyS2. But under windows 98 and 2000 both the modem and the tablet continued to work perfectly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Do I have an IRQ conflict? hpladd Linux - Newbie 2 08-04-2005 03:43 PM
IRQ Conflict (please help!) justintime32 Mandriva 2 02-24-2005 07:07 PM
irq conflict rsmereka Linux - Hardware 11 07-16-2003 05:15 PM
IRQ conflict Nitemare Linux - Hardware 1 05-22-2002 01:56 PM
irq conflict?? dsequeir Linux - Newbie 0 02-21-2002 02:11 AM


All times are GMT -5. The time now is 04:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration