LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-20-2010, 12:59 AM   #1
ajayan
Member
 
Registered: Dec 2007
Posts: 89

Rep: Reputation: 16
IPSEC- Error " no connection has been authorized with policy=PSK"


Hi,
i am trying to configure Ipsec Host to Host Configuration Using openswan and L2tp.eth0 holds static Ip and eth1 holds 192.168.10.15.Here is My Configuration files.

/etc/ipsec.conf

version 2.0
config setup
interfaces=%defaultroute
klipsdebug=none
plutodebug=none
overridemtu=1410
nat_traversal=yes
virtual_private=%v4:10.0.0.0/8,%v4:172.16.0.0/12,%v4:192.168.10.0/24
conn %default
keyingtries=3
compress=yes
disablearrivalcheck=no
authby=secret
type=tunnel
keyexchange=ike
ikelifetime=240m
keylife=60m
conn roadwarrior
pfs=no
left=192.168.10.15
leftnexthop=%defaultroute
leftprotoport=17/0
rightprotoport=17/1701
right=%any
rightsubnet=vhost:%no,%priv
auto=add

/etc/l2tpd/l2tpd.conf

[global]
port = 1701
[lns default]
ip range = 192.168.10.101-192.168.10.254
local ip = 192.168.10.15
require chap = yes
refuse pap = yes
require authentication = yes
name = LinuxVPN
ppp debug = yes
pppoptfile = /etc/ppp/options.l2tpd
length bit = yes

/etc/ipsec.secrets

: PSK "redhat"

/etc/ppp/chap-secrets

vpn * redhat *

Now every thing started fine.For the sake of testing i had disabled firewall and only one rules is added.
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE.When i tried from Win Xp (Another network and another Static IP),its showing error 789.L2TP Connection attempt failed.Here is my log file

May 20 11:11:16 server pluto[20240]: packet from 65.117.27.31:500: ignoring Vendor ID payload [MS NT5 ISAKMPOAKLEY 00000004]
May 20 11:11:16 server pluto[20240]: packet from 65.117.27.31:500: ignoring Vendor ID payload [FRAGMENTATION]
May 20 11:11:16 server pluto[20240]: packet from 65.117.27.31:500: received Vendor ID payload [draft-ietf-ipsec-nat-t-ike-02_n] method set to=106
May 20 11:11:16 server pluto[20240]: packet from 65.117.27.31:500: ignoring Vendor ID payload [Vid-Initial-Contact]
May 20 11:11:16 server pluto[20240]: packet from 65.117.27.31:500: initial Main Mode message received on 122.166.23.39:500 but no connection has been authorized with policy=PSK

How can i Solve the Issue?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pidgin error, XMMS account says "Not authorized" preeti_c Linux - Newbie 3 08-07-2011 01:48 PM
anybody familiar with this error "Xlib: connection to ":0.0" refused by server" ? rajnivanza Linux - Newbie 3 03-22-2009 05:10 PM
net working eth0 eth1 wlan0 "no connection" "no LAN" "no wi-fi" Cayitano Linux - Newbie 5 12-09-2007 07:11 PM
CUPS: "This server could not verify that you are authorized to use this resrouce" hamish Linux - Software 0 07-02-2004 03:57 AM
Ascend Error "Requested Service Not Authorized" tempehops Linux - Networking 0 01-16-2002 07:25 PM


All times are GMT -5. The time now is 10:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration