LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-11-2003, 10:33 PM   #1
Canadian_2k2
Member
 
Registered: Oct 2002
Location: BC,Canada
Distribution: Debian
Posts: 92

Rep: Reputation: 15
ip help


Please help...
I am trying to get an ipv6 adress
when I run tspc -v I get

# tspc -v
tspc - Tunnel Server Protocol Client

Loading configuration file

Connecting to server

Send request

Process response from server

TSP_HOST_TYPE host
TSP_TUNNEL_INTERFACE sit1
TSP_HOME_INTERFACE
TSP_CLIENT_ADDRESS_IPV4 24.81.80.117
TSP_CLIENT_ADDRESS_IPV6 3ffe:0b80:0003:9769:0000:0000:1851:5075
TSP_SERVER_ADDRESS_IPV4 206.123.31.114
TSP_SERVER_ADDRESS_IPV6 3ffe:0b80:0003:9769:0000:0000:0000:0001
TSP_TUNNEL_PREFIXLEN 128
TSP_VERBOSE 1
TSP_HOME_DIR /etc/freenet6
--- Start of configuration script. ---
Script: setup.sh
sit1 setup
Setting up link to 206.123.31.114
ioctl: No such device
Error while executing /sbin/ip
Command: /sbin/ip tunnel add sit1 mode sit ttl 64 remote 206.123.31.114
Closing, exit status: 0
Exiting with return code : 0 (0 = no error)
#
---------------------
what is ioctl? and should it be sit1? my ethernet device is eth0.....
can somebody please help?

thanx
 
Old 06-12-2003, 01:51 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,569

Rep: Reputation: 171Reputation: 171
ioctl is a command to manipulate special files (devices). From the error message it looks that it gets a wrong (not existing) device. My guess is thet there's something wrong in the configuration. Check everything again.
 
Old 06-12-2003, 07:31 PM   #3
Canadian_2k2
Member
 
Registered: Oct 2002
Location: BC,Canada
Distribution: Debian
Posts: 92

Original Poster
Rep: Reputation: 15
There isn't much in the tspc.conf
what should I be looking for?
 
Old 06-13-2003, 03:36 PM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,569

Rep: Reputation: 171Reputation: 171
Quote:
--- Start of configuration script. ---
Script: setup.sh
Frst find the 'setup.sh' script and search for text 'Setting up link to'. The command that gives the error should be near.
 
Old 06-13-2003, 09:11 PM   #5
Canadian_2k2
Member
 
Registered: Oct 2002
Location: BC,Canada
Distribution: Debian
Posts: 92

Original Poster
Rep: Reputation: 15
I found this.....
what is wrong with it?
Display 1 "$TSP_TUNNEL_INTERFACE setup"
Display 1 "Setting up link to $TSP_SERVER_ADDRESS_IPV4"
if [ -x $ipconfig ]; then
Exec $ipconfig tunnel add $TSP_TUNNEL_INTERFACE mode sit ttl 64 remote $TSP_SERVER_ADDRESS_IPV4
else
Exec $ifconfig $TSP_TUNNEL_INTERFACE tunnel ::$TSP_SERVER_ADDRESS_IPV4
fi

thanx
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off




All times are GMT -5. The time now is 05:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration