LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-31-2009, 07:49 PM   #1
byerlyd
LQ Newbie
 
Registered: Jan 2009
Posts: 4

Rep: Reputation: 0
Question IOMMU can anyone help


Hello everyone, this is the first time I have ever tried an OS besides Windows. I am in the process of building a new computer and thought I would give this a try, the following is my set up:

Asus M3a79-T Deluxe motherboard with AM2 AMD Athlon 64 Duel-Core
Four one gig sticks Corsair DDR2 800 ram
Two PCI-E MSI 8600 GTS cards
Four 500 gig Seagate SATA hard drives, running one single RAID ready and three in RAID 5
Two SATA CDR's
One floppy drive

This is my problem I loaded Ubuntu 8.10 desktop-AMD64. It loaded great started right up downloaded all the updates and the driver for the video card and rebooted. After the reboot I get a screen that says:

Please enable IOMMU
No aperture memory hole
it will only take 64 MB

Well you get the picture, I have looked all through my manual and through my bois screens for anything on IOMMU and how to turn it on but found nothing. I also looked at other threads on this topic and am not sure if they would help me or not can anyone guide me through this and help me fix the problem.
 
Old 01-31-2009, 08:05 PM   #2
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: Debian 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,766

Rep: Reputation: Disabled
Welcome to LQ!

Append iommu=calgary in the kernel line in grub.conf

you do not have the h/w apparently
 
Old 02-01-2009, 12:34 AM   #3
AuroraCA
Member
 
Registered: Jul 2008
Location: Northern CA USA
Distribution: Ubuntu, Slackware, Gentoo, Fedora, Red Hat, Puppy Linux
Posts: 370

Rep: Reputation: 35
An IOMMU is a device that will support mapping memory addresses. There is currently high-end branded server hardware that support this, but no desktop machines support IOMMU, AFAIK. An example IOMMU is the AGP and PCI Express graphics cards.

You can try to enable IOMMU as suggested above with the iommu=calgary in the /boot/grub/menu.lst kernel: lines.

You need hardware and software to support IOMMU. Above instructions will just turn on Linux kernel software support. Since current hardware support is limited to high-end expensive server most Linux distro does not enable calgary DMA address mapping with memory protection by default.

If you wish to turn off iommu to disable the warning messages you need to enter iommu=noaperture at the end of the kernel: line in /boot/grub/menu.lst as follows:

Code:
title        Ubuntu 8.10, kernel 2.6.27-9-generic
uuid        e1af5d58-4452-45a4-96ce-20445ec59834
kernel        /boot/vmlinuz-2.6.27-9-generic root=UUID=e1af5d58-4452-45a4-96ce-20445ec59834 ro quiet splash iommu=noaperture
initrd        /boot/initrd.img-2.6.27-9-generic
quiet

title        Ubuntu 8.10, kernel 2.6.27-9-generic (recovery mode)
uuid        e1af5d58-4452-45a4-96ce-20445ec59834
kernel        /boot/vmlinuz-2.6.27-9-generic root=UUID=e1af5d58-4452-45a4-96ce-20445ec59834 ro  single
initrd        /boot/initrd.img-2.6.27-9-generic

title        Ubuntu 8.10, memtest86+
uuid        e1af5d58-4452-45a4-96ce-20445ec59834
kernel        /boot/memtest86+.bin
quiet
Note: Your menu.lst will probably not be identical to the example above.
 
Old 02-01-2009, 09:34 AM   #4
byerlyd
LQ Newbie
 
Registered: Jan 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for the help, I will try it and if I have anymore questions I will let you know.
 
Old 02-01-2009, 03:22 PM   #5
byerlyd
LQ Newbie
 
Registered: Jan 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Okay, I am not sure how to get into the command line, can you help me with what I need to type in to get to the right screen.
 
Old 02-02-2009, 08:52 AM   #6
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285
I know this other thread is messy, but there are numerous potential solutions posed:
http://www.linuxquestions.org/questi...ighlight=IOMMU

Remember that the forum has a search function.
 
Old 02-02-2009, 01:29 PM   #7
vasmakk
Member
 
Registered: Jan 2009
Distribution: Debian Lenny, Ubuntu 9.04
Posts: 87

Rep: Reputation: 16
Quote:
Originally Posted by byerlyd View Post
Okay, I am not sure how to get into the command line, can you help me with what I need to type in to get to the right screen.
I guess you know how to start a Terminal right ?
If not, try from menu: Applications -> Accessories -> Terminal (in Debian) That opens a terminal (console)

then type:

su

( Enter your password)

nano /boot/grub/menu.lst (This loads menu.lst file in the text editor, from where you can edit it)
The lines you want are at the end of this file. Make the changes. (Be very careful. You are changing the boot options! Your comp may not boot if you dont know what you are doing)
Save and Exit. Then reboot.

Vas
 
Old 02-02-2009, 11:54 PM   #8
byerlyd
LQ Newbie
 
Registered: Jan 2009
Posts: 4

Original Poster
Rep: Reputation: 0
I am sorry, I should have told you that I am not able to boot into the OS. It sends me to a text line where I enter my username and password and then I get a line that has my username:$ at the end of it. I am not sure but it might be better to refomat and reload, any thoughts. If you need more information please let me know and I will post all I can.
 
Old 02-03-2009, 12:48 AM   #9
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
You are surely able to load the OS if you say it asks for username and password. It is just going in command line or terminal mode rather than in GUI.
Just type
Code:
sudo vi /boot/grub/menu.lst
where you are and you will be able to edit it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
:high address but no IOMMU error ??? your_shadow03 Linux - Newbie 5 09-30-2008 10:44 AM
PCI-DMA not syncing: high address but no IOMMU joe_merchant Linux - Hardware 4 09-30-2008 06:16 AM


All times are GMT -5. The time now is 06:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration