LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-15-2012, 03:23 PM   #1
anewman
LQ Newbie
 
Registered: Feb 2012
Posts: 2

Rep: Reputation: Disabled
Iomega NAS - Debian Lenny - Cups + Splix IPP printer sharing


I'm using an Iomega NAS which is running Debian Lenny as the firmware, with a Samsung ML-2010 connected via USB. I have successfully enabled terminal use, and apt-get, subsequently installing Cups 1.4.4 and Splix 2.0.0, and setting up the printer using the Splix driver. The NAS had a print server with Samba (not using Cups) but it was tedious to use with it often being a case of printing, then having to reboot the NAS and then it might print the file.

I can access the Cups web interface, and print a test page via that. I have managed to share the printer via Samba with print jobs showing in the Cups interface, although have the same issue of things not printing immediately.

So I'm looking at either: -
  • Making print jobs sent via Samba actually print, instead of getting stuck on "processing".
  • Making IPP work, in the hope this addresses the above issue.

I'm beginning to wonder if this could be a limitation of the hardware rather than a S/W config issue.

Many thanks in advance.
 
Old 02-21-2012, 01:50 PM   #2
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Slackware 14.1 (multilib) with kernel 3.15.5
Posts: 1,536
Blog Entries: 12

Rep: Reputation: 172Reputation: 172
Someone will probably need more details about your situation, eg.
(1) which Iomega NAS,
(2) how exactly you enabled apt-get, as opposed to using ipkg,
(3) whether or not you have serial port access or just ssh
(4) and would you consider testing your hardware with a different OS (ie. Debian 6, ARMEDSlack)
(5) or whether you want to try something less drastic like debootstrap

If you haven't already looked at it you might find http://forum.nas-central.org/viewforum.php?f=41 helpful too.

I doubt it's hardware; there seem to be plenty of success stories with printing on these things.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up IPP printer in CUPS Linux RedHat 4.0 xmdms Linux - Newbie 4 10-31-2009 01:10 PM
CUPS-gutenprint (with Epson printer) not working on Debian Lenny / Mandriva 2009.1 Hartmut Linux - Newbie 2 05-29-2009 08:58 AM
CUPS: share printer with samba/appsocket rather than ipp Meson Linux - Server 0 09-07-2008 05:56 PM
Setting Printer Path in CUPS(IPP) and turbo print gimmee Linux - Networking 3 08-16-2006 08:36 PM
suse 9.1 printing to cups ipp network printer sichen Linux - General 0 08-09-2004 06:30 PM


All times are GMT -5. The time now is 07:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration