LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 05-21-2004, 08:00 PM   #1
freddurgan
LQ Newbie
 
Registered: Jan 2004
Posts: 6

Rep: Reputation: 0
Unhappy "Invalid module format" when I try to install my ATI drivers


I went to /lib/modules/fglrx/build_mod and ran the setup script. It succeeded, so I went to /lib/modules/fglrx and ran the install script, and it failed by saying

FATAL: Error inserting fglrx (/lib/modules/2.6.6/kernel/drivers/char/drm/fglrx.ko): Invalid module format

What does that mean? I'm running X11 6.7 on kernel 2.6.6
 
Old 05-21-2004, 10:37 PM   #2
feend
Member
 
Registered: Nov 2003
Location: williamsburgland
Distribution: Slackware
Posts: 61

Rep: Reputation: 15
Re: "Invalid module format" when I try to install my ATI drivers

Quote:
Originally posted by freddurgan
I went to /lib/modules/fglrx/build_mod and ran the setup script. It succeeded, so I went to /lib/modules/fglrx and ran the install script, and it failed by saying

FATAL: Error inserting fglrx (/lib/modules/2.6.6/kernel/drivers/char/drm/fglrx.ko): Invalid module format

What does that mean? I'm running X11 6.7 on kernel 2.6.6
What distro, & version of fglrx drivers? I think your version of X is more like 4.3.x . The drivers are sensitive to the X version and kernel versions also. Please correct me if I am wrong. You can look at the build errors in the log to help. If you find anything odd post it. You will need to post more info for me to help ya out.
L8tr Feend
 
Old 05-21-2004, 10:49 PM   #3
xanas3712
Member
 
Registered: Apr 2004
Distribution: Slackware/Mandrake/Debian (sarge)
Posts: 266

Rep: Reputation: 30
X11R6.7 = Xorg? Xorg is based on 4.4 rc2 of XFree86 however, I was able to get my ATI drivers to "kind of work" in Xorg (not well though).

Anyhow, if you are running XFree 4.3 you should be able to get it to work, if not and your card is a 9500 or higher you probably will not be able to as I've not heard of someone who has managed to do that.

You may be in the same camp as I am, needing to wait for new drivers.

I do, however, suggest you getting the newest radeon snapshot or r200 snapshot off of http://dri.sourceforge.net and compiling that. It will at least give you a decent driver for use with 2d applications. No 3d, but you'll be able to use MergedFB mode if you are running 2 monitors or something
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Realtek 8180 ,Debian, "Invalid module format" medo Linux - Wireless Networking 0 05-25-2005 07:08 AM
Cedega from Fat32 (Invalid path "." given for "--use-dos-cwd") bdox Linux - Software 0 03-30-2005 11:24 AM
fglrx - "Invalid module format" Carl-Fredrik Linux - Hardware 1 10-29-2004 10:55 AM
"Invalid module format" after FULL kernel recompile RedDwarf Linux - General 6 08-07-2004 07:46 PM
"invalid module format" kinasz Linux - General 2 06-05-2004 03:04 AM


All times are GMT -5. The time now is 08:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration