LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-30-2007, 08:34 PM   #1
apacha
LQ Newbie
 
Registered: May 2007
Location: Guam
Distribution: fedora core 6
Posts: 3

Rep: Reputation: 0
interrupt recovery


Greetings,

I've just installed Fedora Core 6 on my Fujitsu N5000 series Lifebook (Pentium 4 processor). The keyboard is not functioning properly (some of the keys don't work, eg: R, T, F, G, and B) so I'm using a generic USB keyboard as a workaround.

I am experiencing several problems one of which is this: At bootup time this system seems to go through all of the initialization routines the last one being HAL. At this point all I see is a blue screen. I have tried several workarounds. First attempt is to interrupt the initialization and reply "n" to all the prompts. This allows the system to startup X-Window and I'm able to login. To avoid having to go through the interrupt processing at bootup, I have changed the startup parameter in the inittab from 5 to 1. So, now the system boots up in single user mode.

I also tried to bootup on runlevel 3. And ran into more problems. First few attempts, the system did not recognize the interrupt requests but continues with the initialization process. Then comes HAL. I see the following messages on the screen:

Starting HAL daemon: hda: dma_timer_expiry: dma status = 0x24
hda: DMA interrupt recovery
hda: lost interrupt
hda: dma_timer_expiry: dam status = 0x24
hdc: lost interrupt
hda: DMA interrupt recovery
...
And so on.

Can someone suggest what might be my problem.

[Note: Several years ago I installed Red Hat Linux 9 and I can still boot that system up with no apparent problem.]

Last edited by apacha; 05-30-2007 at 08:42 PM.
 
Old 05-30-2007, 09:01 PM   #2
jtshaw
Senior Member
 
Registered: Nov 2000
Location: Seattle, WA USA
Distribution: Ubuntu @ Home, RHEL @ Work
Posts: 3,892
Blog Entries: 1

Rep: Reputation: 67
Try adding acpi=off to your kernel boot parameters and see if that helps. This was a widely reported problem early in the days of 2.6 kernels if memory serves.
 
Old 05-31-2007, 03:51 PM   #3
apacha
LQ Newbie
 
Registered: May 2007
Location: Guam
Distribution: fedora core 6
Posts: 3

Original Poster
Rep: Reputation: 0
Angry

I appended the "acpi=off" to the "kernel /vmlinuz-2.6.18-1.2798.fc6 ro root=/dev/VolGroup00/LogVol00 rhgb quiet" line in the /etc/grub.conf. Rebooted to run level 2 and now I get the following message: "unknown bus type 2." [The same message is repeated over and over.]

John
 
Old 05-31-2007, 04:53 PM   #4
apacha
LQ Newbie
 
Registered: May 2007
Location: Guam
Distribution: fedora core 6
Posts: 3

Original Poster
Rep: Reputation: 0
I was able to do more searches on this problem and ran across i586 vs. i686 issues. I decided to run modprobe as follows.

#modprobe acpi-cpufreq
FATAL: Error inserting acpi_cpufreq (/lib/modules/2.6.18-1.2798.fc6/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko): No such device

I didn't notice this error message during the boot process. I'm not sure how to address this problem. Do I need to use a different kernel? If so, how would I go about doing it?

Following is the uname -all report:
#uname --all
Linux fanihi 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:37:32 EDT 2006 i686 i686 i386 GNU/Linux

[I have a Fujitsu N5000 Notebook series, Pentium 4 Processor. I don't remember how to get that info from fedora but from Windows/XP I have this info: Processor Type: x86 Family 15 Model 2 Stepping 9, Processor Vendor: GenuineIntel, Number of Processors: 2, Physical Memory: 510 MB]

John
 
Old 06-01-2007, 02:32 PM   #5
jtshaw
Senior Member
 
Registered: Nov 2000
Location: Seattle, WA USA
Distribution: Ubuntu @ Home, RHEL @ Work
Posts: 3,892
Blog Entries: 1

Rep: Reputation: 67
You can't load any of the acpi modules if you have acpi=off as a kernel parameter... If everything else appears to be working you might want to consider trying to use apm instead of acpi.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Linux Data Recovery on Windows - Is possible through Disk Doctors Linux Recovery Software LXer Syndicated Linux News 0 10-22-2006 12:21 PM
control is not going to interrupt handler when interrupt comes in serial driver sateeshalla Linux - Kernel 1 05-04-2006 09:43 AM
<0>Kernel panic: Aiee, killing interrupt handler! In interrupt handler - not syncing mrb Linux - Newbie 2 01-09-2005 09:47 AM
about interrupt dummyagain Programming 0 10-26-2003 02:09 AM
interrupt??? raven Linux - Hardware 1 06-10-2002 06:57 AM


All times are GMT -5. The time now is 11:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration