LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-28-2003, 11:14 AM   #1
VictorN
LQ Newbie
 
Registered: Aug 2003
Posts: 4

Rep: Reputation: 0
Internet via IP, but not via URL?


Good Morning,

I have been struggling to give my new RH9 PC access to the Internet. Iíve spent a lot of time searching and reading posts on this site and thanks to that Iíve come quite a way. But still have one final hurdle that I canít seem to overcome: I can access websites if I use the IP address, but not if I use the URL.

Hereís my setup. I have a Verizon DSL line coming into a DSL modem. That modem is attached to a Linksys DSL router. The router is configured to handle the PPPoE password, etc. Connected to the router are two PCs: and old NT4.0 PC and the RH9 PC. The NT machine accesses the Internet just fine so I know I the router and modem are fine. I can also ping the router and access the routerís configuration page from the RH9 box. Finally, as I mentioned above, I can access Internet websites from the RH box if I use the IP address, but not if I use the URL. When I try to use a URL I get a "Could not find blablabla" message.

So that made me think I have some DNS setting wrong. I checked my NT box to see what DNS settings I have and there are none. The Verizon documentation does not mention any DNS settings. So I did a WhoIs search and found the Name Server IP addresses for the two BellAtlantic Name Servers. I added those and still URLís donít work.

I bet there is something obvious I am missing, but being a newbie, it isnít so obvious to me.

One other thing. After I logon to the RH9 box I get the following error message:

Could not look up internet address for localhost. This will prevent GNOME from operation correctly. It may be possible to correct the problem by adding localhost to the file /etc/hosts.

Iím not sure whether that is significant or not. Iím sure that message is a fairly new one, so in my effort to get online I probably tweaked something the wrong way.

Thanks,
Victor
 
Old 08-28-2003, 11:29 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
You'll need to put your ISP's DNS entries in /etc/resolv.conf file. If you don't know them, ask your ISP for them.

Usually in this type of format for the file:

search isp.domain.com
nameserver <isp's dns ip number1>
nameserver <isp's dns ip number2>
 
Old 08-28-2003, 11:33 AM   #3
glj
Member
 
Registered: Jul 2001
Location: London
Distribution: RH 9
Posts: 151

Rep: Reputation: 30
Does the /etc/hosts file still exist?
localhost is the basic entry that even MS installations have in their hosts file. Try opening the file and seeing whats there. If there isn't a file create one and add the line
127.0.0.1 localhost

that should cure GNOME error. As far as the internet errors go are you sure the correct nameservers are inputted into your Linux box? I'm not the expert here so this post will probably result in 20 posts correcting mine, but here goes anyway!

You'll need to know the IP addresses of you DNS servers. When you have them, stick them in a file /etc/resolv.conf (I think) like this

nameserver 1.2.3.4

where 1.2.3.4 is the IP of the dns server. Add as many lines like this as you like.
To get the IP addresses go to your NT box, and in command promp type "ipconfig /all" and the IP addresses should be there somewhere (I think that command was included in the NT distribution of Windows).
I really hope that's ok, and that I haven't mislead you

glj
 
Old 08-28-2003, 09:15 PM   #4
VictorN
LQ Newbie
 
Registered: Aug 2003
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for your responses.

The changes suggested to /etc/hosts did make the error message go away, but I still can not get to the internet using a URL.

This is what I have in /etc/resolv.conf

; generated by /sbin/dhclient-script
search
nameserver 199.45.32.40
nameserver 199.45.32.41

Is this correct, or do I need to tweak this some.

Thanks,
Victor
 
Old 08-29-2003, 08:22 AM   #5
VictorN
LQ Newbie
 
Registered: Aug 2003
Posts: 4

Original Poster
Rep: Reputation: 0
Should resolv.conf read

; generated by /sbin/dhclient-script
search www.bellatlantic.net
nameserver 199.45.32.40
nameserver 199.45.32.41

Does adding the bellatlantic.net make a difference?
 
Old 08-29-2003, 08:41 AM   #6
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
First of all there's gotta be a DNS server setting on the NT box, do a "ipconfig /all" in command prompt and check for DNS servers(usually it points at the local ip of your router because they're capable of forwarding DNS queries)
if all fails, you might want to try installing named with caching-nameserver configuration and point the nameserver to yourself, you can't go wrong this way.
If you decide to do that make sure you configure your firewall properly so that it allows yourself to acces port 53.

Last edited by Demonbane; 08-29-2003 at 08:43 AM.
 
Old 08-29-2003, 08:44 AM   #7
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
The Red Hat firewall has been known to cause this exact problem. If it's on turn it off and try again.

as root do

iptables --list

if there is any output other than three empty table row headings then it's on, especially of you see the word Lokkit in there.
 
Old 08-30-2003, 01:09 PM   #8
VictorN
LQ Newbie
 
Registered: Aug 2003
Posts: 4

Original Poster
Rep: Reputation: 0
Looking_lost

Yes, that was it. I turned the firewall off and I can now access the Internet.

Thank you very much!
Victor
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
change url wooot Linux - Networking 6 08-08-2005 09:08 PM
ERROR The requested URL could not be retrieved While trying to retrieve the URL: /re Niceman2005 Linux - General 1 06-29-2005 10:51 AM
open a url in c++ bertlef Programming 2 01-07-2005 05:27 PM
Internet connection sharing (how-to url) NoBrains Linux - Networking 0 02-27-2004 08:49 PM
Url MikeeX General 3 07-20-2002 12:12 AM


All times are GMT -5. The time now is 08:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration